summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrenton Horne2019-03-23 22:26:07 +1000
committerBrenton Horne2019-03-23 22:26:07 +1000
commite4cb225c37ddf3ef8a960ec250cfdcaaf8d9bf3f (patch)
tree1dfaf8ebbd0b9f4fda4aa86f972c7079cd0b5844
downloadaur-e4cb225c37ddf3ef8a960ec250cfdcaaf8d9bf3f.tar.gz
Initial commit
-rw-r--r--.SRCINFO36
-rw-r--r--.gitignore5
-rwxr-xr-xPKGBUILD63
-rwxr-xr-xopenra-ca19
-rwxr-xr-xopenra-ca.appdata.xml40
-rwxr-xr-xopenra-ca.desktop11
-rwxr-xr-xopenra-ca.install18
7 files changed, 192 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6e8c905f4851
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,36 @@
+pkgbase = openra-ca-git
+ pkgdesc = A mod of OpenRA that combines units from Red Alert and Tiberian Dawn mods
+ pkgver = 96.git.fc3cf0b
+ pkgrel = 1
+ url = https://www.openra.net
+ install = openra-ca.install
+ arch = any
+ license = GPL3
+ makedepends = dos2unix
+ makedepends = git
+ makedepends = unzip
+ depends = mono
+ depends = ttf-dejavu
+ depends = openal
+ depends = libgl
+ depends = freetype2
+ depends = sdl2
+ depends = lua51
+ depends = hicolor-icon-theme
+ depends = gtk-update-icon-cache
+ depends = desktop-file-utils
+ depends = xdg-utils
+ depends = zenity
+ provides = openra-ca
+ options = !strip
+ source = git+https://github.com/Inq8/CAmod.git
+ source = openra-ca
+ source = openra-ca.appdata.xml
+ source = openra-ca.desktop
+ md5sums = SKIP
+ md5sums = bdab27df863114bb7447839b9a75c0cf
+ md5sums = 1fcf493eabd3fbd6d0ccd387ecc446e6
+ md5sums = fede5894ebe787ad39d8bdaac2efdc56
+
+pkgname = openra-ca-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..914dc12797ca
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*.xz
+CAmod
+pkg
+src
+*.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..76d9408ee60b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,63 @@
+pkgname=openra-ca-git
+_pkgname=openra-ca
+pkgver=96.git.fc3cf0b
+pkgrel=1
+pkgdesc="A mod of OpenRA that combines units from Red Alert and Tiberian Dawn mods"
+arch=('any')
+url="https://www.openra.net"
+license=('GPL3')
+install=openra-ca.install
+depends=('mono' 'ttf-dejavu' 'openal' 'libgl' 'freetype2' 'sdl2' 'lua51' 'hicolor-icon-theme' 'gtk-update-icon-cache'
+ 'desktop-file-utils' 'xdg-utils' 'zenity')
+makedepends=('dos2unix' 'git' 'unzip')
+provides=('openra-ca')
+options=(!strip)
+source=("git+https://github.com/Inq8/CAmod.git"
+"openra-ca"
+"openra-ca.appdata.xml"
+"openra-ca.desktop")
+md5sums=('SKIP'
+ 'bdab27df863114bb7447839b9a75c0cf'
+ '1fcf493eabd3fbd6d0ccd387ecc446e6'
+ 'fede5894ebe787ad39d8bdaac2efdc56')
+
+pkgver() {
+ cd $srcdir/CAmod
+ no=$(git rev-list --count HEAD)
+ hash=$(git log | head -n 1 | cut -d ' ' -f 2 | head -c 7)
+ printf "${no}.git.${hash}"
+}
+
+prepare() {
+ cd $srcdir/CAmod
+ dos2unix *.md
+ make version VERSION="Master commit ${pkgver}"
+}
+
+build() {
+ cd $srcdir/CAmod
+ make
+}
+
+package() {
+ cd $srcdir/CAmod
+ mkdir -p $pkgdir/usr/{lib/openra-ca/mods,bin,share/pixmaps,share/doc/packages/openra-ca,share/applications,share/appdata}
+ install -dm775 $pkgdir/var/games/openra-ca
+ cp -r engine/{glsl,lua,AUTHORS,COPYING,Eluant.dll*,FuzzyLogicLibrary.dll,GeoLite2-Country.mmdb.gz,'global mix database.dat',ICSharpCode.SharpZipLib.dll,launch-dedicated.sh,launch-game.sh,MaxMind.Db.dll,OpenAL-CS.dll,OpenAL-CS.dll.config,Open.Nat.dll,OpenRA.Game.exe,OpenRA.Platforms.Default.dll,OpenRA.Server.exe,OpenRA.Utility.exe,rix0rrr.BeaconLib.dll,SDL2-CS.dll,SDL2-CS.dll.config,SharpFont.dll,SharpFont.dll.config,VERSION} $pkgdir/usr/lib/openra-ca
+ cp -r mods/ca $pkgdir/usr/lib/openra-ca/mods
+ cp -r engine/mods/{common,modcontent} $pkgdir/usr/lib/openra-ca/mods
+ install -Dm755 $srcdir/openra-ca $pkgdir/usr/bin/openra-ca
+ cp -r $srcdir/openra-ca.appdata.xml $pkgdir/usr/share/appdata/openra-ca.appdata.xml
+ cp -r README.md $pkgdir/usr/share/doc/packages/openra-ca/README.md
+ cp -r mods/ca/icon.png $pkgdir/usr/share/pixmaps/openra-ca.png
+
+ for i in 16x16 32x32 48x48 64x64 128x128 256x256
+ do
+ install -Dm644 packaging/linux/mod_${i}.png $pkgdir/usr/share/icons/hicolor/$i/apps/%{name}.png
+ done
+
+ install -Dm644 $srcdir/openra-ca.desktop $pkgdir/usr/share/applications/openra-ca.desktop
+ rm $pkgdir/usr/lib/openra-ca/*.sh
+}
+
+
diff --git a/openra-ca b/openra-ca
new file mode 100755
index 000000000000..d147da754f52
--- /dev/null
+++ b/openra-ca
@@ -0,0 +1,19 @@
+#!/bin/sh
+cd "/usr/lib/openra-ca"
+
+# Run the game
+mono --debug OpenRA.Game.exe Game.Mod=ca Engine.LaunchPath="/usr/bin/openra-ca" "Engine.ModSearchPaths=/usr/lib/openra-ca/mods" "$@"
+
+# Show a crash dialog if something went wrong
+if [ $? != 0 ] && [ $? != 1 ]; then
+ ERROR_MESSAGE="Combined Arms has encountered a fatal error.\nPlease refer to the crash logs and FAQ for more information.\n\nLog files are located in ~/.openra/Logs\nThe FAQ is available at http://wiki.openra.net/FAQ"
+ if command -v zenity > /dev/null; then
+ zenity --no-wrap --error --title "Combined Arms" --text "${ERROR_MESSAGE}" 2> /dev/null
+ elif command -v kdialog > /dev/null; then
+ kdialog --title "Combined Arms" --error "${ERROR_MESSAGE}"
+ else
+ printf "${ERROR_MESSAGE}\n"
+ fi
+ exit 1
+fi
+
diff --git a/openra-ca.appdata.xml b/openra-ca.appdata.xml
new file mode 100755
index 000000000000..8a9a52abbbff
--- /dev/null
+++ b/openra-ca.appdata.xml
@@ -0,0 +1,40 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<component type="desktop">
+ <id>openra-ca.desktop</id>
+ <metadata_license>CC0-1.0</metadata_license>
+ <project_license>GPL-3.0</project_license>
+ <name>OpenRA - Combined Arms</name>
+ <summary>An open-source game that combines units from Command &amp; Conquer (CNC) and CNC: Red Alert.</summary>
+ <description>
+ <p>
+ OpenRA Combined Arms is a project that combines units from the Red Alert and Tiberian Dawn mods of the OpenRA game.
+ </p>
+ <p>
+ This game requires additional game assets, with the essential ones being freely downloadable, but they are still subject to copyright.
+ </p>
+ </description>
+ <url type="homepage">https://github.com/Inq8/CAmod</url>
+ <update_contact>https://github.com/Inq8</update_contact>
+ <content_rating type="oars-1.0">
+ <content_attribute id="violence-cartoon">none</content_attribute>
+ <content_attribute id="violence-fantasy">none</content_attribute>
+ <content_attribute id="violence-realistic">moderate</content_attribute>
+ <content_attribute id="violence-bloodshed">moderate</content_attribute>
+ <content_attribute id="violence-sexual">none</content_attribute>
+ <content_attribute id="drugs-alcohol">none</content_attribute>
+ content_attribute id="drugs-narcotics">none</content_attribute>
+ <content_attribute id="drugs-tobacco">none</content_attribute>
+ <content_attribute id="sex-nudity">none</content_attribute>
+ <content_attribute id="sex-themes">none</content_attribute>
+ <content_attribute id="language-profanity">mild</content_attribute>
+ <content_attribute id="language-humor">mild</content_attribute>
+ <content_attribute id="language-discrimination">none</content_attribute>
+ <content_attribute id="social-chat">intense</content_attribute>
+ <content_attribute id="social-info">none</content_attribute>
+ <content_attribute id="social-audio">none</content_attribute>
+ <content_attribute id="social-location">none</content_attribute>
+ <content_attribute id="social-contacts">none</content_attribute>
+ <content_attribute id="money-purchasing">none</content_attribute>
+ <content_attribute id="money-gambling">none</content_attribute>
+ </content_rating>
+</component>
diff --git a/openra-ca.desktop b/openra-ca.desktop
new file mode 100755
index 000000000000..7a19cf375d33
--- /dev/null
+++ b/openra-ca.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Type=Application
+Version=1.0
+Name=OpenRA - Combined Arms
+GenericName=Real Time Strategy Game
+GenericName[de]=Echtzeit-Strategiespiel
+Comment=Mod of OpenRA that combines units from the Red Alert and Tiberian Dawn official mods
+Icon=openra-ca
+Exec=openra-ca
+Terminal=false
+Categories=Game;StrategyGame;X-RTS;X-RealTimeStrategy;X-RealTimeStrategyGame;
diff --git a/openra-ca.install b/openra-ca.install
new file mode 100755
index 000000000000..a00383965830
--- /dev/null
+++ b/openra-ca.install
@@ -0,0 +1,18 @@
+post_upgrade() {
+ update-desktop-database -q
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}
+
+post_install() {
+ echo "If the game doesn't run, try using the Cg renderer ~/.openra/settings.yaml like so:"
+ echo "Graphics:"
+ echo " Renderer: Cg"
+ echo "Be careful to only use one indenting tab with 8 shift width."
+ post_upgrade
+}
+
+post_remove() {
+ echo "openra downloaded data files to ~/.openra/Content and you might want"
+ echo "to delete those."
+ post_upgrade
+}