summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrenton Horne2019-03-23 22:43:00 +1000
committerBrenton Horne2019-03-23 22:43:00 +1000
commite90296849b446f1ed37e0a0d1f3bb89bb32862b3 (patch)
tree0279951a29bc42d5581f44cb0b46081132799413
downloadaur-e90296849b446f1ed37e0a0d1f3bb89bb32862b3.tar.gz
Initial commit
-rw-r--r--.SRCINFO36
-rw-r--r--.gitignore5
-rwxr-xr-xPKGBUILD62
-rwxr-xr-xopenra-dr19
-rwxr-xr-xopenra-dr.appdata.xml46
-rwxr-xr-xopenra-dr.desktop11
-rwxr-xr-xopenra-dr.install18
7 files changed, 197 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d05b9e256e2d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,36 @@
+pkgbase = openra-dr-git
+ pkgdesc = A Red Alert-inspired mod of OpenRA
+ pkgver = 324.git.ffcd6ba
+ pkgrel = 1
+ url = https://www.openra.net
+ install = openra-dr.install
+ arch = any
+ license = GPL3
+ makedepends = dos2unix
+ makedepends = git
+ makedepends = unzip
+ depends = mono
+ depends = ttf-dejavu
+ depends = openal
+ depends = libgl
+ depends = freetype2
+ depends = sdl2
+ depends = lua51
+ depends = hicolor-icon-theme
+ depends = gtk-update-icon-cache
+ depends = desktop-file-utils
+ depends = xdg-utils
+ depends = zenity
+ provides = openra-dr
+ options = !strip
+ source = git+https://github.com/drogoganor/DarkReign.git
+ source = openra-dr
+ source = openra-dr.appdata.xml
+ source = openra-dr.desktop
+ md5sums = SKIP
+ md5sums = d58a49e0348ab309c3f6b2e2659cf454
+ md5sums = 331eabdd70606238705a80b1566ea932
+ md5sums = ac393c6822f0f3ed822b102f6cc1e16e
+
+pkgname = openra-dr-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e2c4311099ec
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*.xz
+DarkReign
+pkg
+src
+*.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..7153bfb636bd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,62 @@
+pkgname=openra-dr-git
+_pkgname=openra-dr
+pkgver=324.git.ffcd6ba
+pkgrel=1
+pkgdesc="A Red Alert-inspired mod of OpenRA"
+arch=('any')
+url="https://www.openra.net"
+license=('GPL3')
+install=openra-dr.install
+depends=('mono' 'ttf-dejavu' 'openal' 'libgl' 'freetype2' 'sdl2' 'lua51' 'hicolor-icon-theme' 'gtk-update-icon-cache'
+ 'desktop-file-utils' 'xdg-utils' 'zenity')
+makedepends=('dos2unix' 'git' 'unzip')
+provides=('openra-dr')
+options=(!strip)
+source=("git+https://github.com/drogoganor/DarkReign.git"
+"openra-dr"
+"openra-dr.appdata.xml"
+"openra-dr.desktop")
+md5sums=('SKIP'
+ 'd58a49e0348ab309c3f6b2e2659cf454'
+ '331eabdd70606238705a80b1566ea932'
+ 'ac393c6822f0f3ed822b102f6cc1e16e')
+
+pkgver() {
+ cd $srcdir/DarkReign
+ no=$(git rev-list --count HEAD)
+ hash=$(git log | head -n 1 | cut -d ' ' -f 2 | head -c 7)
+ printf "${no}.git.${hash}"
+}
+
+prepare() {
+ cd $srcdir/DarkReign
+ dos2unix *.md
+ make version VERSION="Master commit ${pkgver}"
+}
+
+build() {
+ cd $srcdir/DarkReign
+ make
+}
+
+package() {
+ cd $srcdir/DarkReign
+ mkdir -p $pkgdir/usr/{lib/openra-dr/mods,bin,share/pixmaps,share/doc/packages/openra-dr,share/applications,share/appdata}
+ install -dm775 $pkgdir/var/games/openra-dr
+ cp -r engine/{glsl,lua,AUTHORS,COPYING,Eluant.dll*,FuzzyLogicLibrary.dll,GeoLite2-Country.mmdb.gz,'global mix database.dat',ICSharpCode.SharpZipLib.dll,launch-dedicated.sh,launch-game.sh,MaxMind.Db.dll,OpenAL-CS.dll,OpenAL-CS.dll.config,Open.Nat.dll,OpenRA.Game.exe,OpenRA.Platforms.Default.dll,OpenRA.Server.exe,OpenRA.Utility.exe,rix0rrr.BeaconLib.dll,SDL2-CS.dll,SDL2-CS.dll.config,SharpFont.dll,SharpFont.dll.config,VERSION} $pkgdir/usr/lib/openra-dr
+ cp -r mods/dr $pkgdir/usr/lib/openra-dr/mods
+ cp -r engine/mods/{common,modcontent} $pkgdir/usr/lib/openra-dr/mods
+ install -Dm755 $srcdir/openra-dr $pkgdir/usr/bin/openra-dr
+ cp -r $srcdir/openra-dr.appdata.xml $pkgdir/usr/share/appdata/openra-dr.appdata.xml
+ cp -r README.md $pkgdir/usr/share/doc/packages/openra-dr/README.md
+ cp -r mods/dr/icon.png $pkgdir/usr/share/pixmaps/openra-dr.png
+ mkdir -p $pkgdir/usr/share/icons/hicolor/{16x16,32x32,48x48,64x64,128x128,256x256}/apps
+ for size in 16 32 48 64 128 256; do
+ size="${size}x${size}"
+ cp packaging/linux/mod_${size}.png "$pkgdir/usr/share/icons/hicolor/${size}/apps/${_pkgname}.png"
+ done
+ install -Dm644 $srcdir/openra-dr.desktop $pkgdir/usr/share/applications/openra-dr.desktop
+ rm $pkgdir/usr/lib/openra-dr/*.sh
+}
+
+
diff --git a/openra-dr b/openra-dr
new file mode 100755
index 000000000000..3ed3ca327849
--- /dev/null
+++ b/openra-dr
@@ -0,0 +1,19 @@
+#!/bin/sh
+cd "/usr/lib/openra-dr"
+
+# Run the game
+mono --debug OpenRA.Game.exe Game.Mod=dr Engine.LaunchPath="/usr/bin/openra-dr" "Engine.ModSearchPaths=/usr/lib/openra-dr/mods" "$@"
+
+# Show a crash dialog if something went wrong
+if [ $? != 0 ] && [ $? != 1 ]; then
+ ERROR_MESSAGE="Dark Reign has encountered a fatal error.\nPlease refer to the crash logs and FAQ for more information.\n\nLog files are located in ~/.openra/Logs\nThe FAQ is available at http://wiki.openra.net/FAQ"
+ if command -v zenity > /dev/null; then
+ zenity --no-wrap --error --title "Dark Reign" --text "${ERROR_MESSAGE}" 2> /dev/null
+ elif command -v kdialog > /dev/null; then
+ kdialog --title "Dark Reign" --error "${ERROR_MESSAGE}"
+ else
+ printf "${ERROR_MESSAGE}\n"
+ fi
+ exit 1
+fi
+
diff --git a/openra-dr.appdata.xml b/openra-dr.appdata.xml
new file mode 100755
index 000000000000..049e272355e2
--- /dev/null
+++ b/openra-dr.appdata.xml
@@ -0,0 +1,46 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<component type="desktop">
+ <id>openra-dr.desktop</id>
+ <metadata_license>CC0-1.0</metadata_license>
+ <project_license>GPL-3.0</project_license>
+ <name>OpenRA - Dark Reign</name>
+ <summary>An open-source remake of the original Dark Reign: The Future of War game</summary>
+ <description>
+ <p>
+ OpenRA Dark Reign is a project that recreates and modernizes the classic Dark Reign: The Future of War real time strategy game.
+ </p>
+ <p>
+ OpenRA Dark Reign: The Future of War is free in itself, and there are free demo assets available for it. In order to use all the game's features, however, you will need to have assets from the original game, which are not free.
+ </p>
+ </description>
+ <screenshots>
+ <screenshot>
+ <image>https://fusion809.github.io/images/Games/OpenRA-DarkReign-commit-100-20180513.png</image>
+ <caption>Dark Reign OpenRA Mod</caption>
+ </screenshot>
+ </screenshots>
+ <url type="homepage">https://github.com/drogoganor/DarkReign</url>
+ <update_contact>https://github.com/drogoganor</update_contact>
+ <content_rating type="oars-1.0">
+ <content_attribute id="violence-cartoon">none</content_attribute>
+ <content_attribute id="violence-fantasy">none</content_attribute>
+ <content_attribute id="violence-realistic">moderate</content_attribute>
+ <content_attribute id="violence-bloodshed">moderate</content_attribute>
+ <content_attribute id="violence-sexual">none</content_attribute>
+ <content_attribute id="drugs-alcohol">none</content_attribute>
+ <content_attribute id="drugs-narcotics">none</content_attribute>
+ <content_attribute id="drugs-tobacco">none</content_attribute>
+ <content_attribute id="sex-nudity">none</content_attribute>
+ <content_attribute id="sex-themes">none</content_attribute>
+ <content_attribute id="language-profanity">mild</content_attribute>
+ <content_attribute id="language-humor">mild</content_attribute>
+ <content_attribute id="language-discrimination">none</content_attribute>
+ <content_attribute id="social-chat">intense</content_attribute>
+ <content_attribute id="social-info">none</content_attribute>
+ <content_attribute id="social-audio">none</content_attribute>
+ <content_attribute id="social-location">none</content_attribute>
+ <content_attribute id="social-contacts">none</content_attribute>
+ <content_attribute id="money-purchasing">none</content_attribute>
+ <content_attribute id="money-gambling">none</content_attribute>
+ </content_rating>
+</component>
diff --git a/openra-dr.desktop b/openra-dr.desktop
new file mode 100755
index 000000000000..88ffd4cedf21
--- /dev/null
+++ b/openra-dr.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Type=Application
+Version=1.0
+Name=OpenRA - Dark Reign
+GenericName=Real Time Strategy Game
+GenericName[de]=Echtzeit-Strategiespiel
+Comment=Reimagining of the Dark Reign: The Future of War game
+Icon=openra-dr
+Exec=openra-dr
+Terminal=false
+Categories=Game;StrategyGame;X-RTS;X-RealTimeStrategy;X-RealTimeStrategyGame;
diff --git a/openra-dr.install b/openra-dr.install
new file mode 100755
index 000000000000..a00383965830
--- /dev/null
+++ b/openra-dr.install
@@ -0,0 +1,18 @@
+post_upgrade() {
+ update-desktop-database -q
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}
+
+post_install() {
+ echo "If the game doesn't run, try using the Cg renderer ~/.openra/settings.yaml like so:"
+ echo "Graphics:"
+ echo " Renderer: Cg"
+ echo "Be careful to only use one indenting tab with 8 shift width."
+ post_upgrade
+}
+
+post_remove() {
+ echo "openra downloaded data files to ~/.openra/Content and you might want"
+ echo "to delete those."
+ post_upgrade
+}