summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrenton Horne2019-03-23 23:59:50 +1000
committerBrenton Horne2019-03-23 23:59:50 +1000
commitdb02bed78abe7ed92bc4ce710c0a5248f5968429 (patch)
tree5b3794f83166e9e31416a57444a7543cc492d254
parent253c7132c632d0c2e579a195e35117a2a68e3ae2 (diff)
downloadaur-db02bed78abe7ed92bc4ce710c0a5248f5968429.tar.gz
Adding message for if make fails
-rwxr-xr-xPKGBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a512b203adaf..55696ddfb3da 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,7 @@
# Maintainer: Brenton Horne <brentonhorne77@gmail.com>
+
pkgname=openra-gen-git
-_pkgname=openra-gen
+_pkgname=${pkgname/-git}
pkgver=1160.git.e448241
pkgrel=1
pkgdesc="A Command & Conquer: Generals-inspired mod of OpenRA"
@@ -37,7 +38,9 @@ prepare() {
build() {
cd $srcdir/Generals-Alpha
- make
+ make || (printf "make failed; please do not complain at the AUR about this, as this is an upstream issue.\n" && \
+ printf "So report this at ${url}/issues/new, after checking\n" && \
+ printf "for existing issues.\n")
}
package() {