summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEden Rose2017-09-09 01:41:22 -0400
committerEden Rose2017-09-09 01:41:22 -0400
commit23ff52f1b851fa8b9a3c9c351a68ab7768f9d14e (patch)
tree33d093f5904a2afba588a758e79020a964fd10c5
parent6cbd92a5a83ba9d828d7614faa9c5b679e0a3af8 (diff)
downloadaur-23ff52f1b851fa8b9a3c9c351a68ab7768f9d14e.tar.gz
Fixed RA2 so that its functioning.
-rw-r--r--.SRCINFO4
-rwxr-xr-xPKGBUILD47
-rw-r--r--RA2-mod.config.patch12
3 files changed, 45 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ae3bf699e370..e3cd9143cecf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = openra-git
pkgdesc = An open-source implementation of the Red Alert engine using .NET/Mono and OpenGL. DuneII and Red Alert 2, mods Included. -GIT VERSION
- pkgver = BLEED.20170815.944dfeb47
+ pkgver = BLEED.20170909.43664a12b
pkgrel = 1
url = http://www.openra.net
install = openra.install
@@ -26,9 +26,11 @@ pkgbase = openra-git
source = OpenRA::git://github.com/OpenRA/OpenRA.git#branch=bleed
source = RA2::git://github.com/OpenRA/ra2.git
source = D2::git://github.com/OpenRA/d2.git
+ source = RA2-mod.config.patch
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
+ md5sums = 17da3f549c51bc2d25840167cd79bbbc
pkgname = openra-git
diff --git a/PKGBUILD b/PKGBUILD
index 7bfbd7420b26..719f57b32dc2 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,10 @@
# $Id$
-# Maintainer: Eden Rose(mnovick1988) <contact through AUR please>
+# Maintainer: Eden Rose(endlesseden) <eenov1988 "at" gmail.com >
# Contributor: Sven-Hendrik Haase <sh@lutzhaase.com>
# Contributor: Matthew Bowra-Dean <matthew@ijw.co.nz>
#
pkgname=openra-git
-pkgver=BLEED.20170815.944dfeb47
+pkgver=BLEED.20170909.43664a12b
pkgrel=1
pkgdesc="An open-source implementation of the Red Alert engine using .NET/Mono and OpenGL. DuneII and Red Alert 2, mods Included. -GIT VERSION"
arch=('any')
@@ -20,10 +20,12 @@ options=(!strip)
source=('OpenRA::git://github.com/OpenRA/OpenRA.git#branch=bleed'
'RA2::git://github.com/OpenRA/ra2.git'
- 'D2::git://github.com/OpenRA/d2.git')
+ 'D2::git://github.com/OpenRA/d2.git'
+ 'RA2-mod.config.patch')
md5sums=('SKIP'
'SKIP'
- 'SKIP')
+ 'SKIP'
+ '17da3f549c51bc2d25840167cd79bbbc')
pkgver() {
@@ -49,6 +51,16 @@ build() {
make test DEBUG=false ### Checking the build, for erroneous yaml files...
make check DEBUG=false ### Checking the build, for StyleCop violations...
#make docs DEBUG=false ### This exists in the Makefile, but is unused? (Make Documentation, mainly aimed at modders)
+ cd ../
+
+ cd RA2
+ if [ -e engine ]; then
+ rm -r engine
+ fi
+ ln -s ../OpenRA engine
+ patch -p1 mod.config < $srcdir/RA2-mod.config.patch
+ make
+
}
package() {
@@ -65,19 +77,20 @@ package() {
mkdir -p $pkgdir/usr/lib/openra/mods/ra2
fi
cp -rf $srcdir/RA2/OpenRA.Mods* $pkgdir/usr/lib/openra/mods/ra2
- cp -rf $srcdir/RA2/mods/ra2/*.yaml $pkgdir/usr/lib/openra/mods/ra2
- cp -rf $srcdir/RA2/mods/ra2/*.png $pkgdir/usr/lib/openra/mods/ra2
- cp -rf $srcdir/RA2/mods/ra2/audio $pkgdir/usr/lib/openra/mods/ra2
- cp -rf $srcdir/RA2/mods/ra2/chrome $pkgdir/usr/lib/openra/mods/ra2
- cp -rf $srcdir/RA2/mods/ra2/bits $pkgdir/usr/lib/openra/mods/ra2
- cp -rf $srcdir/RA2/mods/ra2/installer $pkgdir/usr/lib/openra/mods/ra2
- cp -rf $srcdir/RA2/mods/ra2/languages $pkgdir/usr/lib/openra/mods/ra2
- cp -rf $srcdir/RA2/mods/ra2/maps $pkgdir/usr/lib/openra/mods/ra2
- cp -rf $srcdir/RA2/mods/ra2/rules $pkgdir/usr/lib/openra/mods/ra2
- cp -rf $srcdir/RA2/mods/ra2/sequences $pkgdir/usr/lib/openra/mods/ra2
- cp -rf $srcdir/RA2/mods/ra2/tilesets $pkgdir/usr/lib/openra/mods/ra2
- cp -rf $srcdir/RA2/mods/ra2/uibits $pkgdir/usr/lib/openra/mods/ra2
- cp -rf $srcdir/RA2/mods/ra2/weapons $pkgdir/usr/lib/openra/mods/ra2
+ cp -rf $srcdir/RA2/mods/ra2 $pkgdir/usr/lib/openra/mods/ra2
+ #cp -rf $srcdir/RA2/mods/ra2/*.png $pkgdir/usr/lib/openra/mods/ra2
+
+ #cp -rf $srcdir/RA2/mods/ra2/audio $pkgdir/usr/lib/openra/mods/ra2
+ #cp -rf $srcdir/RA2/mods/ra2/chrome $pkgdir/usr/lib/openra/mods/ra2
+ #cp -rf $srcdir/RA2/mods/ra2/bits $pkgdir/usr/lib/openra/mods/ra2
+ #cp -rf $srcdir/RA2/mods/ra2/installer $pkgdir/usr/lib/openra/mods/ra2
+ #cp -rf $srcdir/RA2/mods/ra2/languages $pkgdir/usr/lib/openra/mods/ra2
+ #cp -rf $srcdir/RA2/mods/ra2/maps $pkgdir/usr/lib/openra/mods/ra2
+ #cp -rf $srcdir/RA2/mods/ra2/rules $pkgdir/usr/lib/openra/mods/ra2
+ #cp -rf $srcdir/RA2/mods/ra2/sequences $pkgdir/usr/lib/openra/mods/ra2
+ #cp -rf $srcdir/RA2/mods/ra2/tilesets $pkgdir/usr/lib/openra/mods/ra2
+ #cp -rf $srcdir/RA2/mods/ra2/uibits $pkgdir/usr/lib/openra/mods/ra2
+ #cp -rf $srcdir/RA2/mods/ra2/weapons $pkgdir/usr/lib/openra/mods/ra2
#########################################################
### adding DuneII to OpenRA
diff --git a/RA2-mod.config.patch b/RA2-mod.config.patch
new file mode 100644
index 000000000000..94069a1e460c
--- /dev/null
+++ b/RA2-mod.config.patch
@@ -0,0 +1,12 @@
+--- mod.config 2017-09-08 22:13:07.274789138 -0400
++++ mod.config.patched 2017-09-08 22:12:52.214584975 -0400
+@@ -4,7 +4,8 @@
+
+ MOD_ID="ra2"
+
+-ENGINE_VERSION="4204ba"
++#ENGINE_VERSION="4204ba"
++ENGINE_VERSION="{DEV_VERSION}"
+
+ INCLUDE_DEFAULT_MODS="False"
+