summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBangL2016-05-27 04:00:20 +0200
committerBangL2016-05-27 04:04:29 +0200
commit2c62e518bee428bc8f6f20370c6157fbc21e8519 (patch)
tree6ee95c7cfcefd5b336494732598a4d4e5eeb0658
downloadaur-2c62e518bee428bc8f6f20370c6157fbc21e8519.tar.gz
init
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD44
-rw-r--r--openra.install18
3 files changed, 92 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f1728f4e36fe
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+pkgbase = openra-kang
+ pkgdesc = An open-source implementation of the Red Alert engine using .NET/Mono and OpenGL
+ pkgver = BLEED.b49f143
+ pkgrel = 1
+ url = http://www.openra.net
+ install = openra.install
+ arch = any
+ license = GPL3
+ makedepends = git
+ makedepends = unzip
+ depends = mono
+ depends = ttf-dejavu
+ depends = openal
+ depends = libgl
+ depends = freetype2
+ depends = sdl2
+ depends = lua51
+ depends = hicolor-icon-theme
+ depends = gtk-update-icon-cache
+ depends = desktop-file-utils
+ depends = xdg-utils
+ depends = zenity
+ provides = openra
+ conflicts = openra
+ options = !strip
+ source = OpenRA::git://github.com/BangL/OpenRA.git#branch=bleed
+ md5sums = SKIP
+
+pkgname = openra-kang
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6c2d1ee63396
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# $Id$
+# Maintainer: BangL <contact through AUR please>
+pkgname=openra-kang
+pkgver=BLEED.b49f143
+pkgrel=1
+pkgdesc="An open-source implementation of the Red Alert engine using .NET/Mono and OpenGL"
+arch=('any')
+url="http://www.openra.net"
+license=('GPL3')
+install=openra.install
+depends=('mono' 'ttf-dejavu' 'openal' 'libgl' 'freetype2' 'sdl2' 'lua51' 'hicolor-icon-theme' 'gtk-update-icon-cache'
+ 'desktop-file-utils' 'xdg-utils' 'zenity')
+makedepends=('git' 'unzip')
+provides=('openra')
+conflicts=('openra')
+options=(!strip)
+
+source=('OpenRA::git://github.com/BangL/OpenRA.git#branch=bleed')
+md5sums=('SKIP')
+
+
+pkgver() {
+ cd "$srcdir/OpenRA"
+
+ PV=$(git name-rev --name-only --tags --no-undefined HEAD 2>/dev/null || echo git-`git rev-parse --short HEAD`)
+ echo $PV | sed 's/git-/BLEED./'
+}
+
+build() {
+ cd OpenRA
+
+ make dependencies
+ make core
+ make tools
+}
+
+package() {
+ cd OpenRA
+
+ make prefix=/usr DESTDIR="$pkgdir" install-all
+ make prefix=/usr DESTDIR="$pkgdir" install-linux-shortcuts
+ make prefix=/usr DESTDIR="$pkgdir" install-linux-mime
+ make prefix=/usr DESTDIR="$pkgdir" install-linux-appdata
+}
diff --git a/openra.install b/openra.install
new file mode 100644
index 000000000000..a00383965830
--- /dev/null
+++ b/openra.install
@@ -0,0 +1,18 @@
+post_upgrade() {
+ update-desktop-database -q
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}
+
+post_install() {
+ echo "If the game doesn't run, try using the Cg renderer ~/.openra/settings.yaml like so:"
+ echo "Graphics:"
+ echo " Renderer: Cg"
+ echo "Be careful to only use one indenting tab with 8 shift width."
+ post_upgrade
+}
+
+post_remove() {
+ echo "openra downloaded data files to ~/.openra/Content and you might want"
+ echo "to delete those."
+ post_upgrade
+}