summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEndlessEden2021-08-22 16:32:08 +1000
committerEndlessEden2021-08-22 16:32:08 +1000
commitee06db33c46f7dadb0f898585171a101a26b1d85 (patch)
treee8c41f6a0cdf5b6eb06834709a2df7e773f6f363
parent23d6ed711c1c830459f326e1ffff7ee792c8f842 (diff)
downloadaur-ee06db33c46f7dadb0f898585171a101a26b1d85.tar.gz
initial fixup, rest needs to be done upstream
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD43
2 files changed, 30 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 95c37e7dac3b..02825cc33713 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = openra-kang
- pkgdesc = An open-source implementation of the Red Alert engine using .NET/Mono and OpenGL
- pkgver = kang.7bbfe86
+ pkgdesc = An open-source implementation of the Red Alert engine using .NET/Mono and OpenGL, Kang Version. (Warning: Upstream Unmaintained since 2017)
+ pkgver = 20210822.g7bbfe86d7kang
pkgrel = 1
- url = http://www.openra.net
+ url = https://github.com/BangL/OpenRA
install = openra.install
arch = any
license = GPL3
@@ -23,7 +23,7 @@ pkgbase = openra-kang
provides = openra
conflicts = openra
options = !strip
- source = OpenRA::git://github.com/BangL/OpenRA.git#branch=bleed
+ source = openra-kang::git+https://github.com/BangL/OpenRA.git#branch=bleed
md5sums = SKIP
pkgname = openra-kang
diff --git a/PKGBUILD b/PKGBUILD
index 7b6d5c81caf5..aa52b7128ef8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
# $Id$
# Maintainer: BangL <contact through AUR please>
pkgname=openra-kang
-pkgver=kang.7bbfe86
+pkgver=20210822.g7bbfe86d7kang
pkgrel=1
-pkgdesc="An open-source implementation of the Red Alert engine using .NET/Mono and OpenGL"
+pkgdesc="An open-source implementation of the Red Alert engine using .NET/Mono and OpenGL, Kang Version. (Warning: Upstream Unmaintained since 2017)"
arch=('any')
-url="http://www.openra.net"
+url="https://github.com/BangL/OpenRA"
license=('GPL3')
install=openra.install
depends=('mono' 'ttf-dejavu' 'openal' 'libgl' 'freetype2' 'sdl2' 'lua51' 'hicolor-icon-theme' 'gtk-update-icon-cache'
@@ -15,31 +15,40 @@ provides=('openra')
conflicts=('openra')
options=(!strip)
-source=('OpenRA::git://github.com/BangL/OpenRA.git#branch=bleed')
+source=("$pkgname"::"git+$url.git#branch=bleed")
md5sums=('SKIP')
pkgver() {
- cd "$srcdir/OpenRA"
+ cd "$srcdir"/"$pkgname"
+
+ DATE="$(date +%Y%m%d)"
+ PV=$(git name-rev --name-only --tags --no-undefined HEAD 2>/dev/null || echo git-`git rev-parse --short HEAD`kang) ### get GIT version
+ echo "$DATE"$PV | sed -e 's/git-/.g/g'
- PV=$(git name-rev --name-only --tags --no-undefined HEAD 2>/dev/null || echo kang.`git rev-parse --short HEAD`)
- echo $PV
}
build() {
- cd OpenRA
+ cd "$srcdir"/"$pkgname"
+
+# make version
+# make dependencies
+# make core
+# make tools
+
+make all DEBUG=false TARGETPLATFORM=unix-generic
- make version
- make dependencies
- make core
- make tools
}
package() {
- cd OpenRA
+ cd "$srcdir"/"$pkgname"
+
+# make prefix=/usr DESTDIR="$pkgdir" install-all
+# make prefix=/usr DESTDIR="$pkgdir" install-linux-shortcuts
+# make prefix=/usr DESTDIR="$pkgdir" install-linux-mime
+# make prefix=/usr DESTDIR="$pkgdir" install-linux-appdata
- make prefix=/usr DESTDIR="$pkgdir" install-all
- make prefix=/usr DESTDIR="$pkgdir" install-linux-shortcuts
- make prefix=/usr DESTDIR="$pkgdir" install-linux-mime
- make prefix=/usr DESTDIR="$pkgdir" install-linux-appdata
+ make prefix=/usr DESTDIR="$pkgdir" install DEBUG=false
+ make prefix=/usr DESTDIR="$pkgdir" install-linux-shortcuts DEBUG=false
+ make prefix=/usr DESTDIR="$pkgdir" install-linux-appdata DEBUG=false
}