summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrenton Horne2020-02-11 10:48:52 +1000
committerBrenton Horne2020-02-11 10:48:52 +1000
commit13d339fe3c8a5d6563ed345629f34c9657ea4c04 (patch)
tree93693b5c34e12dbe7734a5845a3fd9d63f313a75
parentd38050068caf59b7f6e19e075b1a92bac4ada67c (diff)
downloadaur-13d339fe3c8a5d6563ed345629f34c9657ea4c04.tar.gz
Creating a workaround to the GeoLite2 issue
-rw-r--r--.SRCINFO6
-rw-r--r--Makefile.patch19
-rwxr-xr-xPKGBUILD9
-rw-r--r--fetch-engine.patch12
4 files changed, 45 insertions, 1 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 43c5d82abaa3..b088216520ef 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -24,10 +24,16 @@ pkgbase = openra-kknd-git
provides = openra-kknd
options = !strip
source = git+https://github.com/IceReaper/KKnD.git
+ source = local://GeoLite2-Country.mmdb.gz
+ source = fetch-engine.patch
+ source = Makefile.patch
source = openra-kknd
source = openra-kknd.appdata.xml
source = openra-kknd.desktop
md5sums = SKIP
+ md5sums = efb8c043dfa095146f373fec367aef64
+ md5sums = 711019044fbb1c1e3aa5edc58b54343d
+ md5sums = feae017ba5765215cd151a892362e6b1
md5sums = 97e2915c76fed6ddc325652bbc03daa6
md5sums = c5f78612c8da1e25119bd13c14989a14
md5sums = bca1c5bd8363910c329041cafcb784d5
diff --git a/Makefile.patch b/Makefile.patch
new file mode 100644
index 000000000000..8a126fdbd5d8
--- /dev/null
+++ b/Makefile.patch
@@ -0,0 +1,19 @@
+--- Makefile 2020-02-11 10:18:32.479087754 +1000
++++ Makefile 2020-02-11 10:19:53.128498490 +1000
+@@ -314,8 +314,7 @@
+ @ $(CP_R) thirdparty/download/osx/*.dll.config .
+
+ geoip-dependencies:
+- @./thirdparty/fetch-geoip-db.sh
+- @ $(CP) thirdparty/download/GeoLite2-Country.mmdb.gz .
++ @$(CP) ../../GeoLite2-Country.mmdb.gz .
+
+ dependencies: $(os-dependencies)
+
+@@ -512,4 +511,4 @@
+
+ .SUFFIXES:
+
+-.PHONY: core package all mods clean distclean dependencies version $(PROGRAMS) nunit
++.PHONY: core package all mods clean distclean dependencies version $(PROGRAMS) nunit
+\ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index a496530733a2..b0f5751c5b10 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,10 +15,16 @@ makedepends=('dos2unix' 'git' 'unzip')
provides=("${_pkgname}")
options=(!strip)
source=("git+https://github.com/IceReaper/KKnD.git"
+"local://GeoLite2-Country.mmdb.gz"
+"fetch-engine.patch"
+"Makefile.patch"
"${_pkgname}"
"${_pkgname}.appdata.xml"
"${_pkgname}.desktop")
md5sums=('SKIP'
+ 'efb8c043dfa095146f373fec367aef64'
+ '711019044fbb1c1e3aa5edc58b54343d'
+ 'feae017ba5765215cd151a892362e6b1'
'97e2915c76fed6ddc325652bbc03daa6'
'c5f78612c8da1e25119bd13c14989a14'
'bca1c5bd8363910c329041cafcb784d5')
@@ -36,6 +42,7 @@ prepare() {
printf "Success in converting docs...\n"
make version VERSION="${pkgver}"
printf "Success in setting version\n"
+ patch -Np1 -i $srcdir/fetch-engine.patch
}
build() {
@@ -47,7 +54,7 @@ package() {
cd $srcdir/KKnD
mkdir -p $pkgdir/usr/{lib/${_pkgname}/mods,bin,share/pixmaps,share/doc/packages/${_pkgname},share/applications,share/appdata}
install -dm775 $pkgdir/var/games/${_pkgname}
- cp -r engine/{glsl,lua,AUTHORS,COPYING,Eluant.dll*,FuzzyLogicLibrary.dll,GeoLite2-Country.mmdb.gz,'global mix database.dat',ICSharpCode.SharpZipLib.dll,launch-dedicated.sh,launch-game.sh,MaxMind.Db.dll,OpenAL-CS.dll,OpenAL-CS.dll.config,Open.Nat.dll,OpenRA.Game.exe,OpenRA.Platforms.Default.dll,OpenRA.Server.exe,OpenRA.Utility.exe,rix0rrr.BeaconLib.dll,SDL2-CS.dll,SDL2-CS.dll.config,SharpFont.dll,SharpFont.dll.config,VERSION} $pkgdir/usr/lib/${_pkgname}
+ cp -r engine/{glsl,lua,AUTHORS,COPYING,*.dll*,GeoLite2-Country.mmdb.gz,'global mix database.dat',launch-dedicated.sh,launch-game.sh,*.exe,VERSION} $pkgdir/usr/lib/${_pkgname}
cp -r mods/*kknd* $pkgdir/usr/lib/${_pkgname}/mods
cp -r engine/mods/{common,modcontent} $pkgdir/usr/lib/${_pkgname}/mods
install -Dm755 $srcdir/${_pkgname} $pkgdir/usr/bin/${_pkgname}
diff --git a/fetch-engine.patch b/fetch-engine.patch
new file mode 100644
index 000000000000..4f192bc82c42
--- /dev/null
+++ b/fetch-engine.patch
@@ -0,0 +1,12 @@
+diff --git a/fetch-engine.sh b/fetch-engine.sh
+index 1eab9b4..b4dfc0e 100755
+--- a/fetch-engine.sh
++++ b/fetch-engine.sh
+@@ -72,6 +72,7 @@ if [ "${AUTOMATIC_ENGINE_MANAGEMENT}" = "True" ]; then
+
+ echo "Compiling engine..."
+ cd "${ENGINE_DIRECTORY}" || exit 1
++ patch Makefile < ../../Makefile.patch
+ make version VERSION="${ENGINE_VERSION}"
+ exit 0
+ fi \ No newline at end of file