summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrenton Horne2019-03-23 22:19:18 +1000
committerBrenton Horne2019-03-23 22:19:18 +1000
commit79f39fde9d8fc13a33fe9d6e6cd5505bf8e71327 (patch)
tree8d53971873e1a9ca2e0efe909d893a860c65e32d
downloadaur-79f39fde9d8fc13a33fe9d6e6cd5505bf8e71327.tar.gz
Initial commit
-rw-r--r--.SRCINFO36
-rw-r--r--.gitignore5
-rwxr-xr-xPKGBUILD55
-rwxr-xr-xopenra-kknd19
-rwxr-xr-xopenra-kknd.appdata.xml40
-rwxr-xr-xopenra-kknd.desktop11
-rwxr-xr-xopenra-kknd.install13
7 files changed, 179 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bf04378e18ef
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,36 @@
+pkgbase = openra-kknd-git
+ pkgdesc = A Krush, Kill n' Destroy-inspired mod of OpenRA
+ pkgver = 148
+ pkgrel = 1
+ url = https://www.openra.net
+ install = openra-kknd.install
+ arch = any
+ license = GPL3
+ makedepends = dos2unix
+ makedepends = git
+ makedepends = unzip
+ depends = mono
+ depends = ttf-dejavu
+ depends = openal
+ depends = libgl
+ depends = freetype2
+ depends = sdl2
+ depends = lua51
+ depends = hicolor-icon-theme
+ depends = gtk-update-icon-cache
+ depends = desktop-file-utils
+ depends = xdg-utils
+ depends = zenity
+ provides = openra-kknd
+ options = !strip
+ source = git+https://github.com/IceReaper/KKnD.git
+ source = openra-kknd
+ source = openra-kknd.appdata.xml
+ source = openra-kknd.desktop
+ md5sums = SKIP
+ md5sums = 97e2915c76fed6ddc325652bbc03daa6
+ md5sums = c5f78612c8da1e25119bd13c14989a14
+ md5sums = bca1c5bd8363910c329041cafcb784d5
+
+pkgname = openra-kknd-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..a21c033be9ea
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*.xz
+KKnD
+pkg
+src
+*.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..4cbca2783357
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+pkgname=openra-kknd-git
+_pkgname=openra-kknd
+pkgver=148
+pkgrel=1
+pkgdesc="A Krush, Kill n' Destroy-inspired mod of OpenRA"
+arch=('any')
+url="https://www.openra.net"
+license=('GPL3')
+install=${_pkgname}.install
+depends=('mono' 'ttf-dejavu' 'openal' 'libgl' 'freetype2' 'sdl2' 'lua51' 'hicolor-icon-theme' 'gtk-update-icon-cache'
+ 'desktop-file-utils' 'xdg-utils' 'zenity')
+makedepends=('dos2unix' 'git' 'unzip')
+provides=("${_pkgname}")
+options=(!strip)
+source=("git+https://github.com/IceReaper/KKnD.git"
+"${_pkgname}"
+"${_pkgname}.appdata.xml"
+"${_pkgname}.desktop")
+md5sums=('SKIP'
+ '97e2915c76fed6ddc325652bbc03daa6'
+ 'c5f78612c8da1e25119bd13c14989a14'
+ 'bca1c5bd8363910c329041cafcb784d5')
+
+prepare() {
+ cd $srcdir/KKnD
+ dos2unix *.md
+ printf "Success in converting docs...\n"
+ make version VERSION="Master commit ${pkgver}"
+ printf "Success in setting version\n"
+}
+
+build() {
+ cd $srcdir/KKnD
+ make
+}
+
+package() {
+ cd $srcdir/KKnD
+ mkdir -p $pkgdir/usr/{lib/${_pkgname}/mods,bin,share/pixmaps,share/doc/packages/${_pkgname},share/applications,share/appdata}
+ install -dm775 $pkgdir/var/games/${_pkgname}
+ cp -r engine/{glsl,lua,AUTHORS,COPYING,Eluant.dll*,FuzzyLogicLibrary.dll,GeoLite2-Country.mmdb.gz,'global mix database.dat',ICSharpCode.SharpZipLib.dll,launch-dedicated.sh,launch-game.sh,MaxMind.Db.dll,OpenAL-CS.dll,OpenAL-CS.dll.config,Open.Nat.dll,OpenRA.Game.exe,OpenRA.Platforms.Default.dll,OpenRA.Server.exe,OpenRA.Utility.exe,rix0rrr.BeaconLib.dll,SDL2-CS.dll,SDL2-CS.dll.config,SharpFont.dll,SharpFont.dll.config,VERSION} $pkgdir/usr/lib/${_pkgname}
+ cp -r mods/*kknd* $pkgdir/usr/lib/${_pkgname}/mods
+ cp -r engine/mods/{common,modcontent} $pkgdir/usr/lib/${_pkgname}/mods
+ install -Dm755 $srcdir/${_pkgname} $pkgdir/usr/bin/${_pkgname}
+ cp -r $srcdir/${_pkgname}.appdata.xml $pkgdir/usr/share/appdata/${_pkgname}.appdata.xml
+ cp -r README.md $pkgdir/usr/share/doc/packages/${_pkgname}/README.md
+ mkdir -p $pkgdir/usr/share/icons/hicolor/{16x16,32x32,48x48,64x64,128x128,256x256}/apps
+ for size in 16 32 48 64 128 256; do
+ size="${size}x${size}"
+ cp packaging/linux/mod_${size}.png "$pkgdir/usr/share/icons/hicolor/${size}/apps/${_pkgname}.png"
+ done
+ install -Dm644 packaging/linux/mod_256x256.png "$pkgdir/usr/share/pixmaps/${_pkgname}.png"
+ install -Dm644 $srcdir/${_pkgname}.desktop $pkgdir/usr/share/applications/${_pkgname}.desktop
+ rm $pkgdir/usr/lib/${_pkgname}/*.sh
+}
diff --git a/openra-kknd b/openra-kknd
new file mode 100755
index 000000000000..1b39089d93e6
--- /dev/null
+++ b/openra-kknd
@@ -0,0 +1,19 @@
+#!/bin/sh
+cd "/usr/lib/openra-kknd"
+
+# Run the game
+mono --debug OpenRA.Game.exe Game.Mod=kknd Engine.LaunchPath="/usr/bin/openra-kknd" "Engine.ModSearchPaths=/usr/lib/openra-kknd/mods" "$@"
+
+# Show a crash dialog if something went wrong
+if [ $? != 0 ] && [ $? != 1 ]; then
+ ERROR_MESSAGE="OpenRA Krush, Kill n' Destroy has encountered a fatal error.\nPlease refer to the crash logs and FAQ for more information.\n\nLog files are located in ~/.openra/Logs\nThe FAQ is available at http://wiki.openra.net/FAQ"
+ if command -v zenity > /dev/null; then
+ zenity --no-wrap --error --title "OpenRA Krush, Kill n' Destroy" --text "${ERROR_MESSAGE}" 2> /dev/null
+ elif command -v kdialog > /dev/null; then
+ kdialog --title "OpenRA Krush, Kill n' Destroy" --error "${ERROR_MESSAGE}"
+ else
+ printf "${ERROR_MESSAGE}\n"
+ fi
+ exit 1
+fi
+
diff --git a/openra-kknd.appdata.xml b/openra-kknd.appdata.xml
new file mode 100755
index 000000000000..40af9c7a211d
--- /dev/null
+++ b/openra-kknd.appdata.xml
@@ -0,0 +1,40 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<component type="desktop">
+ <id>openra-kknd.desktop</id>
+ <metadata_license>CC0-1.0</metadata_license>
+ <project_license>GPL-3.0</project_license>
+ <name>OpenRA - Krush, Kill n' Destroy</name>
+ <summary>An open-source remake of the original Krush, Kill n' Destroy game</summary>
+ <description>
+ <p>
+ OpenRA Krush, Kill n' Destroy is a project that recreates and modernizes the Krush, Kill n' Destroy real time strategy game, using the open-source OpenRA game engine.
+ </p>
+ <p>
+ OpenRA Krush, Kill n' Destroy is free in itself, but it requires assets from the original Krush, Kill n' Destroy game, which are not free.
+ </p>
+ </description>
+ <url type="homepage">https://github.com/IceReaper/KKnD</url>
+ <update_contact>https://github.com/IceReaper</update_contact>
+ <content_rating type="oars-1.0">
+ <content_attribute id="violence-cartoon">none</content_attribute>
+ <content_attribute id="violence-fantasy">none</content_attribute>
+ <content_attribute id="violence-realistic">moderate</content_attribute>
+ <content_attribute id="violence-bloodshed">moderate</content_attribute>
+ <content_attribute id="violence-sexual">none</content_attribute>
+ <content_attribute id="drugs-alcohol">none</content_attribute>
+ <content_attribute id="drugs-narcotics">none</content_attribute>
+ <content_attribute id="drugs-tobacco">none</content_attribute>
+ <content_attribute id="sex-nudity">none</content_attribute>
+ <content_attribute id="sex-themes">none</content_attribute>
+ <content_attribute id="language-profanity">mild</content_attribute>
+ <content_attribute id="language-humor">mild</content_attribute>
+ <content_attribute id="language-discrimination">none</content_attribute>
+ <content_attribute id="social-chat">intense</content_attribute>
+ <content_attribute id="social-info">none</content_attribute>
+ <content_attribute id="social-audio">none</content_attribute>
+ <content_attribute id="social-location">none</content_attribute>
+ <content_attribute id="social-contacts">none</content_attribute>
+ <content_attribute id="money-purchasing">none</content_attribute>
+ <content_attribute id="money-gambling">none</content_attribute>
+ </content_rating>
+</component>
diff --git a/openra-kknd.desktop b/openra-kknd.desktop
new file mode 100755
index 000000000000..773e1f39db2b
--- /dev/null
+++ b/openra-kknd.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Type=Application
+Version=1.0
+Name=OpenRA - Krush, Kill n' Destroy
+GenericName=Real Time Strategy Game
+GenericName[de]=Echtzeit-Strategiespiel
+Comment=Reimagining of the Krush, Kill n' Destroy game
+Icon=openra-kknd
+Exec=openra-kknd
+Terminal=false
+Categories=Game;StrategyGame;X-RTS;X-RealTimeStrategy;X-RealTimeStrategyGame;
diff --git a/openra-kknd.install b/openra-kknd.install
new file mode 100755
index 000000000000..7c3e4e22316b
--- /dev/null
+++ b/openra-kknd.install
@@ -0,0 +1,13 @@
+post_upgrade() {
+ update-desktop-database -q
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}
+
+post_install() {
+ echo "You will need the original game assets to play this game, see https://github.com/IceReaper/KKnD/wiki for details\n"
+ post_upgrade
+}
+
+post_remove() {
+ post_upgrade
+}