summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrenton Horne2020-05-25 04:41:58 +1000
committerBrenton Horne2020-05-25 04:41:58 +1000
commit9d9fb37b77092f9d60c751be57082835c0a56003 (patch)
tree9d2e9c99656035c04a11b79b765649540f279741
parentb6087ab7be90e1d0019cf342694f77af15c46dac (diff)
downloadaur-9d9fb37b77092f9d60c751be57082835c0a56003.tar.gz
Fixing build and updating
-rw-r--r--.SRCINFO2
-rwxr-xr-xPKGBUILD8
2 files changed, 1 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index daecf5e95678..ce085e68532b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -24,14 +24,12 @@ pkgbase = openra-kknd-git
provides = openra-kknd
options = !strip
source = git+https://github.com/IceReaper/KKnD.git
- source = local://GeoLite2-Country.mmdb.gz
source = fetch-engine.patch
source = Makefile.patch
source = openra-kknd
source = openra-kknd.appdata.xml
source = openra-kknd.desktop
md5sums = SKIP
- md5sums = efb8c043dfa095146f373fec367aef64
md5sums = 711019044fbb1c1e3aa5edc58b54343d
md5sums = feae017ba5765215cd151a892362e6b1
md5sums = 97e2915c76fed6ddc325652bbc03daa6
diff --git a/PKGBUILD b/PKGBUILD
index 3e5384093062..fc61f47a9a37 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,17 +15,12 @@ makedepends=('dos2unix' 'git' 'unzip')
provides=("${_pkgname}")
options=(!strip)
source=("git+https://github.com/IceReaper/KKnD.git"
-# The following file needs to be downloaded manually from
-# Maxmind, see https://dev.maxmind.com/geoip/geoip2/geolite2/
-# for details
-"local://GeoLite2-Country.mmdb.gz"
"fetch-engine.patch"
"Makefile.patch"
"${_pkgname}"
"${_pkgname}.appdata.xml"
"${_pkgname}.desktop")
md5sums=('SKIP'
- 'efb8c043dfa095146f373fec367aef64'
'711019044fbb1c1e3aa5edc58b54343d'
'feae017ba5765215cd151a892362e6b1'
'97e2915c76fed6ddc325652bbc03daa6'
@@ -45,7 +40,6 @@ prepare() {
printf "Success in converting docs...\n"
make version VERSION="${pkgver}"
printf "Success in setting version\n"
- patch -Np1 -i $srcdir/fetch-engine.patch
}
build() {
@@ -57,7 +51,7 @@ package() {
cd $srcdir/KKnD
mkdir -p $pkgdir/usr/{lib/${_pkgname}/mods,bin,share/pixmaps,share/doc/packages/${_pkgname},share/applications,share/appdata}
install -dm775 $pkgdir/var/games/${_pkgname}
- cp -r engine/{glsl,lua,AUTHORS,COPYING,*.dll*,GeoLite2-Country.mmdb.gz,'global mix database.dat',launch-dedicated.sh,launch-game.sh,*.exe,VERSION} $pkgdir/usr/lib/${_pkgname}
+ cp -r engine/{glsl,lua,AUTHORS,COPYING,*.dll*,'global mix database.dat',launch-dedicated.sh,launch-game.sh,*.exe,VERSION} $pkgdir/usr/lib/${_pkgname}
cp -r mods/*kknd* $pkgdir/usr/lib/${_pkgname}/mods
cp -r engine/mods/{common,modcontent} $pkgdir/usr/lib/${_pkgname}/mods
install -Dm755 $srcdir/${_pkgname} $pkgdir/usr/bin/${_pkgname}