summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrenton Horne2020-06-13 04:24:28 +1000
committerBrenton Horne2020-06-13 04:24:28 +1000
commitdda0e7a24d6bfbb0893ca593128b530a24788565 (patch)
tree0fea8945ace417f0e66ec1a0c53c43d2e7ee0643
parent092ed431439e5e5782b3b97a70559bb780d46073 (diff)
downloadaur-dda0e7a24d6bfbb0893ca593128b530a24788565.tar.gz
Rm old unneeded patches
-rw-r--r--.SRCINFO1
-rw-r--r--Makefile.patch19
-rwxr-xr-xPKGBUILD6
-rw-r--r--fetch-engine.patch12
4 files changed, 0 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d9c2b9e0faef..c689c5ed58ea 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -26,7 +26,6 @@ pkgbase = openra-raplus-git
options = !strip
source = git+https://github.com/MlemandPurrs/raplusmod.git
source = openra-raplus
- source = Makefile.patch
source = openra-raplus.appdata.xml
source = openra-raplus.desktop
md5sums = SKIP
diff --git a/Makefile.patch b/Makefile.patch
deleted file mode 100644
index 8a126fdbd5d8..000000000000
--- a/Makefile.patch
+++ /dev/null
@@ -1,19 +0,0 @@
---- Makefile 2020-02-11 10:18:32.479087754 +1000
-+++ Makefile 2020-02-11 10:19:53.128498490 +1000
-@@ -314,8 +314,7 @@
- @ $(CP_R) thirdparty/download/osx/*.dll.config .
-
- geoip-dependencies:
-- @./thirdparty/fetch-geoip-db.sh
-- @ $(CP) thirdparty/download/GeoLite2-Country.mmdb.gz .
-+ @$(CP) ../../GeoLite2-Country.mmdb.gz .
-
- dependencies: $(os-dependencies)
-
-@@ -512,4 +511,4 @@
-
- .SUFFIXES:
-
--.PHONY: core package all mods clean distclean dependencies version $(PROGRAMS) nunit
-+.PHONY: core package all mods clean distclean dependencies version $(PROGRAMS) nunit
-\ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 21b773a0bfa1..74c3b4d244b3 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,12 +15,7 @@ makedepends=('dos2unix' 'git' 'unzip' 'msbuild')
provides=('openra-raplus')
options=(!strip)
source=("git+${url}.git"
-# You have to get the following file from MaxMind, which will require a free account
-# https://dev.maxmind.com/geoip/geoip2/geolite2/
-#"local://GeoLite2-Country.mmdb.gz"
"openra-raplus"
-#"fetch-engine.patch"
-"Makefile.patch"
"openra-raplus.appdata.xml"
"openra-raplus.desktop")
md5sums=('SKIP'
@@ -40,7 +35,6 @@ prepare() {
cd $srcdir/raplusmod
dos2unix *.md
find . -name "*.sh" -exec chmod +x {} \;
-# patch -Np1 -i $srcdir/fetch-engine.patch
printf "Success in converting docs...\n"
}
diff --git a/fetch-engine.patch b/fetch-engine.patch
deleted file mode 100644
index 4f192bc82c42..000000000000
--- a/fetch-engine.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --git a/fetch-engine.sh b/fetch-engine.sh
-index 1eab9b4..b4dfc0e 100755
---- a/fetch-engine.sh
-+++ b/fetch-engine.sh
-@@ -72,6 +72,7 @@ if [ "${AUTOMATIC_ENGINE_MANAGEMENT}" = "True" ]; then
-
- echo "Compiling engine..."
- cd "${ENGINE_DIRECTORY}" || exit 1
-+ patch Makefile < ../../Makefile.patch
- make version VERSION="${ENGINE_VERSION}"
- exit 0
- fi \ No newline at end of file