summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrenton Horne2019-03-23 21:54:01 +1000
committerBrenton Horne2019-03-23 21:54:01 +1000
commit33b3b9526030db61a528e0ab6b1dbab122c0df5d (patch)
tree4f2e26094535a0c27061a48136a53f505072847f
downloadaur-33b3b9526030db61a528e0ab6b1dbab122c0df5d.tar.gz
Initial commit
-rw-r--r--.SRCINFO36
-rw-r--r--.gitignore5
-rwxr-xr-xPKGBUILD64
-rwxr-xr-xopenra-rv19
-rwxr-xr-xopenra-rv.appdata.xml40
-rwxr-xr-xopenra-rv.desktop11
-rwxr-xr-xopenra-rv.install14
7 files changed, 189 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..aa90039b95c7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,36 @@
+pkgbase = openra-rv-git
+ pkgdesc = A Romanov's Vengeance-inspired mod of OpenRA, warning you will need the original Red Alert 2 game (Ultimate Edition) assets to play this game
+ pkgver = 1624.git.7f5be71
+ pkgrel = 1
+ url = https://www.openra.net
+ install = openra-rv.install
+ arch = any
+ license = GPL3
+ makedepends = dos2unix
+ makedepends = git
+ makedepends = unzip
+ depends = mono
+ depends = ttf-dejavu
+ depends = openal
+ depends = libgl
+ depends = freetype2
+ depends = sdl2
+ depends = lua51
+ depends = hicolor-icon-theme
+ depends = gtk-update-icon-cache
+ depends = desktop-file-utils
+ depends = xdg-utils
+ depends = zenity
+ provides = openra-rv
+ options = !strip
+ source = git+https://github.com/MustaphaTR/Romanovs-Vengeance.git
+ source = openra-rv
+ source = openra-rv.appdata.xml
+ source = openra-rv.desktop
+ md5sums = SKIP
+ md5sums = 80198a3797c5f4103536702d15e37f19
+ md5sums = 8bc1150ba694cb3e1a8bcadee4ef75ce
+ md5sums = 98c237db6df1eb777658842765948ea2
+
+pkgname = openra-rv-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..21cf48bba6ca
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*.xz
+Romanovs-Vengeance
+pkg
+src
+*.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..4566cf2b8d4f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,64 @@
+pkgname=openra-rv-git
+_pkgname=openra-rv
+pkgver=1624.git.7f5be71
+pkgrel=1
+pkgdesc="A Romanov's Vengeance-inspired mod of OpenRA, warning you will need the original Red Alert 2 game (Ultimate Edition) assets to play this game"
+arch=('any')
+url="https://www.openra.net"
+license=('GPL3')
+install=openra-rv.install
+depends=('mono' 'ttf-dejavu' 'openal' 'libgl' 'freetype2' 'sdl2' 'lua51' 'hicolor-icon-theme' 'gtk-update-icon-cache'
+ 'desktop-file-utils' 'xdg-utils' 'zenity')
+makedepends=('dos2unix' 'git' 'unzip')
+provides=('openra-rv')
+options=(!strip)
+source=("git+https://github.com/MustaphaTR/Romanovs-Vengeance.git"
+"openra-rv"
+"openra-rv.appdata.xml"
+"openra-rv.desktop")
+md5sums=('SKIP'
+ '80198a3797c5f4103536702d15e37f19'
+ '8bc1150ba694cb3e1a8bcadee4ef75ce'
+ '98c237db6df1eb777658842765948ea2')
+
+pkgver() {
+ cd $srcdir/Romanovs-Vengeance
+ no=$(git rev-list --count HEAD)
+ hash=$(git log | head -n 1 | cut -d ' ' -f 2 | head -c 7)
+ printf "${no}.git.${hash}"
+}
+
+prepare() {
+ cd $srcdir/Romanovs-Vengeance
+ dos2unix *.md
+ printf "Success in converting docs...\n"
+ make version VERSION="Master commit ${pkgver}"
+ printf "Success in setting version\n"
+}
+
+build() {
+ cd $srcdir/Romanovs-Vengeance
+ make || (printf "make failed; please do not complain at the AUR about this, as this is an upstream issue.\n" && \
+ printf "So report this at https://github.com/MustaphaTR/Romanovs-Vengeance/issues/new, after checking\n" && \
+ printf "for existing issues.\n")
+}
+
+package() {
+ cd $srcdir/Romanovs-Vengeance
+ mkdir -p $pkgdir/usr/{lib/openra-rv/mods,bin,share/pixmaps,share/doc/packages/openra-rv,share/applications,share/appdata}
+ install -dm775 $pkgdir/var/games/openra-rv
+ cp -r engine/{glsl,lua,AUTHORS,COPYING,Eluant.dll*,FuzzyLogicLibrary.dll,GeoLite2-Country.mmdb.gz,'global mix database.dat',ICSharpCode.SharpZipLib.dll,launch-dedicated.sh,launch-game.sh,MaxMind.Db.dll,OpenAL-CS.dll,OpenAL-CS.dll.config,Open.Nat.dll,OpenRA.Game.exe,OpenRA.Platforms.Default.dll,OpenRA.Server.exe,OpenRA.Utility.exe,rix0rrr.BeaconLib.dll,SDL2-CS.dll,SDL2-CS.dll.config,SharpFont.dll,SharpFont.dll.config,VERSION} $pkgdir/usr/lib/openra-rv
+ cp -r mods/rv $pkgdir/usr/lib/openra-rv/mods
+ cp -r engine/mods/{as,common,modcontent} $pkgdir/usr/lib/openra-rv/mods
+ install -Dm755 $srcdir/openra-rv $pkgdir/usr/bin/openra-rv
+ cp -r $srcdir/openra-rv.appdata.xml $pkgdir/usr/share/appdata/openra-rv.appdata.xml
+ cp -r README.md $pkgdir/usr/share/doc/packages/openra-rv/README.md
+ cp -r mods/rv/logo.png $pkgdir/usr/share/pixmaps/openra-rv.png
+ install -Dm644 $srcdir/openra-rv.desktop $pkgdir/usr/share/applications/openra-rv.desktop
+ mkdir -p $pkgdir/usr/share/icons/hicolor/{16x16,32x32,48x48,64x64,128x128,256x256}/apps
+ for size in 16 32 48 64 128 256; do
+ size="${size}x${size}"
+ cp packaging/linux/mod_${size}.png "$pkgdir/usr/share/icons/hicolor/${size}/apps/${pkgname}.png"
+ done
+ rm $pkgdir/usr/lib/openra-rv/*.sh
+}
diff --git a/openra-rv b/openra-rv
new file mode 100755
index 000000000000..1943f58bfab8
--- /dev/null
+++ b/openra-rv
@@ -0,0 +1,19 @@
+#!/bin/sh
+cd "/usr/lib/openra-rv"
+
+# Run the game
+mono --debug OpenRA.Game.exe Game.Mod=rv Engine.LaunchPath="/usr/bin/openra-rv" "Engine.ModSearchPaths=/usr/lib/openra-rv/mods" "$@"
+
+# Show a crash dialog if something went wrong
+if [ $? != 0 ] && [ $? != 1 ]; then
+ ERROR_MESSAGE="OpenRA Romanov's Vengeance has encountered a fatal error.\nPlease refer to the crash logs and FAQ for more information.\n\nLog files are located in ~/.openra/Logs\nThe FAQ is available at http://wiki.openra.net/FAQ"
+ if command -v zenity > /dev/null; then
+ zenity --no-wrap --error --title "OpenRA Romanov's Vengeance" --text "${ERROR_MESSAGE}" 2> /dev/null
+ elif command -v kdialog > /dev/null; then
+ kdialog --title "OpenRA Romanov's Vengeance" --error "${ERROR_MESSAGE}"
+ else
+ printf "${ERROR_MESSAGE}\n"
+ fi
+ exit 1
+fi
+
diff --git a/openra-rv.appdata.xml b/openra-rv.appdata.xml
new file mode 100755
index 000000000000..660a16112215
--- /dev/null
+++ b/openra-rv.appdata.xml
@@ -0,0 +1,40 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<component type="desktop">
+ <id>openra-ra2.desktop</id>
+ <metadata_license>CC0-1.0</metadata_license>
+ <project_license>GPL-3.0</project_license>
+ <name>OpenRA - Romanov's Vengeance</name>
+ <summary>An open-source remake of the original Red Alert 2 game</summary>
+ <description>
+ <p>
+ OpenRA Romanov's Vengeance is a project that recreates and modernizes the Red Alert 2 real time strategy game, using the open-source OpenRA game engine.
+ </p>
+ <p>
+ OpenRA Romanov's Vengeance is free in itself, but it requires assets from the original Red Alert 2 game, which are not free.
+ </p>
+ </description>
+ <url type="homepage">https://github.com/MustaphaTR/Romanovs-Vengeance</url>
+ <update_contact>paul_at_chote.net</update_contact>
+ <content_rating type="oars-1.0">
+ <content_attribute id="violence-cartoon">none</content_attribute>
+ <content_attribute id="violence-fantasy">none</content_attribute>
+ <content_attribute id="violence-realistic">moderate</content_attribute>
+ <content_attribute id="violence-bloodshed">moderate</content_attribute>
+ <content_attribute id="violence-sexual">none</content_attribute>
+ <content_attribute id="drugs-alcohol">none</content_attribute>
+ <content_attribute id="drugs-narcotics">none</content_attribute>
+ <content_attribute id="drugs-tobacco">none</content_attribute>
+ <content_attribute id="sex-nudity">none</content_attribute>
+ <content_attribute id="sex-themes">none</content_attribute>
+ <content_attribute id="language-profanity">mild</content_attribute>
+ <content_attribute id="language-humor">mild</content_attribute>
+ <content_attribute id="language-discrimination">none</content_attribute>
+ <content_attribute id="social-chat">intense</content_attribute>
+ <content_attribute id="social-info">none</content_attribute>
+ <content_attribute id="social-audio">none</content_attribute>
+ <content_attribute id="social-location">none</content_attribute>
+ <content_attribute id="social-contacts">none</content_attribute>
+ <content_attribute id="money-purchasing">none</content_attribute>
+ <content_attribute id="money-gambling">none</content_attribute>
+ </content_rating>
+</component>
diff --git a/openra-rv.desktop b/openra-rv.desktop
new file mode 100755
index 000000000000..17912db86d36
--- /dev/null
+++ b/openra-rv.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Type=Application
+Version=1.0
+Name=OpenRA - Romanov's Vengeance
+GenericName=Real Time Strategy Game
+GenericName[de]=Echtzeit-Strategiespiel
+Comment=Reimagining of the Red Alert 2 game
+Icon=openra-rv
+Exec=openra-rv
+Terminal=false
+Categories=Game;StrategyGame;X-RTS;X-RealTimeStrategy;X-RealTimeStrategyGame;
diff --git a/openra-rv.install b/openra-rv.install
new file mode 100755
index 000000000000..7db7b8b139d8
--- /dev/null
+++ b/openra-rv.install
@@ -0,0 +1,14 @@
+post_upgrade() {
+ update-desktop-database -q
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}
+
+post_install() {
+ echo "You will need the original game assets to play this game, see https://github.com/OpenRA/ra2/wiki for details.\n"
+ echo "Beware you will need the expansion game assets, which are only in C&C: Ultimate Edition.\n"
+ post_upgrade
+}
+
+post_remove() {
+ post_upgrade
+}