summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrenton Horne2019-03-23 22:17:32 +1000
committerBrenton Horne2019-03-23 22:17:32 +1000
commitb4108bb12ba95e9c2571d188eeffb92c33a51a4a (patch)
tree5296a96d6c1159d88f60dfd9975373b5cab2a4f5
downloadaur-b4108bb12ba95e9c2571d188eeffb92c33a51a4a.tar.gz
Initial commit
-rw-r--r--.SRCINFO36
-rw-r--r--.gitignore5
-rwxr-xr-xPKGBUILD63
-rwxr-xr-xopenra-sp19
-rwxr-xr-xopenra-sp.appdata.xml37
-rwxr-xr-xopenra-sp.desktop11
-rwxr-xr-xopenra-sp.install18
7 files changed, 189 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9ad51ef7ef9d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,36 @@
+pkgbase = openra-sp-git
+ pkgdesc = A Tiberian Sun-inspired mod of OpenRA
+ pkgver = 206.git.525762a
+ pkgrel = 1
+ url = https://www.openra.net
+ install = openra-sp.install
+ arch = any
+ license = GPL3
+ makedepends = dos2unix
+ makedepends = git
+ makedepends = unzip
+ depends = mono
+ depends = ttf-dejavu
+ depends = openal
+ depends = libgl
+ depends = freetype2
+ depends = sdl2
+ depends = lua51
+ depends = hicolor-icon-theme
+ depends = gtk-update-icon-cache
+ depends = desktop-file-utils
+ depends = xdg-utils
+ depends = zenity
+ provides = openra-sp
+ options = !strip
+ source = git+https://github.com/ABrandau/OpenRAModSDK.git
+ source = openra-sp
+ source = openra-sp.appdata.xml
+ source = openra-sp.desktop
+ md5sums = SKIP
+ md5sums = f1cf30ba15c005526b2bbda106011c13
+ md5sums = 9c765b2e005b0db03d569ccf679f323b
+ md5sums = 451b5a8a2e603e2a140f8844461aff68
+
+pkgname = openra-sp-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..357032a7cf28
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*.xz
+OpenRAModSDK
+pkg
+src
+*.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..3525fb4a75c1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,63 @@
+# Maintainer: Brenton Horne <brentonhorne77 at gmail dot com>
+
+pkgname=openra-sp-git
+_pkgname=openra-sp
+pkgver=206.git.525762a
+pkgrel=1
+pkgdesc="A Tiberian Sun-inspired mod of OpenRA"
+arch=('any')
+url="https://www.openra.net"
+license=('GPL3')
+install=openra-sp.install
+depends=('mono' 'ttf-dejavu' 'openal' 'libgl' 'freetype2' 'sdl2' 'lua51' 'hicolor-icon-theme' 'gtk-update-icon-cache'
+ 'desktop-file-utils' 'xdg-utils' 'zenity')
+makedepends=('dos2unix' 'git' 'unzip')
+provides=('openra-sp')
+options=(!strip)
+source=("git+https://github.com/ABrandau/OpenRAModSDK.git"
+"openra-sp"
+"openra-sp.appdata.xml"
+"openra-sp.desktop")
+md5sums=('SKIP'
+ 'f1cf30ba15c005526b2bbda106011c13'
+ '9c765b2e005b0db03d569ccf679f323b'
+ '451b5a8a2e603e2a140f8844461aff68')
+
+pkgver() {
+ cd $srcdir/OpenRAModSDK
+ no=$(git rev-list --count HEAD)
+ hash=$(git log | head -n 1 | cut -d ' ' -f 2 | head -c 7)
+ printf "${no}.git.${hash}"
+}
+
+prepare() {
+ cd $srcdir/OpenRAModSDK
+ dos2unix *.md
+ chmod +x *.sh
+ make version VERSION="Master commit ${pkgver}"
+}
+
+build() {
+ cd $srcdir/OpenRAModSDK
+ make
+}
+
+package() {
+ cd $srcdir/OpenRAModSDK
+ mkdir -p $pkgdir/usr/{lib/${_pkgname}/mods,bin,share/pixmaps,share/doc/packages/openra-sp,share/applications,share/appdata}
+ install -dm775 $pkgdir/var/games/openra-sp
+ cp -r engine/{glsl,lua,AUTHORS,COPYING,Eluant.dll*,FuzzyLogicLibrary.dll,GeoLite2-Country.mmdb.gz,'global mix database.dat',ICSharpCode.SharpZipLib.dll,launch-dedicated.sh,launch-game.sh,MaxMind.Db.dll,OpenAL-CS.dll,OpenAL-CS.dll.config,Open.Nat.dll,OpenRA.Game.exe,OpenRA.Platforms.Default.dll,OpenRA.Server.exe,OpenRA.Utility.exe,rix0rrr.BeaconLib.dll,SDL2-CS.dll,SDL2-CS.dll.config,SharpFont.dll,SharpFont.dll.config,VERSION} $pkgdir/usr/lib/openra-sp
+ cp -r mods/sp $pkgdir/usr/lib/${_pkgname}/mods
+ cp -r engine/mods/{as,ts,common,modcontent} $pkgdir/usr/lib/${_pkgname}/mods
+ install -Dm755 $srcdir/openra-sp $pkgdir/usr/bin/openra-sp
+ cp -r $srcdir/openra-sp.appdata.xml $pkgdir/usr/share/appdata/openra-sp.appdata.xml
+ cp -r README.md $pkgdir/usr/share/doc/packages/${_pkgname}/README.md
+ ln -sf /usr/lib/${_pkgname}/mods/sp/icon.png ${pkgdir}/usr/share/pixmaps/${_pkgname}.png
+ install -Dm644 $srcdir/openra-sp.desktop $pkgdir/usr/share/applications/openra-sp.desktop
+ mkdir -p $pkgdir/usr/share/icons/hicolor/{16x16,32x32,48x48,64x64,128x128,256x256}/apps
+ for size in 16 32 48 64 128 256; do
+ size="${size}x${size}"
+ cp packaging/linux/mod_${size}.png "$pkgdir/usr/share/icons/hicolor/${size}/apps/${pkgname}.png"
+ done
+ rm $pkgdir/usr/lib/${_pkgname}/*.sh
+}
diff --git a/openra-sp b/openra-sp
new file mode 100755
index 000000000000..27beebac62c1
--- /dev/null
+++ b/openra-sp
@@ -0,0 +1,19 @@
+#!/bin/sh
+cd "/usr/lib/openra-sp"
+
+# Run the game
+mono --debug OpenRA.Game.exe Game.Mod="sp" Engine.LaunchPath="/usr/bin/openra-sp" "Engine.ModSearchPaths=/usr/lib/openra-sp/mods" "$@"
+
+# Show a crash dialog if something went wrong
+if [ $? != 0 ] && [ $? != 1 ]; then
+ ERROR_MESSAGE="OpenRA Shattered Paradise has encountered a fatal error.\nPlease refer to the crash logs and FAQ for more information.\n\nLog files are located in ~/.openra/Logs\nThe FAQ is available at http://wiki.openra.net/FAQ"
+ if command -v zenity > /dev/null; then
+ zenity --no-wrap --error --title "Shattered Paradise" --text "${ERROR_MESSAGE}" 2> /dev/null
+ elif command -v kdialog > /dev/null; then
+ kdialog --title "Shattered Paradise" --error "${ERROR_MESSAGE}"
+ else
+ printf "${ERROR_MESSAGE}\n"
+ fi
+ exit 1
+fi
+
diff --git a/openra-sp.appdata.xml b/openra-sp.appdata.xml
new file mode 100755
index 000000000000..b6499b51f7fe
--- /dev/null
+++ b/openra-sp.appdata.xml
@@ -0,0 +1,37 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<component type="desktop">
+ <id>openra-sp.desktop</id>
+ <metadata_license>CC0-1.0</metadata_license>
+ <project_license>GPL-3.0</project_license>
+ <name>OpenRA - Shattered Paradise</name>
+ <summary>An expansion for the Tiberian Sun mod of OpenRA.</summary>
+ <description>
+ <p>
+Shattered Paradise is an expansion for Tiberian Sun on OpenRA, it's goal is to (im)balance the game by adding new factions (Scrin, Mutants and Cabal) and reworking the original sides, all of this to create a game a little more varied and balanced than TS. The mod puts a lot of emphasis on making the factions as asymmetric as possible.
+ </p>
+ </description>
+ <url type="homepage">https://github.com/ABrandau/Shattered-Paradise</url>
+ <update_contact>paul_at_chote.net</update_contact>
+ <content_rating type="oars-1.0">
+ <content_attribute id="violence-cartoon">none</content_attribute>
+ <content_attribute id="violence-fantasy">none</content_attribute>
+ <content_attribute id="violence-realistic">moderate</content_attribute>
+ <content_attribute id="violence-bloodshed">moderate</content_attribute>
+ <content_attribute id="violence-sexual">none</content_attribute>
+ <content_attribute id="drugs-alcohol">none</content_attribute>
+ <content_attribute id="drugs-narcotics">none</content_attribute>
+ <content_attribute id="drugs-tobacco">none</content_attribute>
+ <content_attribute id="sex-nudity">none</content_attribute>
+ <content_attribute id="sex-themes">none</content_attribute>
+ <content_attribute id="language-profanity">mild</content_attribute>
+ <content_attribute id="language-humor">mild</content_attribute>
+ <content_attribute id="language-discrimination">none</content_attribute>
+ <content_attribute id="social-chat">intense</content_attribute>
+ <content_attribute id="social-info">none</content_attribute>
+ <content_attribute id="social-audio">none</content_attribute>
+ <content_attribute id="social-location">none</content_attribute>
+ <content_attribute id="social-contacts">none</content_attribute>
+ <content_attribute id="money-purchasing">none</content_attribute>
+ <content_attribute id="money-gambling">none</content_attribute>
+ </content_rating>
+</component>
diff --git a/openra-sp.desktop b/openra-sp.desktop
new file mode 100755
index 000000000000..dca212b58178
--- /dev/null
+++ b/openra-sp.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Type=Application
+Version=1.0
+Name=OpenRA - Shattered Paradise
+GenericName=Real Time Strategy Game
+GenericName[de]=Echtzeit-Strategiespiel
+Comment=An expansion for the Tiberian Sun mod of OpenRA
+Icon=openra-sp
+Exec=openra-sp
+Terminal=false
+Categories=Game;StrategyGame;X-RTS;X-RealTimeStrategy;X-RealTimeStrategyGame;
diff --git a/openra-sp.install b/openra-sp.install
new file mode 100755
index 000000000000..a00383965830
--- /dev/null
+++ b/openra-sp.install
@@ -0,0 +1,18 @@
+post_upgrade() {
+ update-desktop-database -q
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}
+
+post_install() {
+ echo "If the game doesn't run, try using the Cg renderer ~/.openra/settings.yaml like so:"
+ echo "Graphics:"
+ echo " Renderer: Cg"
+ echo "Be careful to only use one indenting tab with 8 shift width."
+ post_upgrade
+}
+
+post_remove() {
+ echo "openra downloaded data files to ~/.openra/Content and you might want"
+ echo "to delete those."
+ post_upgrade
+}