summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLW-archlinux2018-03-15 15:31:37 +0100
committerLW-archlinux2018-03-15 15:31:37 +0100
commitd428cd985c5c1cf9e50fac5230bdb74fecac4226 (patch)
tree969d803dfeba7997ed86d26022fe6c5f84299b35
parenta7d70a015a1f6dbcd655e9751b936beda54670e0 (diff)
downloadaur-d428cd985c5c1cf9e50fac5230bdb74fecac4226.tar.gz
added bash-completion functionality, updated to 0.35.5
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD10
2 files changed, 11 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 521fe9a63341..93687865c5d0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = openrc
pkgdesc = Dependency based init system that works with sysvinit.
- pkgver = 0.34.11
- pkgrel = 1
+ pkgver = 0.35.5
+ pkgrel = 2
url = https://github.com/OpenRC/openrc/
arch = i686
arch = x86_64
@@ -12,6 +12,7 @@ pkgbase = openrc
optdepends = openrc-arch-services-git: collection of services for Arch
optdepends = net-tools: for network service support
optdepends = opentmpfiles: adds support for systemd-style tmpfiles.d
+ optdepends = bash-completion: tab completion for openrc commands in bash shells
backup = etc/openrc/inittab
backup = etc/openrc/rc.conf
backup = etc/openrc/conf.d/bootmisc
@@ -28,9 +29,9 @@ pkgbase = openrc
backup = etc/openrc/conf.d/netmount
backup = etc/openrc/conf.d/network
backup = etc/openrc/conf.d/staticroute
- source = openrc-0.34.11::https://github.com/OpenRC/openrc/archive/0.34.11.tar.gz
+ source = openrc-0.35.5::https://github.com/OpenRC/openrc/archive/0.35.5.tar.gz
source = openrc.logrotate
- sha512sums = 76245d31c6fe9e90e5e2f35ce918b915fc88c231674e0c99dc98b8f3fa120e794900eec9919a0ab029a081b206393246eccb9119a79c90ad6e39325d022928be
+ sha512sums = 655a0a32650ed46998ae84473e8a82aadd9de09904c5173cd9b9e2500fc8935e96539672b513a883c077ae862ece12ab768d4f379dbeb4389a7067ce7121dc0d
sha512sums = 690612fddfb2c4cf8f6b5ba7239b9faf29eb3d9b152ab4dcf62694aa2852780440d08cee56d98a9597607f446b3697c911269562821a8402bb5747cbbae34bd9
pkgname = openrc
diff --git a/PKGBUILD b/PKGBUILD
index 79dad79ed73b..62646ac944e5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
# Contributor: Bartłomiej Piotrowski <nospam@bpiotrowski.pl>
pkgname=openrc
-pkgver=0.34.11
-pkgrel=1
+pkgver=0.35.5
+pkgrel=2
pkgdesc='Dependency based init system that works with sysvinit.'
arch=('i686' 'x86_64')
url='https://github.com/OpenRC/openrc/'
@@ -12,7 +12,8 @@ license=('BSD')
depends=('openrc-sysvinit' 'pam' 'sh')
optdepends=('openrc-arch-services-git: collection of services for Arch'
'net-tools: for network service support'
- 'opentmpfiles: adds support for systemd-style tmpfiles.d')
+ 'opentmpfiles: adds support for systemd-style tmpfiles.d'
+ 'bash-completion: tab completion for openrc commands in bash shells')
backup=(etc/openrc/inittab
etc/openrc/rc.conf
etc/openrc/conf.d/{bootmisc,consolefont,devfs,dmesg,fsck,hostname,hwclock,keymaps}
@@ -21,7 +22,7 @@ backup=(etc/openrc/inittab
source=($pkgname-$pkgver::https://github.com/OpenRC/$pkgname/archive/$pkgver.tar.gz
$pkgname.logrotate)
# oldsourcelocation : http://dev.gentoo.org/~williamh/dist/$pkgname-$pkgver.tar.bz2
-sha512sums=('76245d31c6fe9e90e5e2f35ce918b915fc88c231674e0c99dc98b8f3fa120e794900eec9919a0ab029a081b206393246eccb9119a79c90ad6e39325d022928be'
+sha512sums=('655a0a32650ed46998ae84473e8a82aadd9de09904c5173cd9b9e2500fc8935e96539672b513a883c077ae862ece12ab768d4f379dbeb4389a7067ce7121dc0d'
'690612fddfb2c4cf8f6b5ba7239b9faf29eb3d9b152ab4dcf62694aa2852780440d08cee56d98a9597607f446b3697c911269562821a8402bb5747cbbae34bd9')
_makeargs=(BRANDING='Arch Linux')
@@ -36,6 +37,7 @@ _makeargs+=(LIBEXECDIR=/usr/lib/openrc)
_makeargs+=(BINDIR=/usr/bin)
_makeargs+=(SBINDIR=/usr/bin)
_makeargs+=(SYSCONFDIR=/etc/openrc) # avoid conflicts with other init systems
+_makeargs+=(MKBASHCOMP=yes) # enable bash completion for openrc commands
build() {