summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGraham Edgecombe2017-07-12 22:18:23 +0100
committerGraham Edgecombe2017-07-12 22:18:32 +0100
commit34614b281c6cfdf43731c0acc8c1eaa4ca5a1491 (patch)
treec4ac895318e326c92abd807332c7de627a1ab66c
parent3e9b9335503134992946260e6b8d8d453c52a809 (diff)
downloadaur-34614b281c6cfdf43731c0acc8c1eaa4ca5a1491.tar.gz
Update to 0.1.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD13
2 files changed, 14 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ebe1d51a5ed2..8f45f8700efc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Thu May 4 17:20:35 UTC 2017
+# Wed Jul 12 21:18:29 UTC 2017
pkgbase = openrct2
pkgdesc = Open source re-implementation of Roller Coaster Tycoon 2 (requires full copy of the game)
- pkgver = 0.0.7
+ pkgver = 0.1.0
pkgrel = 1
url = https://openrct2.website
install = openrct2.install
@@ -26,8 +26,8 @@ pkgbase = openrct2
optdepends = kdialog: System dialog box support (KDE)
optdepends = alsa-lib: ALSA audio driver
optdepends = libpulse: PulseAudio audio driver
- source = https://github.com/OpenRCT2/OpenRCT2/archive/v0.0.7.tar.gz
- sha256sums = cf35b6e058d675ae8369c9845f9c7c9e4269a1f4a57da91dcdcdcde7e608adac
+ source = https://github.com/OpenRCT2/OpenRCT2/archive/v0.1.0.tar.gz
+ sha256sums = 0347a47d380fc18ea543928c92a13d1bdb4431573154afeb80fa33f1149e6992
pkgname = openrct2
diff --git a/PKGBUILD b/PKGBUILD
index daff56f65d77..dd904c5362cf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Graham Edgecombe <graham@grahamedgecombe.com>
pkgname=openrct2
-pkgver=0.0.7
+pkgver=0.1.0
pkgrel=1
pkgdesc='Open source re-implementation of Roller Coaster Tycoon 2 (requires full
copy of the game)'
@@ -16,17 +16,24 @@ optdepends=('zenity: System dialog box support (GNOME/GTK)'
'libpulse: PulseAudio audio driver')
install=openrct2.install
source=("https://github.com/OpenRCT2/OpenRCT2/archive/v$pkgver.tar.gz")
-sha256sums=('cf35b6e058d675ae8369c9845f9c7c9e4269a1f4a57da91dcdcdcde7e608adac')
+sha256sums=('0347a47d380fc18ea543928c92a13d1bdb4431573154afeb80fa33f1149e6992')
build() {
cd "$srcdir/OpenRCT2-$pkgver"
mkdir -p build
cd build
- cmake -DCMAKE_BUILD_TYPE=RelWithDebInfo -DCMAKE_INSTALL_PREFIX=/usr ..
+ cmake -DCMAKE_BUILD_TYPE=RelWithDebInfo -DCMAKE_INSTALL_PREFIX=/usr \
+ -DWITH_TESTS=on -DDISABLE_RCT2_TESTS=on ..
make all g2
}
+check() {
+ cd "$srcdir/OpenRCT2-$pkgver/build"
+
+ make test
+}
+
package() {
cd "$srcdir/OpenRCT2-$pkgver/build"