summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGraham Edgecombe2015-06-25 20:02:25 +0100
committerGraham Edgecombe2015-06-25 20:02:25 +0100
commitcccffbed77a2cfae95be47ca165a77534f702ace (patch)
tree06720cfd436f5a3bbfea52808f0ca0675734baf8
parent3f5da728e665a06ec488f5c68d2cff803af9c8e0 (diff)
downloadaur-cccffbed77a2cfae95be47ca165a77534f702ace.tar.gz
Use the system's root certificates.
-rw-r--r--PKGBUILD4
1 files changed, 4 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f87f823f70a2..597b972572aa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -33,6 +33,10 @@ package() {
install -d "$pkgdir/usr/share/doc/openrct2"
mv "$pkgdir/usr/share/openrct2/"*.txt "$pkgdir/usr/share/doc/openrct2"
+ # Use root certificates from ArchLinux instead of the ones bundled with
+ # OpenRCT2.
+ ln -sf /etc/ssl/certs/ca-certificates.crt "$pkgdir/usr/share/openrct2/curl-ca-bundle.crt"
+
# ArchLinux-specific stuff (launcher, .desktop file and icon).
install -Dm755 openrct2 "$pkgdir/usr/bin/openrct2"
install -Dm644 openrct2.desktop "$pkgdir/usr/share/applications/openrct2.desktop"