summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRyan Dupke2023-04-01 16:02:47 -0400
committerRyan Dupke2023-04-01 16:02:47 -0400
commit256129ae7524419a62accd7d2d4260fb65b82848 (patch)
tree4a71212af1eac948780fed9c56dc18420da0414e
parent546cbf055ace6e8f720c43ee90cca183e5dc110f (diff)
downloadaur-openrct2-git.tar.gz
Use Ninja for compilation
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD10
2 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 04c3cfbce002..78bf4a1b84fd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = openrct2-git
pkgdesc = Open source re-implementation of Roller Coaster Tycoon 2 (requires full copy of the game)
- pkgver = 0.4.3.r416.g62b0a5edfe
+ pkgver = 0.4.4.r18.g1174063c27
pkgrel = 1
url = https://openrct2.io
install = openrct2.install
@@ -11,6 +11,7 @@ pkgbase = openrct2-git
license = GPL3
makedepends = git
makedepends = cmake
+ makedepends = ninja
makedepends = nlohmann-json
depends = hicolor-icon-theme
depends = sdl2
diff --git a/PKGBUILD b/PKGBUILD
index 20651ff66101..674df18993af 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Ryan Dupke <rctdude2 at gmail dot com>
# Contributor: Graham Edgecombe <graham@grahamedgecombe.com>
pkgname=openrct2-git
-pkgver=0.4.3.r416.g62b0a5edfe
+pkgver=0.4.4.r18.g1174063c27
pkgrel=1
pkgdesc='Open source re-implementation of Roller Coaster Tycoon 2 (requires full
copy of the game)'
@@ -11,7 +11,7 @@ license=('GPL3')
depends=('hicolor-icon-theme' 'sdl2' 'curl' 'speexdsp'
'fontconfig' 'libpng' 'openssl' 'libzip' 'icu' 'benchmark'
'libogg' 'libvorbis' 'flac' 'discord-rpc')
-makedepends=('git' 'cmake' 'nlohmann-json')
+makedepends=('git' 'cmake' 'ninja' 'nlohmann-json')
optdepends=('zenity: System dialog box support (GNOME/GTK)'
'kdialog: System dialog box support (KDE)'
'alsa-lib: ALSA audio driver'
@@ -36,16 +36,16 @@ build() {
# https://github.com/OpenRCT2/OpenRCT2/issues/6200
CXXFLAGS+=" -Wno-error=stringop-overflow"
- cmake -B build -S "$pkgname" \
+ cmake -G Ninja -S "$pkgname" \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX='/usr' \
-DSTATIC=OFF \
-Wno-dev
- cmake --build build -v
+ ninja
}
package() {
- DESTDIR="$pkgdir" cmake --install build
+ DESTDIR="$pkgdir" ninja install
rm "$pkgdir/usr/lib/libopenrct2.a"
rmdir "$pkgdir/usr/lib"