summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGraham Edgecombe2018-10-31 19:02:35 +0000
committerGraham Edgecombe2018-10-31 19:02:35 +0000
commit294b1e6f26d93578125f7282182ae1119cac8b02 (patch)
tree11323babd16b64e7b3dc85cd69afcd30cde81e92
parente629a94e325e6d950277ebd7e0aad300150c36f7 (diff)
downloadaur-294b1e6f26d93578125f7282182ae1119cac8b02.tar.gz
Use the system's rapidjson package instead of downloading it
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD12
2 files changed, 9 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5ce6a3790a56..a5c6d0aa762a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Tue Jun 12 20:28:31 UTC 2018
+# Wed Oct 31 19:02:25 UTC 2018
pkgbase = openrct2-git
pkgdesc = Open source re-implementation of Roller Coaster Tycoon 2 (requires full copy of the game)
- pkgver = r14988.fae367ccf
- pkgrel = 2
+ pkgver = r15600.215ea7edc
+ pkgrel = 1
url = https://openrct2.io
install = openrct2.install
arch = i686
@@ -13,6 +13,7 @@ pkgbase = openrct2-git
license = GPL3
makedepends = git
makedepends = cmake
+ makedepends = rapidjson
depends = hicolor-icon-theme
depends = sdl2
depends = curl
@@ -31,8 +32,6 @@ pkgbase = openrct2-git
conflicts = openrct2
source = openrct2-git::git+https://github.com/OpenRCT2/OpenRCT2.git#branch=develop
source = discord-rpc::git+https://github.com/discordapp/discord-rpc.git
- source = rapidjson::git+https://github.com/janisozaur/rapidjson.git#branch=patch-1
- sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 8acd7daba296..18bb5dc5e27c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Graham Edgecombe <graham@grahamedgecombe.com>
pkgname=openrct2-git
-pkgver=r14988.fae367ccf
-pkgrel=2
+pkgver=r15600.215ea7edc
+pkgrel=1
pkgdesc='Open source re-implementation of Roller Coaster Tycoon 2 (requires full
copy of the game)'
arch=('i686' 'x86_64' 'armv7h' 'aarch64')
@@ -9,7 +9,7 @@ url='https://openrct2.io'
license=('GPL3')
depends=('hicolor-icon-theme' 'sdl2' 'curl' 'jansson' 'speexdsp' 'fontconfig'
'libpng' 'openssl' 'libzip' 'icu')
-makedepends=('git' 'cmake')
+makedepends=('git' 'cmake' 'rapidjson')
optdepends=('zenity: System dialog box support (GNOME/GTK)'
'kdialog: System dialog box support (KDE)'
'alsa-lib: ALSA audio driver'
@@ -18,10 +18,8 @@ conflicts=('openrct2')
provides=('openrct2')
install=openrct2.install
source=("$pkgname"::'git+https://github.com/OpenRCT2/OpenRCT2.git#branch=develop'
- 'discord-rpc::git+https://github.com/discordapp/discord-rpc.git'
- 'rapidjson::git+https://github.com/janisozaur/rapidjson.git#branch=patch-1')
+ 'discord-rpc::git+https://github.com/discordapp/discord-rpc.git')
sha256sums=('SKIP'
- 'SKIP'
'SKIP')
pkgver() {
@@ -33,7 +31,7 @@ prepare() {
cd "$srcdir/$pkgname"
ln -sf "$srcdir/discord-rpc" discord-rpc
mkdir -p discord-rpc/thirdparty
- ln -sf "$srcdir/rapidjson" discord-rpc/thirdparty/rapidjson
+ ln -sf "/usr/include/rapidjson" discord-rpc/thirdparty/rapidjson
}
build() {