summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaichi Shinozaki2016-01-29 14:32:36 +0000
committerDaichi Shinozaki2016-01-29 14:32:36 +0000
commitc258e10df3662dfe95ca3ed3eae22553b2babfdf (patch)
tree20253e9314e2fe0c95041a0e0a4d54829bf27524
parent4259978c4da298c066f0e93867b67b1e807f4388 (diff)
downloadaur-c258e10df3662dfe95ca3ed3eae22553b2babfdf.tar.gz
Removed experimental modules (accidentaly added in previous commit
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD13
2 files changed, 5 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1716c9368dab..0b45608a9763 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
# Generated by mksrcinfo v8
-# Fri Jan 29 14:28:44 UTC 2016
+# Fri Jan 29 14:31:52 UTC 2016
pkgbase = openresty
pkgdesc = A Fast and Scalable Web Platform by Extending NGINX with Lua
pkgver = 1.9.7.3
- pkgrel = 1
+ pkgrel = 2
url = http://openresty.org/
arch = i686
arch = x86_64
license = BSD
- makedepends = git
depends = perl>=5.6.1
depends = readline
depends = pcre
@@ -26,13 +25,9 @@ pkgbase = openresty
source = http://openresty.org/download/openresty-1.9.7.3.tar.gz
source = service
source = openresty.logrotate
- source = git+https://github.com/openresty/stream-lua-nginx-module.git
- source = git+https://github.com/openresty/stream-echo-nginx-module.git
sha256sums = 3e4422576d11773a03264021ff7985cd2eeac3382b511ae3052e835210a9a69a
sha256sums = ec55ac7da98f5f5ec54d096c5f79b656edec0ebca835b6b9f1d20fb7be7119c5
sha256sums = 613b0ed3fe4b5ee505ddb5122ee41604f464a5049be81c97601ee93970763a23
- sha256sums = SKIP
- sha256sums = SKIP
pkgname = openresty
diff --git a/PKGBUILD b/PKGBUILD
index b83823818f6a..99bf56ef2422 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,27 @@
+# Maintainer: Daichi Shinozaki <dseg@shield.jp>
# Contributor: Jean-Sébastien Ney <jeansebastien.ney@gmail.com>
# Contributor: James Cleveland <jc@blackflags.co.uk>
# Contributor: Eimantas Bunevičius <eimantaster@gmail.com>
-# Commit improvements: https://github.com/eimiss/aur-openresty
_cfgdir=/opt/openresty/nginx/conf
_tmpdir=/var/lib/openresty
pkgname=openresty
pkgver=1.9.7.3
-pkgrel=1
+pkgrel=2
pkgdesc="A Fast and Scalable Web Platform by Extending NGINX with Lua"
arch=('i686' 'x86_64')
url="http://openresty.org/"
license=('BSD')
depends=('perl>=5.6.1' 'readline' 'pcre' 'openssl')
-makedepends=('git')
install=
source=(http://openresty.org/download/$pkgname-$pkgver.tar.gz
service
openresty.logrotate
- 'git+https://github.com/openresty/stream-lua-nginx-module.git'
- 'git+https://github.com/openresty/stream-echo-nginx-module.git'
)
noextract=()
sha256sums=('3e4422576d11773a03264021ff7985cd2eeac3382b511ae3052e835210a9a69a'
'ec55ac7da98f5f5ec54d096c5f79b656edec0ebca835b6b9f1d20fb7be7119c5'
'613b0ed3fe4b5ee505ddb5122ee41604f464a5049be81c97601ee93970763a23'
- 'SKIP'
- 'SKIP')
-
+ )
backup=(${_cfgdir:1}/fastcgi.conf
${_cfgdir:1}/fastcgi_params
${_cfgdir:1}/koi-win
@@ -59,8 +54,6 @@ build() {
--with-http_v2_module \
--with-stream \
--with-stream_ssl_module \
- --add-module="../stream-lua-nginx-module" \
- --add-module="../stream-echo-nginx-module" \
# --without-http_echo_module \ # disable ngx_http_echo_module
# --without-http_xss_module \ # disable ngx_http_xss_module
# --without-http_coolkit_module \ # disable ngx_http_coolkit_module