summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBo Davidson2023-07-10 05:52:54 -0500
committerBo Davidson2023-07-10 05:52:54 -0500
commit11a4eac71fdeb90356b4e68249723fc97af3d110 (patch)
treed3e77003fb9d26db5ec118a9f6ecb8ee2c7ae9ef
parent1151ffce9c03f50106040f0cf2f7fdc8bd651d77 (diff)
downloadaur-openrgb.tar.gz
Update to rel 0.9 - If AsusTUF patch is needed let me know
-rw-r--r--.SRCINFO10
-rw-r--r--1743.patch53
-rw-r--r--PKGBUILD10
3 files changed, 8 insertions, 65 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6bc6ad7d8a1c..de626d21894e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = openrgb
pkgdesc = Open source RGB lighting control that doesn't depend on manufacturer software.
- pkgver = 0.8
- pkgrel = 3
+ pkgver = 0.9
+ pkgrel = 1
url = https://gitlab.com/CalcProgrammer1/OpenRGB
arch = x86_64
license = GPL2
@@ -13,13 +13,11 @@ pkgbase = openrgb
depends = mbedtls2
optdepends = i2c-tools: Motherboard & RAM access
options = !lto
- source = https://gitlab.com/CalcProgrammer1/OpenRGB/-/archive/release_0.8/OpenRGB-release_0.8.tar.gz
+ source = https://gitlab.com/CalcProgrammer1/OpenRGB/-/archive/release_0.9/OpenRGB-release_0.9.tar.gz
source = openrgb.conf
source = openrgb.service
- source = 1743.patch
- sha256sums = 0d803753873ca1ec2bd78632b4ac605669394e7eeba2d2efe305c7f9c9d7df0c
+ sha256sums = 2e62799339b72b6d3afc4792e6ff39487583210bb5ddde93e2daa38ae35381c2
sha256sums = b5a53d747422f8b594e3e9615e238457d696732efce94050cdd72182a8645ef2
sha256sums = 272dc43a77d0e48d29f32da753c7e05fd635883b173c21047f4eefa8bfc77938
- sha256sums = 2f7fe2fa62731884f16ebf5d4bb22bb2366e300d292bc3a113a8689d1cc14109
pkgname = openrgb
diff --git a/1743.patch b/1743.patch
deleted file mode 100644
index 4fecb4e457b9..000000000000
--- a/1743.patch
+++ /dev/null
@@ -1,53 +0,0 @@
-From 02d72bb447df72f35a0bf5557d527914614d4a73 Mon Sep 17 00:00:00 2001
-From: Artem Polishchuk <ego.cordatus@gmail.com>
-Date: Wed, 15 Mar 2023 21:49:39 +0200
-Subject: [PATCH] Fix building with GCC 13
-
-https://gcc.gnu.org/gcc-13/porting_to.html
-
-fix: #3225
----
- .../ENESMBusInterface/ENESMBusInterface_SpectrixS40G.cpp | 1 +
- Controllers/SteelSeriesController/SteelSeriesMouseController.h | 1 +
- Controllers/SteelSeriesController/SteelSeriesRivalController.cpp | 1 +
- 3 files changed, 3 insertions(+)
-
-diff --git a/Controllers/ENESMBusController/ENESMBusInterface/ENESMBusInterface_SpectrixS40G.cpp b/Controllers/ENESMBusController/ENESMBusInterface/ENESMBusInterface_SpectrixS40G.cpp
-index 2bdc37ad6..17080edb8 100644
---- a/Controllers/ENESMBusController/ENESMBusInterface/ENESMBusInterface_SpectrixS40G.cpp
-+++ b/Controllers/ENESMBusController/ENESMBusInterface/ENESMBusInterface_SpectrixS40G.cpp
-@@ -10,6 +10,7 @@
- #include "ENESMBusInterface_SpectrixS40G.h"
- #include <sys/ioctl.h>
- #include <cstring>
-+#include <cstdint>
-
- /*---------------------------------------------------------------------*\
- | Functions for submitting NVME admin passthrough command taken from |
-diff --git a/Controllers/SteelSeriesController/SteelSeriesMouseController.h b/Controllers/SteelSeriesController/SteelSeriesMouseController.h
-index 64df7a1cc..a4e561a35 100644
---- a/Controllers/SteelSeriesController/SteelSeriesMouseController.h
-+++ b/Controllers/SteelSeriesController/SteelSeriesMouseController.h
-@@ -10,6 +10,7 @@
- #include <hidapi/hidapi.h>
- #include <vector>
- #include "SteelSeriesGeneric.h"
-+#include <cstdint>
-
- #pragma once
-
-diff --git a/Controllers/SteelSeriesController/SteelSeriesRivalController.cpp b/Controllers/SteelSeriesController/SteelSeriesRivalController.cpp
-index 8f0cd4cdb..367e9175b 100644
---- a/Controllers/SteelSeriesController/SteelSeriesRivalController.cpp
-+++ b/Controllers/SteelSeriesController/SteelSeriesRivalController.cpp
-@@ -11,6 +11,7 @@
- #include <cstring>
- #include <stdio.h>
- #include <stdlib.h>
-+#include <cstdint>
-
- static void send_usb_msg(hid_device* dev, char * data_pkt, unsigned int size)
- {
---
-GitLab
-
diff --git a/PKGBUILD b/PKGBUILD
index 3721c71b4eea..bfb4aff8d964 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Bo Davidson <bo.davidson@go.tarleton.edu>
# Contributor: Paul Davis <paul@dangersalad.com>
pkgname=openrgb
-pkgver=0.8
-pkgrel=3
+pkgver=0.9
+pkgrel=1
pkgdesc="Open source RGB lighting control that doesn't depend on manufacturer software."
arch=("x86_64")
url="https://gitlab.com/CalcProgrammer1/OpenRGB"
@@ -21,12 +21,10 @@ source=(
"https://gitlab.com/CalcProgrammer1/OpenRGB/-/archive/release_$pkgver/OpenRGB-release_$pkgver.tar.gz"
openrgb.conf
openrgb.service
- 1743.patch # https://gitlab.com/CalcProgrammer1/OpenRGB/-/merge_requests/1743.patch
)
-sha256sums=('0d803753873ca1ec2bd78632b4ac605669394e7eeba2d2efe305c7f9c9d7df0c'
+sha256sums=('2e62799339b72b6d3afc4792e6ff39487583210bb5ddde93e2daa38ae35381c2'
'b5a53d747422f8b594e3e9615e238457d696732efce94050cdd72182a8645ef2'
- '272dc43a77d0e48d29f32da753c7e05fd635883b173c21047f4eefa8bfc77938'
- '2f7fe2fa62731884f16ebf5d4bb22bb2366e300d292bc3a113a8689d1cc14109')
+ '272dc43a77d0e48d29f32da753c7e05fd635883b173c21047f4eefa8bfc77938')
prepare() {
# Searches and applies any .patch file included this git repo