summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBo Davidson2020-09-27 12:17:00 -0500
committerBo Davidson2020-09-27 12:17:00 -0500
commit0ca3781ab68e8f0ba5c3acce19b51bd7664bbb0f (patch)
tree75ca0bc9f2f4782f89fdf25cf034b8f4197fa57c
parentc2de57e91c9bf8d54d5d2d018cf1542b50a02afb (diff)
downloadaur-0ca3781ab68e8f0ba5c3acce19b51bd7664bbb0f.tar.gz
Updated to version 0.4 and added .conf and .desktop for installation
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD34
-rw-r--r--openrgb.conf1
-rw-r--r--openrgb.desktop10
4 files changed, 51 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 47c9a8fa2d73..a6fa649ebbc3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,26 @@
pkgbase = openrgb
- pkgdesc = Open source RGB lighting control that doesn't depend on manufacturer software
- pkgver = 0.2
+ pkgdesc = Open source RGB lighting control that doesn't depend on manufacturer software.
+ pkgver = 0.4
pkgrel = 1
url = https://gitlab.com/CalcProgrammer1/OpenRGB
arch = x86_64
license = GPL2
+ makedepends = git
+ makedepends = make
+ makedepends = binutils
+ makedepends = pkgconf
depends = qt5-base
depends = libusb
- optdepends = linux-openrgb: ASUS and ASRock motherboard support
+ depends = hidapi
+ optdepends = i2c-tools: Motherboard & RAM access
provides = openrgb
- source = https://gitlab.com/CalcProgrammer1/OpenRGB/-/archive/release_0.2/OpenRGB-release_0.2.tar.gz
- md5sums = aba82b83744b04d5fe1728aea85b5a62
+ conflicts = openrgb-git
+ source = https://gitlab.com/CalcProgrammer1/OpenRGB/-/archive/release_0.4/OpenRGB-release_0.4.tar.gz
+ source = openrgb.desktop
+ source = openrgb.conf
+ sha256sums = a5743d6b0589e136b236cbfd815d7b7cb5c7331c1ca63cbd38e7b93d52c930fe
+ sha256sums = 2f96f6bcb381490dae7132b9533045dd46db8a0fc9f9ab5d00d952545800c6fc
+ sha256sums = b5a53d747422f8b594e3e9615e238457d696732efce94050cdd72182a8645ef2
pkgname = openrgb
diff --git a/PKGBUILD b/PKGBUILD
index 2e2ef8b14467..a6ac2a8478db 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,39 @@
# Maintainer: Paul Davis <paul@dangersalad.com>
+# Contributor: Bo Davidson <a3JvemFyZXFAZ21haWwuY29tCg== | base64 -d>
pkgname=openrgb
-pkgver=0.2
+pkgver=0.4
pkgrel=1
-pkgdesc="Open source RGB lighting control that doesn't depend on manufacturer software"
+pkgdesc="Open source RGB lighting control that doesn't depend on manufacturer software."
arch=("x86_64")
url="https://gitlab.com/CalcProgrammer1/OpenRGB"
license=('GPL2')
-depends=('qt5-base' 'libusb')
-optdepends=('linux-openrgb: ASUS and ASRock motherboard support')
+depends=('qt5-base' 'libusb' 'hidapi')
+makedepends=('git' 'make' 'binutils' 'pkgconf')
+optdepends=('i2c-tools: Motherboard & RAM access')
+conflicts=('openrgb-git')
provides=("openrgb")
-source=("https://gitlab.com/CalcProgrammer1/OpenRGB/-/archive/release_$pkgver/OpenRGB-release_$pkgver.tar.gz")
-md5sums=('aba82b83744b04d5fe1728aea85b5a62')
+source=("https://gitlab.com/CalcProgrammer1/OpenRGB/-/archive/release_$pkgver/OpenRGB-release_$pkgver.tar.gz"
+ 'openrgb.desktop'
+ 'openrgb.conf')
+sha256sums=('a5743d6b0589e136b236cbfd815d7b7cb5c7331c1ca63cbd38e7b93d52c930fe'
+ '2f96f6bcb381490dae7132b9533045dd46db8a0fc9f9ab5d00d952545800c6fc'
+ 'b5a53d747422f8b594e3e9615e238457d696732efce94050cdd72182a8645ef2')
build() {
cd "OpenRGB-release_$pkgver"
- qmake OpenRGB.pro
- make
+ qmake OpenRGB.pro
+ make -j$(nproc)
+}
+
+check() {
+ mkdir -p $HOME/.config/OpenRGB
}
package() {
- install -Dm755 "$srcdir/OpenRGB-release_$pkgver/OpenRGB" "$pkgdir"/usr/bin/OpenRGB
+ cd "$srcdir/OpenRGB-release_$pkgver"
+ install -Dm755 OpenRGB "$pkgdir"/usr/bin/openrgb
+ install -Dm644 qt/OpenRGB.png "$pkgdir"/usr/share/pixmaps/openrgb.png
+ install -Dm644 -t "$pkgdir"/usr/share/applications ../openrgb.desktop
+ install -Dm644 -t "$pkgdir"/usr/lib/udev/rules.d 60-openrgb.rules
+ install -Dm644 -t "$pkgdir"/usr/lib/modules-load.d ../openrgb.conf
}
diff --git a/openrgb.conf b/openrgb.conf
new file mode 100644
index 000000000000..0cdf71fd3e40
--- /dev/null
+++ b/openrgb.conf
@@ -0,0 +1 @@
+i2c-dev
diff --git a/openrgb.desktop b/openrgb.desktop
new file mode 100644
index 000000000000..be588616b112
--- /dev/null
+++ b/openrgb.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Name=OpenRGB
+GenericName=RGB Settings
+Comment=Open source RGB lighting control that doesn't depend on manufacturer software.
+Exec=bash -c 'cd $HOME/.config/OpenRGB && openrgb'
+Icon=openrgb
+Terminal=false
+Type=Application
+Categories=Settings;System;
+StartupNotify=true