summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBo Davidson2023-05-21 07:59:12 -0500
committerBo Davidson2023-05-21 07:59:12 -0500
commit9a0fed4dcafcd333e600ec7ee13883fcec151fa5 (patch)
tree44da60bedc018af402016104c1a0a5dcf8b32aea
parentc80c9416f701c7e4264277a878f68cfb491698df (diff)
downloadaur-9a0fed4dcafcd333e600ec7ee13883fcec151fa5.tar.gz
Build fix /w patch, linking mbedtls2, removes -pipe msgs
Thanks to AndyRTR for fix. https://aur.archlinux.org/packages/openrgb#comment-915525 Tested in clean chroot.
-rw-r--r--.SRCINFO4
-rw-r--r--1743.patch53
-rw-r--r--PKGBUILD12
3 files changed, 65 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f1dc1f6cf264..281e2d2180ee 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = openrgb
pkgdesc = Open source RGB lighting control that doesn't depend on manufacturer software.
pkgver = 0.8
- pkgrel = 1
+ pkgrel = 2
url = https://gitlab.com/CalcProgrammer1/OpenRGB
arch = x86_64
license = GPL2
@@ -16,8 +16,10 @@ pkgbase = openrgb
source = https://gitlab.com/CalcProgrammer1/OpenRGB/-/archive/release_0.8/OpenRGB-release_0.8.tar.gz
source = openrgb.conf
source = openrgb.service
+ source = 1743.patch
sha256sums = 0d803753873ca1ec2bd78632b4ac605669394e7eeba2d2efe305c7f9c9d7df0c
sha256sums = b5a53d747422f8b594e3e9615e238457d696732efce94050cdd72182a8645ef2
sha256sums = 272dc43a77d0e48d29f32da753c7e05fd635883b173c21047f4eefa8bfc77938
+ sha256sums = 2f7fe2fa62731884f16ebf5d4bb22bb2366e300d292bc3a113a8689d1cc14109
pkgname = openrgb
diff --git a/1743.patch b/1743.patch
new file mode 100644
index 000000000000..4fecb4e457b9
--- /dev/null
+++ b/1743.patch
@@ -0,0 +1,53 @@
+From 02d72bb447df72f35a0bf5557d527914614d4a73 Mon Sep 17 00:00:00 2001
+From: Artem Polishchuk <ego.cordatus@gmail.com>
+Date: Wed, 15 Mar 2023 21:49:39 +0200
+Subject: [PATCH] Fix building with GCC 13
+
+https://gcc.gnu.org/gcc-13/porting_to.html
+
+fix: #3225
+---
+ .../ENESMBusInterface/ENESMBusInterface_SpectrixS40G.cpp | 1 +
+ Controllers/SteelSeriesController/SteelSeriesMouseController.h | 1 +
+ Controllers/SteelSeriesController/SteelSeriesRivalController.cpp | 1 +
+ 3 files changed, 3 insertions(+)
+
+diff --git a/Controllers/ENESMBusController/ENESMBusInterface/ENESMBusInterface_SpectrixS40G.cpp b/Controllers/ENESMBusController/ENESMBusInterface/ENESMBusInterface_SpectrixS40G.cpp
+index 2bdc37ad6..17080edb8 100644
+--- a/Controllers/ENESMBusController/ENESMBusInterface/ENESMBusInterface_SpectrixS40G.cpp
++++ b/Controllers/ENESMBusController/ENESMBusInterface/ENESMBusInterface_SpectrixS40G.cpp
+@@ -10,6 +10,7 @@
+ #include "ENESMBusInterface_SpectrixS40G.h"
+ #include <sys/ioctl.h>
+ #include <cstring>
++#include <cstdint>
+
+ /*---------------------------------------------------------------------*\
+ | Functions for submitting NVME admin passthrough command taken from |
+diff --git a/Controllers/SteelSeriesController/SteelSeriesMouseController.h b/Controllers/SteelSeriesController/SteelSeriesMouseController.h
+index 64df7a1cc..a4e561a35 100644
+--- a/Controllers/SteelSeriesController/SteelSeriesMouseController.h
++++ b/Controllers/SteelSeriesController/SteelSeriesMouseController.h
+@@ -10,6 +10,7 @@
+ #include <hidapi/hidapi.h>
+ #include <vector>
+ #include "SteelSeriesGeneric.h"
++#include <cstdint>
+
+ #pragma once
+
+diff --git a/Controllers/SteelSeriesController/SteelSeriesRivalController.cpp b/Controllers/SteelSeriesController/SteelSeriesRivalController.cpp
+index 8f0cd4cdb..367e9175b 100644
+--- a/Controllers/SteelSeriesController/SteelSeriesRivalController.cpp
++++ b/Controllers/SteelSeriesController/SteelSeriesRivalController.cpp
+@@ -11,6 +11,7 @@
+ #include <cstring>
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <cstdint>
+
+ static void send_usb_msg(hid_device* dev, char * data_pkt, unsigned int size)
+ {
+--
+GitLab
+
diff --git a/PKGBUILD b/PKGBUILD
index b73fc82730ee..e17b8a1680ab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Paul Davis <paul@dangersalad.com>
pkgname=openrgb
pkgver=0.8
-pkgrel=1
+pkgrel=2
pkgdesc="Open source RGB lighting control that doesn't depend on manufacturer software."
arch=("x86_64")
url="https://gitlab.com/CalcProgrammer1/OpenRGB"
@@ -21,12 +21,15 @@ source=(
"https://gitlab.com/CalcProgrammer1/OpenRGB/-/archive/release_$pkgver/OpenRGB-release_$pkgver.tar.gz"
openrgb.conf
openrgb.service
+ 1743.patch # https://gitlab.com/CalcProgrammer1/OpenRGB/-/merge_requests/1743.patch
)
sha256sums=('0d803753873ca1ec2bd78632b4ac605669394e7eeba2d2efe305c7f9c9d7df0c'
'b5a53d747422f8b594e3e9615e238457d696732efce94050cdd72182a8645ef2'
- '272dc43a77d0e48d29f32da753c7e05fd635883b173c21047f4eefa8bfc77938')
+ '272dc43a77d0e48d29f32da753c7e05fd635883b173c21047f4eefa8bfc77938'
+ '2f7fe2fa62731884f16ebf5d4bb22bb2366e300d292bc3a113a8689d1cc14109')
prepare() {
+ # Searches and applies any .patch file included this git repo
cd "$srcdir/OpenRGB-release_$pkgver"
local src
for src in "${source[@]}"; do
@@ -40,9 +43,12 @@ prepare() {
build() {
+ export CXXFLAGS=${CXXFLAGS/-pipe}
+ export LDFLAGS="$LDFLAGS -L/usr/lib/mbedtls2" # props to AndyRTR for linking to mbedtls2 fix
+
cd "$srcdir/OpenRGB-release_$pkgver"
sed -i 's|rules.path=/lib|rules.path=/usr/lib|g' OpenRGB.pro
- qmake OpenRGB.pro
+ qmake INCLUDEPATH+="/usr/include/mbedtls2" OpenRGB.pro
make
}