summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBo Davidson2021-06-01 12:04:13 -0500
committerBo Davidson2021-06-01 12:04:13 -0500
commitaaceeecf7b1950fc98610d98e12cef9b0729d495 (patch)
treeaa66a9b714516783eb993a6ba97af5ff51e9056c
parente52acded7fa90df3bf7265dce798bd3a53effc37 (diff)
downloadaur-aaceeecf7b1950fc98610d98e12cef9b0729d495.tar.gz
pkgver 0.6, hidapifix patch no longer needed
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD8
-rw-r--r--hidapifix.patch33
3 files changed, 9 insertions, 42 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 25d42297524d..7d01873e7884 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = openrgb
pkgdesc = Open source RGB lighting control that doesn't depend on manufacturer software.
- pkgver = 0.5
- pkgrel = 7
+ pkgver = 0.6
+ pkgrel = 1
url = https://gitlab.com/CalcProgrammer1/OpenRGB
arch = x86_64
license = GPL2
@@ -10,14 +10,14 @@ pkgbase = openrgb
depends = libusb
depends = hidapi
optdepends = i2c-tools: Motherboard & RAM access
- source = https://gitlab.com/CalcProgrammer1/OpenRGB/-/archive/release_0.5/OpenRGB-release_0.5.tar.gz
- source = hidapifix.patch
+ source = https://gitlab.com/CalcProgrammer1/OpenRGB/-/archive/release_0.6/OpenRGB-release_0.6.tar.gz
source = openrgb.conf
source = openrgb.service
+ source = openrgb.desktop
sha256sums = e227dedfe0c3aa8f3bcb0c4149aa5feb1db4b0429a151423d74c0103c55d7d26
- sha256sums = eeaed61a7bdbfa98cd9aaa6ea8a55df3eb092bc1f02ba047dd73cf75d1578b88
sha256sums = b5a53d747422f8b594e3e9615e238457d696732efce94050cdd72182a8645ef2
sha256sums = 97445ee2e0824441dbebab14a10c2ea6983e14ab8f7177b977ee6b8bdc3398f9
+ sha256sums = 2f96f6bcb381490dae7132b9533045dd46db8a0fc9f9ab5d00d952545800c6fc
pkgname = openrgb
diff --git a/PKGBUILD b/PKGBUILD
index 4cc5d2729dd7..4fab64a38154 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Bo Davidson <bo.davidson@go.tarleton.edu>
# Contributor: Paul Davis <paul@dangersalad.com>
pkgname=openrgb
-pkgver=0.5
-pkgrel=7
+pkgver=0.6
+pkgrel=1
pkgdesc="Open source RGB lighting control that doesn't depend on manufacturer software."
arch=("x86_64")
url="https://gitlab.com/CalcProgrammer1/OpenRGB"
@@ -12,15 +12,15 @@ makedepends=('pkgconf')
optdepends=('i2c-tools: Motherboard & RAM access')
source=(
"https://gitlab.com/CalcProgrammer1/OpenRGB/-/archive/release_$pkgver/OpenRGB-release_$pkgver.tar.gz"
- hidapifix.patch # https://gitlab.com/CalcProgrammer1/OpenRGB/-/issues/924
openrgb.conf
openrgb.service
+ openrgb.desktop
)
sha256sums=(
'e227dedfe0c3aa8f3bcb0c4149aa5feb1db4b0429a151423d74c0103c55d7d26'
- 'eeaed61a7bdbfa98cd9aaa6ea8a55df3eb092bc1f02ba047dd73cf75d1578b88'
'b5a53d747422f8b594e3e9615e238457d696732efce94050cdd72182a8645ef2'
'97445ee2e0824441dbebab14a10c2ea6983e14ab8f7177b977ee6b8bdc3398f9'
+ '2f96f6bcb381490dae7132b9533045dd46db8a0fc9f9ab5d00d952545800c6fc'
)
prepare() {
diff --git a/hidapifix.patch b/hidapifix.patch
deleted file mode 100644
index 2fb4a65e77be..000000000000
--- a/hidapifix.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-diff --git a/OpenRGB.pro b/OpenRGB.pro
-index 0e77d373e0d094fb714c1e58162aa67f5037da00..10d209ce25ff9e4a3351b5598e209e2326d81331 100644
---- a/OpenRGB.pro
-+++ b/OpenRGB.pro
-@@ -673,6 +673,15 @@ unix:!macx {
- #-------------------------------------------------------------------------------------------#
- packagesExist(hidapi-hidraw) {
- LIBS += -lhidapi-hidraw
-+
-+ #---------------------------------------------------------------------------------------#
-+ # hidapi-hidraw >= 0.10.1 supports USAGE/USAGE_PAGE #
-+ # Define USE_HID_USAGE if hidapi-hidraw supports it #
-+ #---------------------------------------------------------------------------------------#
-+ HIDAPI_HIDRAW_VERSION = $$system(pkgconf --modversion hidapi-hidraw)
-+ if(versionAtLeast(HIDAPI_HIDRAW_VERSION, "0.10.1")) {
-+ DEFINES += USE_HID_USAGE
-+ }
- } else {
- packagesExist(hidapi-libusb) {
- LIBS += -lhidapi-libusb
-diff --git a/README.md b/README.md
-index 348f7140a9350b792af844064e15e32cb19cb982..e88acff8e83ad3e0d60cf3981a5dcaafa89c4b3d 100644
---- a/README.md
-+++ b/README.md
-@@ -54,7 +54,7 @@ There have been two instances of hardware damage in OpenRGB's development and we
- * Pre-built binaries in AppImage format are available under the Releases section on GitLab.
- * You can build the project using Qt Creator or on the command line.
- 1. Install build dependencies
-- - Debian: sudo apt install build-essential qtcreator qt5-default libusb-1.0-0-dev libhidapi-dev pkgconf
-+ - Debian: sudo apt install build-essential qtcreator qt5-default libusb-1.0-0-dev libhidapi-dev pkgconf pkg-config
- - Fedora: sudo dnf install git make automake gcc gcc-c++ qt-creator qt5-devel hidapi-devel libusb-devel
- 2. git clone https://gitlab.com/CalcProgrammer1/OpenRGB
- 3. cd OpenRGB