summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBo Davidson2021-05-11 16:30:49 -0500
committerBo Davidson2021-05-11 16:30:49 -0500
commite52acded7fa90df3bf7265dce798bd3a53effc37 (patch)
tree9ef0753b2150eddb98542e5d83935fa117ea274b
parent55da81b5648d86e3ccd2c46b3767a3e86d40c53f (diff)
downloadaur-e52acded7fa90df3bf7265dce798bd3a53effc37.tar.gz
Added a systemd service file
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD7
2 files changed, 8 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e55ab36321b9..25d42297524d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = openrgb
pkgdesc = Open source RGB lighting control that doesn't depend on manufacturer software.
pkgver = 0.5
- pkgrel = 6
+ pkgrel = 7
url = https://gitlab.com/CalcProgrammer1/OpenRGB
arch = x86_64
license = GPL2
@@ -13,9 +13,11 @@ pkgbase = openrgb
source = https://gitlab.com/CalcProgrammer1/OpenRGB/-/archive/release_0.5/OpenRGB-release_0.5.tar.gz
source = hidapifix.patch
source = openrgb.conf
+ source = openrgb.service
sha256sums = e227dedfe0c3aa8f3bcb0c4149aa5feb1db4b0429a151423d74c0103c55d7d26
sha256sums = eeaed61a7bdbfa98cd9aaa6ea8a55df3eb092bc1f02ba047dd73cf75d1578b88
sha256sums = b5a53d747422f8b594e3e9615e238457d696732efce94050cdd72182a8645ef2
+ sha256sums = 97445ee2e0824441dbebab14a10c2ea6983e14ab8f7177b977ee6b8bdc3398f9
pkgname = openrgb
diff --git a/PKGBUILD b/PKGBUILD
index 854466a77e8d..4cc5d2729dd7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
-# Maintainer: Bo Davidson <a3JvemFyZXFAZ21haWwuY29tCg== | base64 -d>
+# Maintainer: Bo Davidson <bo.davidson@go.tarleton.edu>
# Contributor: Paul Davis <paul@dangersalad.com>
pkgname=openrgb
pkgver=0.5
-pkgrel=6
+pkgrel=7
pkgdesc="Open source RGB lighting control that doesn't depend on manufacturer software."
arch=("x86_64")
url="https://gitlab.com/CalcProgrammer1/OpenRGB"
@@ -14,11 +14,13 @@ source=(
"https://gitlab.com/CalcProgrammer1/OpenRGB/-/archive/release_$pkgver/OpenRGB-release_$pkgver.tar.gz"
hidapifix.patch # https://gitlab.com/CalcProgrammer1/OpenRGB/-/issues/924
openrgb.conf
+ openrgb.service
)
sha256sums=(
'e227dedfe0c3aa8f3bcb0c4149aa5feb1db4b0429a151423d74c0103c55d7d26'
'eeaed61a7bdbfa98cd9aaa6ea8a55df3eb092bc1f02ba047dd73cf75d1578b88'
'b5a53d747422f8b594e3e9615e238457d696732efce94050cdd72182a8645ef2'
+ '97445ee2e0824441dbebab14a10c2ea6983e14ab8f7177b977ee6b8bdc3398f9'
)
prepare() {
@@ -45,4 +47,5 @@ package() {
cd "$srcdir/OpenRGB-release_$pkgver"
make INSTALL_ROOT="$pkgdir" install
install -Dm644 -t "$pkgdir"/usr/lib/modules-load.d ../openrgb.conf
+ install -Dm644 -t "$pkgdir"/usr/lib/systemd/system ../openrgb.service
}