summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBo Davidson2020-12-07 03:00:06 -0600
committerBo Davidson2020-12-07 03:00:06 -0600
commitfa60d4e990afe1278412f3044eb70bc047bef8fd (patch)
treea237be9da3b216942fbbaa2424af2b277d38940d
parent44a2fe605043b8a6b24999013e2d00d7e19dbd68 (diff)
downloadaur-fa60d4e990afe1278412f3044eb70bc047bef8fd.tar.gz
rel 0.5, upstream renamed OpenRGB binary to openrgb
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a6fa649ebbc3..03b6b9b867c4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,10 @@
pkgbase = openrgb
pkgdesc = Open source RGB lighting control that doesn't depend on manufacturer software.
- pkgver = 0.4
+ pkgver = 0.5
pkgrel = 1
url = https://gitlab.com/CalcProgrammer1/OpenRGB
arch = x86_64
license = GPL2
- makedepends = git
makedepends = make
makedepends = binutils
makedepends = pkgconf
@@ -15,10 +14,10 @@ pkgbase = openrgb
optdepends = i2c-tools: Motherboard & RAM access
provides = openrgb
conflicts = openrgb-git
- source = https://gitlab.com/CalcProgrammer1/OpenRGB/-/archive/release_0.4/OpenRGB-release_0.4.tar.gz
+ source = https://gitlab.com/CalcProgrammer1/OpenRGB/-/archive/release_0.5/OpenRGB-release_0.5.tar.gz
source = openrgb.desktop
source = openrgb.conf
- sha256sums = a5743d6b0589e136b236cbfd815d7b7cb5c7331c1ca63cbd38e7b93d52c930fe
+ sha256sums = e227dedfe0c3aa8f3bcb0c4149aa5feb1db4b0429a151423d74c0103c55d7d26
sha256sums = 2f96f6bcb381490dae7132b9533045dd46db8a0fc9f9ab5d00d952545800c6fc
sha256sums = b5a53d747422f8b594e3e9615e238457d696732efce94050cdd72182a8645ef2
diff --git a/PKGBUILD b/PKGBUILD
index 3937955bfeb1..2aa2d1cb9e9d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,21 @@
# Maintainer: Bo Davidson <a3JvemFyZXFAZ21haWwuY29tCg== | base64 -d>
# Contributor: Paul Davis <paul@dangersalad.com>
pkgname=openrgb
-pkgver=0.4
+pkgver=0.5
pkgrel=1
pkgdesc="Open source RGB lighting control that doesn't depend on manufacturer software."
arch=("x86_64")
url="https://gitlab.com/CalcProgrammer1/OpenRGB"
license=('GPL2')
depends=('qt5-base' 'libusb' 'hidapi')
-makedepends=('git' 'make' 'binutils' 'pkgconf')
+makedepends=('make' 'binutils' 'pkgconf')
optdepends=('i2c-tools: Motherboard & RAM access')
conflicts=('openrgb-git')
provides=("openrgb")
source=("https://gitlab.com/CalcProgrammer1/OpenRGB/-/archive/release_$pkgver/OpenRGB-release_$pkgver.tar.gz"
'openrgb.desktop'
'openrgb.conf')
-sha256sums=('a5743d6b0589e136b236cbfd815d7b7cb5c7331c1ca63cbd38e7b93d52c930fe'
+sha256sums=('e227dedfe0c3aa8f3bcb0c4149aa5feb1db4b0429a151423d74c0103c55d7d26'
'2f96f6bcb381490dae7132b9533045dd46db8a0fc9f9ab5d00d952545800c6fc'
'b5a53d747422f8b594e3e9615e238457d696732efce94050cdd72182a8645ef2')
@@ -27,7 +27,7 @@ build() {
package() {
cd "$srcdir/OpenRGB-release_$pkgver"
- install -Dm755 OpenRGB "$pkgdir"/usr/bin/openrgb
+ install -Dm755 openrgb "$pkgdir"/usr/bin/openrgb
install -Dm644 qt/OpenRGB.png "$pkgdir"/usr/share/pixmaps/openrgb.png
install -Dm644 -t "$pkgdir"/usr/share/applications ../openrgb.desktop
install -Dm644 -t "$pkgdir"/usr/lib/udev/rules.d 60-openrgb.rules