summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLaura Demkowicz-Duffy2021-10-29 02:48:07 +0100
committerLaura Demkowicz-Duffy2021-10-29 02:48:07 +0100
commit6f5c6fb4594d1e6b1d915cfa4287d33d47c8b198 (patch)
treef25f8df991abceb537fdc1967f13d7c39b32d141
downloadaur-6f5c6fb4594d1e6b1d915cfa4287d33d47c8b198.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore21
-rw-r--r--PKGBUILD32
-rw-r--r--openrocket.sh2
4 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9d1375d07dc7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = openrocket-git
+ pkgdesc = A free and fully featured rocket flight simulator - 6 degrees of freedom
+ pkgver = r2955.f67ea41c
+ pkgrel = 1
+ url = https://github.com/openrocket/openrocket
+ arch = any
+ license = GPL
+ makedepends = git
+ makedepends = ant
+ depends = java-environment=8
+ depends = desktop-file-utils
+ provides = openrocket
+ conflicts = openrocket
+ noextract = openrocket.sh
+ source = git+https://github.com/openrocket/openrocket.git#branch=unstable
+ source = openrocket.sh
+ sha256sums = SKIP
+ sha256sums = 74ab605cb11161784d4af96d018eb88adf7a2e4a8b1088a64b94b1e8ec5e18d1
+
+pkgname = openrocket-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..3bfd050bd96c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,21 @@
+# Created by https://www.toptal.com/developers/gitignore/api/archlinuxpackages
+# Edit at https://www.toptal.com/developers/gitignore?templates=archlinuxpackages
+
+### ArchLinuxPackages ###
+*.tar
+*.tar.*
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+pkg/
+src/
+
+# End of https://www.toptal.com/developers/gitignore/api/archlinuxpackages
+
+openrocket
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..34feb696aba0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Laura Demkowicz-Duffy <laura@demkowiczduffy.co.uk>
+pkgname=openrocket-git
+pkgver=r2955.f67ea41c
+pkgrel=1
+pkgdesc="A free and fully featured rocket flight simulator - 6 degrees of freedom"
+arch=('any')
+url=https://github.com/openrocket/openrocket
+license=('GPL')
+depends=('java-environment=8' 'desktop-file-utils')
+makedepends=('git' 'ant')
+provides=('openrocket')
+conflicts=('openrocket')
+source=("git+https://github.com/openrocket/openrocket.git#branch=unstable"
+ "openrocket.sh")
+noextract=("openrocket.sh")
+sha256sums=('SKIP'
+ '74ab605cb11161784d4af96d018eb88adf7a2e4a8b1088a64b94b1e8ec5e18d1')
+
+pkgver() {
+ cd openrocket
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd openrocket
+ ant -f ./build.xml
+}
+
+package() {
+ cd openrocket
+ install -Dm644 swing/build/jar/OpenRocket.jar $pkgdir/usr/share/java/openrocket/openrocket.jar
+}
diff --git a/openrocket.sh b/openrocket.sh
new file mode 100644
index 000000000000..1ec58aceb437
--- /dev/null
+++ b/openrocket.sh
@@ -0,0 +1,2 @@
+#!/bin/sh
+"$JAVA_HOME/bin/java" -jar '/usr/share/java/openrocket/openrocket.jar'