summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenjamin Chrétien2015-07-31 17:23:16 +0900
committerBenjamin Chrétien2015-07-31 17:25:44 +0900
commit85b6a85ad25d60f2a2f344c954b2953155ca4a56 (patch)
tree392bf2ce1dcf6d15fdcc83b8860758b66b51658e
parent8936c1319dad39b056d0b868729b569416486960 (diff)
downloadaur-85b6a85ad25d60f2a2f344c954b2953155ca4a56.tar.gz
Update to version 1.1.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD18
2 files changed, 15 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e802bbe8d19b..b9fec8bd4fb1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = openrtm-aist-python
pkgdesc = Python bindings for OpenRTM-aist
- pkgver = 1.0.0
+ pkgver = 1.1.0
pkgrel = 1
url = http://www.openrtm.org
arch = i686
arch = x86_64
license = GPL
depends = omniorb
- depends = python
- source = http://www.openrtm.org/pub/OpenRTM-aist/python/1.0.0/OpenRTM-aist-Python-1.0.0-RELEASE.tar.gz
- md5sums = dd11ef6a2e6277fa095e0fbd3210a2a5
+ depends = python2
+ source = http://www.openrtm.org/pub/OpenRTM-aist/python/1.0.0/OpenRTM-aist-Python-1.1.0-RC1.tar.gz
+ md5sums = bbc9c4915d13cef0f5a925a070bab0aa
pkgname = openrtm-aist-python
diff --git a/PKGBUILD b/PKGBUILD
index fb7eff3b5b5b..152b6bc97604 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,32 @@
# Maintainer: Sven Schneider <archlinux.sandmann@googlemail.com>
pkgname=openrtm-aist-python
-pkgver=1.0.0
+pkgver=1.1.0
pkgrel=1
pkgdesc="Python bindings for OpenRTM-aist"
arch=('i686' 'x86_64')
url="http://www.openrtm.org"
license=('GPL')
-depends=('omniorb' 'python')
-source=(http://www.openrtm.org/pub/OpenRTM-aist/python/1.0.0/OpenRTM-aist-Python-${pkgver}-RELEASE.tar.gz)
-md5sums=('dd11ef6a2e6277fa095e0fbd3210a2a5')
+depends=('omniorb' 'python2')
+source=("http://www.openrtm.org/pub/OpenRTM-aist/python/${pkgver}/OpenRTM-aist-Python-${pkgver}-RC1.tar.gz")
+md5sums=('bbc9c4915d13cef0f5a925a070bab0aa')
build() {
cd ${srcdir}/OpenRTM-aist-Python-${pkgver}
sed 's/-bpython/-p -bpython/g' -i setup.py
+
+ # Fix for Python 2 scripts
+ sed -i "s,env python *$,env python2,g" $(find . -type f -and -iname "*.py")
+ sed -i "s,/usr/bin/python *$,/usr/bin/env python2,g" $(find . -iname "*.py")
- python setup.py sdist
- python setup.py build
+ python2 setup.py sdist
+ python2 setup.py build
}
package() {
cd ${srcdir}/OpenRTM-aist-Python-${pkgver}
- python setup.py install --root=${pkgdir} --optimize=1
+ python2 setup.py install --root=${pkgdir} --optimize=1
}