summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBuildTools2016-05-20 07:28:13 +0200
committerBuildTools2016-05-20 07:28:13 +0200
commit1446e81fdbcc4891e1c9bc3f2cde9a93b4e48dd4 (patch)
tree325368238d6766fd5f0681f5e5e964b908e40fd2
downloadaur-1446e81fdbcc4891e1c9bc3f2cde9a93b4e48dd4.tar.gz
Initial upload
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD55
-rw-r--r--openrw.desktop9
3 files changed, 86 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..32f1394502f4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = openrw-git
+ pkgdesc = OpenRW 'Open ReWrite' is an un-official open source recreation of the classic Grand Theft Auto III game executable
+ pkgver = r621.2ee4a6e
+ pkgrel = 1
+ url = https://github.com/danhedron/openrw
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = cmake
+ makedepends = make
+ depends = bullet
+ depends = glm
+ depends = sfml
+ depends = boost
+ provides = openrw
+ source = openrw-git::git+https://github.com/danhedron/openrw.git
+ source = openrw.desktop
+ sha256sums = SKIP
+ sha256sums = 78f96261cf22a5413f4e17480b9cb08ce4da8683fb2f8399018e80c96246d0b0
+
+pkgname = openrw-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..422de14823a8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+# Maintainer: PureTryOut
+pkgname=openrw-git
+pkgver=r621.2ee4a6e
+pkgrel=1
+epoch=
+pkgdesc="OpenRW 'Open ReWrite' is an un-official open source recreation of the classic Grand Theft Auto III game executable"
+arch=('x86_64')
+url="https://github.com/danhedron/openrw"
+license=('GPL3')
+groups=()
+depends=('bullet' 'glm' 'sfml' 'boost')
+makedepends=('git' 'cmake' 'make')
+checkdepends=()
+optdepends=()
+provides=('openrw')
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=('openrw-git::git+https://github.com/danhedron/openrw.git'
+ 'openrw.desktop')
+noextract=()
+sha256sums=('SKIP'
+ '78f96261cf22a5413f4e17480b9cb08ce4da8683fb2f8399018e80c96246d0b0')
+validpgpkeys=()
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$pkgname"
+
+ if [[ -d build ]]; then
+ rm -rf build
+ fi
+ mkdir build && cd build
+
+ cmake ..
+ make $MAKEFLAGS
+}
+
+
+package() {
+ cd "$pkgname"
+
+ # The application
+ install -Dm755 build/rwgame/rwgame "$pkgdir/usr/bin/rwgame"
+
+ # .desktop file and icon
+ install -Dm644 "$srcdir/openrw.desktop" "$pkgdir"/usr/share/applications/openrw.desktop
+}
diff --git a/openrw.desktop b/openrw.desktop
new file mode 100644
index 000000000000..dab174e13723
--- /dev/null
+++ b/openrw.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Type=Application
+Version=1.0
+Name=OpenRW
+Comment=OpenRW "Open ReWrite" is an un-official open source recreation of the classic Grand Theft Auto III game executable
+Exec=rwgame
+Icon=openrw
+Terminal=false
+Categories=Game;