summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2023-01-17 13:18:16 -0600
committerLuis Martinez2023-01-17 13:44:33 -0600
commit5d98a18bb156ad433b57b445f2286c169dbb8cda (patch)
tree129e93f0b04e173f80ceba945e7de2581a256c9f
parenta7ffb1a55f68949b963f3295b7293c7b147898a7 (diff)
downloadaur-5d98a18bb156ad433b57b445f2286c169dbb8cda.tar.gz
package cleanup
-rw-r--r--.SRCINFO34
-rw-r--r--PKGBUILD92
2 files changed, 63 insertions, 63 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c2d301fffc07..29ee87642b0d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,34 +1,32 @@
-# Generated by mksrcinfo v8
-# Wed Jul 13 02:40:58 UTC 2022
pkgbase = openscad-git
pkgdesc = The programmers solid 3D CAD modeller
- pkgver = 20220626
+ pkgver = 2019.05.r2561.gbc21c1263
pkgrel = 1
- url = http://openscad.org/
- arch = i686
+ url = https://github.com/openscad/openscad
arch = x86_64
license = GPL2
makedepends = git
makedepends = boost
+ makedepends = cmake
makedepends = eigen
makedepends = imagemagick
- makedepends = ccache
- depends = qt5-base
- depends = qscintilla-qt5
- depends = cgal
- depends = opencsg
+ makedepends = python
depends = boost-libs
- depends = qt5-multimedia
+ depends = cgal
depends = libzip
+ depends = opencsg
+ depends = qscintilla-qt5
+ depends = qt5-base
depends = qt5-gamepad
+ depends = qt5-multimedia
+ depends = qt5-svg
provides = openscad
conflicts = openscad
- source = git+https://github.com/openscad/openscad.git
- source = git+https://github.com/openscad/MCAD.git
- source = git+https://github.com/microsoft/mimalloc.git
- md5sums = SKIP
- md5sums = SKIP
- md5sums = SKIP
+ source = openscad::git+https://github.com/openscad/openscad
+ source = MCAD::git+https://github.com/openscad/MCAD
+ source = mimalloc::git+https://github.com/microsoft/mimalloc
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
pkgname = openscad-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 491ac288dd42..ae3ea55cade0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,64 +1,66 @@
-# Maintainer: Kyle Keen <keenerd@gmail.com>
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+# Contributor: Kyle Keen <keenerd@gmail.com>
# Contributor: Torsten Wagner <tottiwagner@yahoo.de>
pkgname=openscad-git
-pkgver=20220626
+_pkg="${pkgname%-git}"
+pkgver=2019.05.r2561.gbc21c1263
pkgrel=1
pkgdesc="The programmers solid 3D CAD modeller"
-arch=('i686' 'x86_64')
+arch=('x86_64')
license=('GPL2')
-url="http://openscad.org/"
-provides=('openscad')
-conflicts=('openscad')
-depends=('qt5-base' 'qscintilla-qt5' 'cgal' 'opencsg' 'boost-libs'
- 'qt5-multimedia' 'libzip' 'qt5-gamepad')
-makedepends=('git' 'boost' 'eigen' 'imagemagick' 'ccache')
-source=('git+https://github.com/openscad/openscad.git'
- 'git+https://github.com/openscad/MCAD.git'
- 'git+https://github.com/microsoft/mimalloc.git')
-md5sums=('SKIP' 'SKIP' 'SKIP')
-
-_gitname="openscad"
-_gitbranch="master"
+url='https://github.com/openscad/openscad'
+provides=("$_pkg")
+conflicts=("$_pkg")
+depends=(
+ 'boost-libs'
+ 'cgal'
+ 'libzip'
+ 'opencsg'
+ 'qscintilla-qt5'
+ 'qt5-base'
+ 'qt5-gamepad'
+ 'qt5-multimedia'
+ 'qt5-svg')
+makedepends=('git' 'boost' 'cmake' 'eigen' 'imagemagick' 'python')
+source=("$_pkg::git+$url"
+ 'MCAD::git+https://github.com/openscad/MCAD'
+ 'mimalloc::git+https://github.com/microsoft/mimalloc')
+sha256sums=('SKIP'
+ 'SKIP'
+ 'SKIP')
pkgver() {
- cd "$_gitname"
- git show -s --format="%ci" HEAD | sed -e 's/-//g' -e 's/ .*//'
- #git describe --always --tags | sed 's/-/./g'
+ git -C "$_pkg" describe --long --tags | sed 's/^openscad-//;s/-/.r/;s/-/./'
}
prepare() {
- cd "$_gitname"
- # I am amazed that people are willing to avoid using sources(),
- # and download stuff inside of build() instead.
- # "git submodule update --init" is not okay.
-
- cp -ar "$srcdir/MCAD" libraries
- #rm -f libraries/MCAD/*.py
- rm -rf libraries/MCAD/.git/
-
- cp -ar "$srcdir/mimalloc" submodules
- rm -rf submodules/mimalloc/.git/
-
- sed -i 's/ping files.openscad.org/ping archlinux.org/' resources/CMakeLists.txt
- # todo: download the docs with sources() too
+ cd "$_pkg"
+ git submodule init
+ git config submodule.mimalloc.url "$srcdir/mimalloc"
+ git config submodule.libraries/MCAD.url "$srcdir/MCAD"
+ git -c protocol.file.allow=always submodule update
+ sed -i 's/ping files.openscad.org/ping archlinux.org/' resources/CMakeLists.txt
}
build() {
- cd "$_gitname"
- mkdir -p build
- cd build
- cmake -DCMAKE_INSTALL_PREFIX=/usr -DEXPERIMENTAL=ON -DOFFLINE_DOCS=ON ..
- make
- cd ..
- convert "resources/icons/openscad.png" -resize 128x128\> "resources/icons/openscad-128.png"
+ cmake \
+ -B build \
+ -S "$_pkg" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=None \
+ -DEXPERIMENTAL=ON \
+ -DOFFLINE_DOCS=ON \
+ -Wno-dev
+ cmake --build build
+ cd "$_pkg/resources/icons/"
+ convert openscad.png -resize 128x128\> openscad-128.png
}
package() {
- cd "$_gitname/build"
- make INSTALL_ROOT="$pkgdir" install
- cd "$_gitname"
- install -Dm644 "resources/icons/openscad.desktop" "$pkgdir/usr/share/applications/openscad.desktop"
- install -Dm644 "resources/icons/openscad-128.png" "$pkgdir/usr/share/pixmaps/openscad.png"
+ DESTDIR="$pkgdir" cmake --install build
+ cd "$_pkg"
+ install -Dm644 "resources/icons/openscad.desktop" "$pkgdir/usr/share/applications/openscad.desktop"
+ install -Dm644 "resources/icons/openscad-128.png" "$pkgdir/usr/share/pixmaps/openscad.png"
}