summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle Keen2022-07-12 22:41:04 -0400
committerKyle Keen2022-07-12 22:41:04 -0400
commita7ffb1a55f68949b963f3295b7293c7b147898a7 (patch)
tree756eb738a5b41060f0b9db593a7dfe943d66d6a2
parentced65ea7475961c7fbef2fe6ccb4b26a80b109d2 (diff)
downloadaur-a7ffb1a55f68949b963f3295b7293c7b147898a7.tar.gz
add mimalloc submodule
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD40
2 files changed, 33 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f222dc9206dd..c2d301fffc07 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Thu Dec 24 03:25:42 UTC 2020
+# Wed Jul 13 02:40:58 UTC 2022
pkgbase = openscad-git
pkgdesc = The programmers solid 3D CAD modeller
- pkgver = 20201217
+ pkgver = 20220626
pkgrel = 1
url = http://openscad.org/
arch = i686
@@ -25,6 +25,8 @@ pkgbase = openscad-git
conflicts = openscad
source = git+https://github.com/openscad/openscad.git
source = git+https://github.com/openscad/MCAD.git
+ source = git+https://github.com/microsoft/mimalloc.git
+ md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index eba1e6317803..491ac288dd42 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Torsten Wagner <tottiwagner@yahoo.de>
pkgname=openscad-git
-pkgver=20201217
+pkgver=20220626
pkgrel=1
pkgdesc="The programmers solid 3D CAD modeller"
arch=('i686' 'x86_64')
@@ -14,8 +14,9 @@ depends=('qt5-base' 'qscintilla-qt5' 'cgal' 'opencsg' 'boost-libs'
'qt5-multimedia' 'libzip' 'qt5-gamepad')
makedepends=('git' 'boost' 'eigen' 'imagemagick' 'ccache')
source=('git+https://github.com/openscad/openscad.git'
- 'git+https://github.com/openscad/MCAD.git')
-md5sums=('SKIP' 'SKIP')
+ 'git+https://github.com/openscad/MCAD.git'
+ 'git+https://github.com/microsoft/mimalloc.git')
+md5sums=('SKIP' 'SKIP' 'SKIP')
_gitname="openscad"
_gitbranch="master"
@@ -26,21 +27,38 @@ pkgver() {
#git describe --always --tags | sed 's/-/./g'
}
-build() {
+prepare() {
cd "$_gitname"
- # submodules seem kind of weird with the detached bare repo
+ # I am amazed that people are willing to avoid using sources(),
+ # and download stuff inside of build() instead.
+ # "git submodule update --init" is not okay.
+
cp -ar "$srcdir/MCAD" libraries
- rm -f libraries/MCAD/*.py
+ #rm -f libraries/MCAD/*.py
rm -rf libraries/MCAD/.git/
- qmake-qt5 PREFIX="/usr" VERSION="$pkgver" CONFIG+=experimental
+
+ cp -ar "$srcdir/mimalloc" submodules
+ rm -rf submodules/mimalloc/.git/
+
+ sed -i 's/ping files.openscad.org/ping archlinux.org/' resources/CMakeLists.txt
+ # todo: download the docs with sources() too
+}
+
+build() {
+ cd "$_gitname"
+ mkdir -p build
+ cd build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DEXPERIMENTAL=ON -DOFFLINE_DOCS=ON ..
make
- convert "icons/openscad.png" -resize 128x128\> "icons/openscad-128.png"
+ cd ..
+ convert "resources/icons/openscad.png" -resize 128x128\> "resources/icons/openscad-128.png"
}
package() {
- cd "$_gitname"
+ cd "$_gitname/build"
make INSTALL_ROOT="$pkgdir" install
- install -Dm644 "icons/openscad.desktop" "$pkgdir/usr/share/applications/openscad.desktop"
- install -Dm644 "icons/openscad-128.png" "$pkgdir/usr/share/pixmaps/openscad.png"
+ cd "$_gitname"
+ install -Dm644 "resources/icons/openscad.desktop" "$pkgdir/usr/share/applications/openscad.desktop"
+ install -Dm644 "resources/icons/openscad-128.png" "$pkgdir/usr/share/pixmaps/openscad.png"
}