summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorQuey-Liang Kao2016-04-06 12:07:30 +0800
committerQuey-Liang Kao2016-04-06 12:07:30 +0800
commitf52a0c133df48a1ceb06b8c5a72fe88b1858005f (patch)
treebeb1b677c4c22613b7028e45c50863e2d3dbc3a2
downloadaur-f52a0c133df48a1ceb06b8c5a72fe88b1858005f.tar.gz
first commit of this tool collection
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD35
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..604dafcd1ffa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = openscap
+ pkgdesc = Open Source Security Compliance Solution
+ pkgver = 1.2.8
+ pkgrel = 1
+ url = www.open-scap.org
+ arch = x86_64
+ license = GPL
+ depends = swig
+ depends = python
+ depends = acl
+ depends = libcap
+ depends = curl
+ depends = libgcrypt
+ depends = libxml2
+ depends = libxslt
+ depends = libldap
+ depends = pcre
+ depends = perl-xml-parser
+ depends = perl
+ depends = bzip2
+ depends = procps-ng
+ depends = gconf
+ source = https://github.com/OpenSCAP/openscap/releases/download/1.2.8/openscap-1.2.8.tar.gz
+ md5sums = d26a148d834635363ac8cdd707828302
+
+pkgname = openscap
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7bb65f1e0ec0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Quey-Liang Kao <s101062801@m101.nthu.edu.tw>
+
+pkgname=openscap
+pkgver=1.2.8
+pkgrel=1
+pkgdesc="Open Source Security Compliance Solution"
+
+# i686 is theoretically bulitable, if anyone needs it
+arch=('x86_64')
+url="www.open-scap.org"
+license=('GPL')
+
+# The official site suggested the dependencies in terms of Fedora's rpm.
+# Some of the corresponding packages in Arch remain unclear, which are listed
+# here for now.
+# packege missing: libselinux-devel, perl-XML-XPath
+depends=('swig' 'python' 'acl' 'libcap' 'curl' 'libgcrypt' 'libxml2' 'libxslt'
+ 'libldap' 'pcre' 'perl-xml-parser' 'perl' 'bzip2' 'procps-ng' 'gconf')
+
+optdepends=()
+source=("https://github.com/OpenSCAP/openscap/releases/download/$pkgver/$pkgname-$pkgver.tar.gz")
+md5sums=('d26a148d834635363ac8cdd707828302')
+
+build() {
+ cd "$pkgname-$pkgver"
+ CPPFLAGS="-I/usr/include/python3.5m" ./configure --enable-probes-linux --disable-python --enable-python3 --prefix=/usr
+ make -j4
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+ mv $pkgdir/usr/libexec/* $pkgdir/usr/lib/$pkgname/
+ rm -fr $pkgdir/usr/libexec/
+}