summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Corley2015-06-08 11:42:03 +0100
committerMartin Corley2015-06-08 11:42:03 +0100
commitb50c941a5eb0379fe5f34de5c04a927ca24a67aa (patch)
tree304c5075bbd54632d38817358efff7ce7a8279a2
downloadaur-b50c941a5eb0379fe5f34de5c04a927ca24a67aa.tar.gz
Initial import
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD45
-rw-r--r--python2.patch171
3 files changed, 245 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..184c397a19b1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = opensesame
+ pkgdesc = A graphical, open-source experiment builder for the social sciences, with ability to deploy on Android
+ pkgver = 2.9.5
+ pkgrel = 1
+ url = http://www.cogsci.nl/software/opensesame
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = python2
+ depends = python2-pygame
+ depends = python2-numpy
+ depends = python2-pyqt4
+ depends = python2-qscintilla
+ depends = python2-qprogedit>=2.0.0
+ depends = python2-imaging
+ depends = python2-markdown
+ depends = faenza-icon-theme
+ depends = python2-yaml
+ optdepends = psychopy: PsychoPy backend
+ optdepends = python2-expyriment: Expyriment backend
+ optdepends = python2-pyserial: Serial/Parallel port communication
+ options = !emptydirs
+ source = opensesame-2.9.5::git://github.com/smathot/OpenSesame.git#tag=release/2.9.5
+ source = python2.patch
+ md5sums = SKIP
+ md5sums = b7238618028cffb2169c5b05a332e144
+
+pkgname = opensesame
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9773b22e53b0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Contributor: Martin Corley <Martin.Corley@ed.ac.uk>
+
+pkgname=opensesame
+pkgver=2.9.5
+pkgrel=1
+pkgdesc="A graphical, open-source experiment builder for the social sciences, with ability to deploy on Android"
+arch=(any)
+url="http://www.cogsci.nl/software/opensesame"
+license=(GPL)
+makedepends='git'
+# This is a fairly minimal set of dependencies
+depends=('python2' 'python2-pygame' 'python2-numpy' 'python2-pyqt4'
+'python2-qscintilla' 'python2-qprogedit>=2.0.0' 'python2-imaging'
+'python2-markdown' 'faenza-icon-theme' 'python2-yaml')
+optdepends=('psychopy: PsychoPy backend'
+'python2-expyriment: Expyriment backend'
+'python2-pyserial: Serial/Parallel port communication')
+
+options=(!emptydirs)
+#source=(http://files.cogsci.nl/software/opensesame/opensesame_${pkgver}-1.tar.g
+#python2.patch)
+source=("$pkgname-$pkgver"::'git://github.com/smathot/OpenSesame.git#tag=release/2.9.5'
+python2.patch)
+md5sums=('SKIP'
+ 'b7238618028cffb2169c5b05a332e144')
+
+fix_links() {
+ cd "$pkgdir/usr/share/opensesame/resources/theme/gnome/os-custom-icons/"
+ ln -s ../../default/os-custom-icons/16x16/ .
+ ln -s ../../default/os-custom-icons/24x24/ .
+ ln -s ../../default/os-custom-icons/32x32/ .
+}
+
+build() {
+ cd "${srcdir}"/${pkgname}-${pkgver}
+ patch -Np1 -i ../python2.patch
+}
+
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+# fix_links
+}
+
diff --git a/python2.patch b/python2.patch
new file mode 100644
index 000000000000..97eafe117a0c
--- /dev/null
+++ b/python2.patch
@@ -0,0 +1,171 @@
+diff -aur opensesame-2.9.1.orig/dev-scripts/architecture.py opensesame-2.9.1/dev-scripts/architecture.py
+--- opensesame-2.9.1.orig/dev-scripts/architecture.py 2014-11-18 09:59:01.040205947 +0000
++++ opensesame-2.9.1/dev-scripts/architecture.py 2014-11-18 10:01:47.026057991 +0000
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2
+ #-*- coding:utf-8 -*-
+
+ """
+@@ -18,7 +18,7 @@
+ along with OpenSesame. If not, see <http://www.gnu.org/licenses/>.
+ """
+
+-#!/usr/bin/env python
++#!/usr/bin/env python2
+ #-*- coding:utf-8 -*-
+
+ """
+diff -aur opensesame-2.9.1.orig/dev-scripts/check_ts.py opensesame-2.9.1/dev-scripts/check_ts.py
+--- opensesame-2.9.1.orig/dev-scripts/check_ts.py 2014-11-18 09:59:01.040205947 +0000
++++ opensesame-2.9.1/dev-scripts/check_ts.py 2014-11-18 10:01:47.029391307 +0000
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2
+ #-*- coding:utf-8 -*-
+
+ """
+diff -aur opensesame-2.9.1.orig/dev-scripts/docstruct.py opensesame-2.9.1/dev-scripts/docstruct.py
+--- opensesame-2.9.1.orig/dev-scripts/docstruct.py 2014-11-18 09:59:01.040205947 +0000
++++ opensesame-2.9.1/dev-scripts/docstruct.py 2014-11-18 10:01:47.039391256 +0000
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2
+ #-*- coding:utf-8 -*-
+
+ """
+diff -aur opensesame-2.9.1.orig/dev-scripts/extract_translatables.py opensesame-2.9.1/dev-scripts/extract_translatables.py
+--- opensesame-2.9.1.orig/dev-scripts/extract_translatables.py 2014-11-18 09:59:01.040205947 +0000
++++ opensesame-2.9.1/dev-scripts/extract_translatables.py 2014-11-18 10:01:47.039391256 +0000
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2
+ #-*- coding:utf-8 -*-
+
+ """
+diff -aur opensesame-2.9.1.orig/dev-scripts/item-help.py opensesame-2.9.1/dev-scripts/item-help.py
+--- opensesame-2.9.1.orig/dev-scripts/item-help.py 2014-11-18 09:59:01.040205947 +0000
++++ opensesame-2.9.1/dev-scripts/item-help.py 2014-11-18 10:01:47.042724572 +0000
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2
+ #-*- coding:utf-8 -*-
+
+ """
+diff -aur opensesame-2.9.1.orig/dev-scripts/update-hidden.py opensesame-2.9.1/dev-scripts/update-hidden.py
+--- opensesame-2.9.1.orig/dev-scripts/update-hidden.py 2014-11-18 09:59:01.040205947 +0000
++++ opensesame-2.9.1/dev-scripts/update-hidden.py 2014-11-18 10:01:47.042724572 +0000
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2
+ #-*- coding:utf-8 -*-
+
+ """
+diff -aur opensesame-2.9.1.orig/opensesame opensesame-2.9.1/opensesame
+--- opensesame-2.9.1.orig/opensesame 2014-11-18 09:59:01.126871838 +0000
++++ opensesame-2.9.1/opensesame 2014-11-18 10:01:47.649388124 +0000
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2
+ #-*- coding:utf-8 -*-
+
+ """
+diff -aur opensesame-2.9.1.orig/opensesameandroid.py opensesame-2.9.1/opensesameandroid.py
+--- opensesame-2.9.1.orig/opensesameandroid.py 2014-11-18 09:59:01.126871838 +0000
++++ opensesame-2.9.1/opensesameandroid.py 2014-11-18 10:01:47.662721389 +0000
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2
+ #-*- coding:utf-8 -*-
+
+ """
+diff -aur opensesame-2.9.1.orig/opensesamerun opensesame-2.9.1/opensesamerun
+--- opensesame-2.9.1.orig/opensesamerun 2014-11-18 09:59:01.126871838 +0000
++++ opensesame-2.9.1/opensesamerun 2014-11-18 10:01:47.662721389 +0000
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2
+ #-*- coding:utf-8 -*-
+
+ """
+diff -aur opensesame-2.9.1.orig/opensesame_unittest/backends.py opensesame-2.9.1/opensesame_unittest/backends.py
+--- opensesame-2.9.1.orig/opensesame_unittest/backends.py 2014-11-18 09:59:01.126871838 +0000
++++ opensesame-2.9.1/opensesame_unittest/backends.py 2014-11-18 10:01:47.656054757 +0000
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2
+ #-*- coding:utf-8 -*-
+
+ """
+diff -aur opensesame-2.9.1.orig/opensesame_unittest/parsing.py opensesame-2.9.1/opensesame_unittest/parsing.py
+--- opensesame-2.9.1.orig/opensesame_unittest/parsing.py 2014-11-18 09:59:01.126871838 +0000
++++ opensesame-2.9.1/opensesame_unittest/parsing.py 2014-11-18 10:01:47.656054757 +0000
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2
+ #-*- coding:utf-8 -*-
+
+ """
+diff -aur opensesame-2.9.1.orig/opensesame_unittest/syntax.py opensesame-2.9.1/opensesame_unittest/syntax.py
+--- opensesame-2.9.1.orig/opensesame_unittest/syntax.py 2014-11-18 09:59:01.126871838 +0000
++++ opensesame-2.9.1/opensesame_unittest/syntax.py 2014-11-18 10:01:47.659388072 +0000
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2
+ #-*- coding:utf-8 -*-
+
+ """
+diff -aur opensesame-2.9.1.orig/plugins/pp_io/parallelppdev.py opensesame-2.9.1/plugins/pp_io/parallelppdev.py
+--- opensesame-2.9.1.orig/plugins/pp_io/parallelppdev.py 2014-11-18 09:59:01.133538444 +0000
++++ opensesame-2.9.1/plugins/pp_io/parallelppdev.py 2014-11-18 10:01:47.816053934 +0000
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2
+ # parallel port access using the ppdev driver
+
+ import sys
+diff -aur opensesame-2.9.1.orig/setup-android.py opensesame-2.9.1/setup-android.py
+--- opensesame-2.9.1.orig/setup-android.py 2014-11-18 09:59:01.730199767 +0000
++++ opensesame-2.9.1/setup-android.py 2014-11-18 10:01:48.739382522 +0000
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2
+ #-*- coding:utf-8 -*-
+
+ """
+diff -aur opensesame-2.9.1.orig/setup-mac.py opensesame-2.9.1/setup-mac.py
+--- opensesame-2.9.1.orig/setup-mac.py 2014-11-18 09:59:01.730199767 +0000
++++ opensesame-2.9.1/setup-mac.py 2014-11-18 10:01:48.742715838 +0000
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2
+ #-*- coding:utf-8 -*-
+
+ """
+diff -aur opensesame-2.9.1.orig/setup.py opensesame-2.9.1/setup.py
+--- opensesame-2.9.1.orig/setup.py 2014-11-18 09:59:01.730199767 +0000
++++ opensesame-2.9.1/setup.py 2014-11-18 10:01:48.746049155 +0000
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2
+ #-*- coding:utf-8 -*-
+
+ """
+diff -aur opensesame-2.9.1.orig/setup_shared.py opensesame-2.9.1/setup_shared.py
+--- opensesame-2.9.1.orig/setup_shared.py 2014-11-18 09:59:01.733533071 +0000
++++ opensesame-2.9.1/setup_shared.py 2014-11-18 10:01:48.749382470 +0000
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2
+ #-*- coding:utf-8 -*-
+
+ """
+diff -aur opensesame-2.9.1.orig/setup-win32.py opensesame-2.9.1/setup-win32.py
+--- opensesame-2.9.1.orig/setup-win32.py 2014-11-18 09:59:01.730199767 +0000
++++ opensesame-2.9.1/setup-win32.py 2014-11-18 10:01:48.742715838 +0000
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2
+ #-*- coding:utf-8 -*-
+
+ """