summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJon Gjengset2015-10-27 12:08:05 -0400
committerJon Gjengset2015-10-27 12:08:21 -0400
commit243850c24a54848c25e73e6cce394cf07d449c72 (patch)
tree69a5d22185e9f4b4af3b44c59e598541e850662d
parent2acd10dba3fb5d94bff8c50f7b9e37f51f566bf0 (diff)
downloadaur-243850c24a54848c25e73e6cce394cf07d449c72.tar.gz
Fix xargs invocation
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rwxr-xr-xsgx-compile2
3 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1eed29845168..2332786b0405 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = opensgx-git
pkgdesc = an open platform for Intel SGX
pkgver = r31.62fb20f
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/sslab-gatech/opensgx/
arch = x86_64
license = MIT
@@ -21,7 +21,7 @@ pkgbase = opensgx-git
md5sums = 9ac0fa0ddae6d0e70f18992894bd1205
md5sums = e65b4d1335c29babacaa0d5dbcbffe3a
md5sums = 48523504a8c9c6b4fc9175d143d87bf1
- md5sums = 62865bda5775b6a7d633c10d10ec5415
+ md5sums = 2a5dd594a15d21ef549f3efe2b3ae406
pkgname = opensgx-git
diff --git a/PKGBUILD b/PKGBUILD
index dc7010d20366..44d814eba797 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Jon Gjengset <jon@thesquareplanet.com>
pkgname=opensgx-git
pkgver=r31.62fb20f
-pkgrel=1
+pkgrel=2
pkgdesc="an open platform for Intel SGX"
arch=('x86_64')
url="https://github.com/sslab-gatech/opensgx/"
@@ -27,7 +27,7 @@ md5sums=('SKIP'
'9ac0fa0ddae6d0e70f18992894bd1205'
'e65b4d1335c29babacaa0d5dbcbffe3a'
'48523504a8c9c6b4fc9175d143d87bf1'
- '62865bda5775b6a7d633c10d10ec5415')
+ '2a5dd594a15d21ef549f3efe2b3ae406')
pkgver() {
cd "$srcdir/$pkgname"
diff --git a/sgx-compile b/sgx-compile
index 138444d9dec4..76c3f3d3850e 100755
--- a/sgx-compile
+++ b/sgx-compile
@@ -44,5 +44,5 @@ done
sed -i -e '/O_TEXT_SEGMENTS/d' -e '/O_DATA_SEGMENTS/d' "$loader"
-find /usr/lib/sgx/ -type f -iname '*.o' -print0 | xargs -0 --replace '{}' cc -g -Wall -pedantic -Wno-unused-function -std=gnu1x -fno-stack-protector -fvisibility=hidden "-Wl,-T,$loader" '{}' "${args[@]}"
+find /usr/lib/sgx/ -type f -iname '*.o' -print0 | xargs -0 cc -g -Wall -pedantic -Wno-unused-function -std=gnu1x -fno-stack-protector -fvisibility=hidden "-Wl,-T,$loader" "${args[@]}"
rm "$loader"