summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJon Gjengset2015-10-27 11:34:54 -0400
committerJon Gjengset2015-10-27 11:34:54 -0400
commit2acd10dba3fb5d94bff8c50f7b9e37f51f566bf0 (patch)
tree844873ccaa68a4184ccdc2724b929fc08c5ec0e3
parent3b2bf8329a347a81140a813da5529ec0b4c695a4 (diff)
downloadaur-2acd10dba3fb5d94bff8c50f7b9e37f51f566bf0.tar.gz
Align with upstream; fix sgx-compile for weird file names
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
-rwxr-xr-xsgx-compile2
-rw-r--r--test-sh.patch6
4 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 417f65ca6eff..1eed29845168 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = opensgx-git
pkgdesc = an open platform for Intel SGX
- pkgver = r28.1b40acd
+ pkgver = r31.62fb20f
pkgrel = 1
url = https://github.com/sslab-gatech/opensgx/
arch = x86_64
@@ -20,8 +20,8 @@ pkgbase = opensgx-git
md5sums = e862b28b09581142af78369c6c65ce66
md5sums = 9ac0fa0ddae6d0e70f18992894bd1205
md5sums = e65b4d1335c29babacaa0d5dbcbffe3a
- md5sums = 26415403a05ac7da09e5fc4408328c5b
- md5sums = d2e79e8bd225da3b50beab7f53f84b7f
+ md5sums = 48523504a8c9c6b4fc9175d143d87bf1
+ md5sums = 62865bda5775b6a7d633c10d10ec5415
pkgname = opensgx-git
diff --git a/PKGBUILD b/PKGBUILD
index 89bae9164c7e..dc7010d20366 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Jon Gjengset <jon@thesquareplanet.com>
pkgname=opensgx-git
-pkgver=r28.1b40acd
+pkgver=r31.62fb20f
pkgrel=1
pkgdesc="an open platform for Intel SGX"
arch=('x86_64')
@@ -26,8 +26,8 @@ md5sums=('SKIP'
'e862b28b09581142af78369c6c65ce66'
'9ac0fa0ddae6d0e70f18992894bd1205'
'e65b4d1335c29babacaa0d5dbcbffe3a'
- '26415403a05ac7da09e5fc4408328c5b'
- 'd2e79e8bd225da3b50beab7f53f84b7f')
+ '48523504a8c9c6b4fc9175d143d87bf1'
+ '62865bda5775b6a7d633c10d10ec5415')
pkgver() {
cd "$srcdir/$pkgname"
diff --git a/sgx-compile b/sgx-compile
index 77e69987d33f..138444d9dec4 100755
--- a/sgx-compile
+++ b/sgx-compile
@@ -44,5 +44,5 @@ done
sed -i -e '/O_TEXT_SEGMENTS/d' -e '/O_DATA_SEGMENTS/d' "$loader"
-cc -g -Wall -pedantic -Wno-unused-function -std=gnu1x -fno-stack-protector -fvisibility=hidden "-Wl,-T,$loader" $(find /usr/lib/sgx/ -type f -iname '*.o') "${args[@]}"
+find /usr/lib/sgx/ -type f -iname '*.o' -print0 | xargs -0 --replace '{}' cc -g -Wall -pedantic -Wno-unused-function -std=gnu1x -fno-stack-protector -fvisibility=hidden "-Wl,-T,$loader" '{}' "${args[@]}"
rm "$loader"
diff --git a/test-sh.patch b/test-sh.patch
index 3d52525400c3..0f6a6d71cad1 100644
--- a/test-sh.patch
+++ b/test-sh.patch
@@ -1,13 +1,13 @@
diff --git a/user/test.sh b/user/test.sh
-index 5225ca2..4639671 100755
+index c25b83d..19def4e 100755
--- a/user/test.sh
+++ b/user/test.sh
@@ -1,7 +1,7 @@
#!/bin/bash
--SGX=$(dirname "$0")/../sgx
+-SGX=$(dirname "$0")/../opensgx
-PYTHON=python
-+SGX=sgx
++SGX=opensgx
+PYTHON=python2
print_usage() {