summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosh Gwosdz2021-03-27 16:12:14 +0100
committerJosh Gwosdz2021-03-27 16:12:14 +0100
commit889ec7a908e8b0e343fa8507468a6228a4c84b6e (patch)
tree42d4fafd7f89a61efd0aad6ada89a8d1047a20b4
parente09b0762416ed4548c59d315cec0572cb03a58a5 (diff)
downloadaur-889ec7a908e8b0e343fa8507468a6228a4c84b6e.tar.gz
simplify makefile for dev workflow
-rw-r--r--Makefile15
1 files changed, 6 insertions, 9 deletions
diff --git a/Makefile b/Makefile
index e35a38f197d4..d7b0eed56097 100644
--- a/Makefile
+++ b/Makefile
@@ -1,14 +1,11 @@
-all: | update-pkgsums update-srcinfo
-.PHONY: all
-
-update-srcinfo:
+update:
+ updpkgsums
makepkg --printsrcinfo > .SRCINFO
-.PHONY: update-srcinfo
+.PHONY: update
-update-pkgsums:
- rm -f *.tar.gz{,part}
- updpkgsums
-.PHONY: update-pkgsums
+install:
+ makepkg -si
+.PHONY: update
compare-versions:
# https://github.com/erdii/toolbox/blob/main/cmd/aur-compare-oc-versions/main.go