summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCedric Girard2013-09-20 00:22:22 +0200
committerCedric Girard2013-09-20 00:22:22 +0200
commit7a7c1b2c8e16d8a44f2e42e1f62b3868ba548d8d (patch)
treecbac0bebef93e5f04a9e96b25ab9f24bc352b55f
downloadaur-7a7c1b2c8e16d8a44f2e42e1f62b3868ba548d8d.tar.gz
new openshot-bzr PKGBUILD
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD30
-rw-r--r--openshot.install11
3 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..40b9b1e9e625
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+pkgbase = openshot-bzr
+ pkgdesc = an open-source, non-linear video editor for Linux based on MLT framework
+ pkgver = 741
+ pkgrel = 1
+ url = http://www.openshotvideo.com/
+ install = openshot.install
+ arch = any
+ license = GPL
+ makedepends = bzr
+ depends = mlt-python-bindings
+ depends = pygoocanvas
+ depends = sdl
+ depends = librsvg
+ depends = mplayer
+ depends = pyxdg
+ depends = pygtk
+ depends = python2-httplib2
+ depends = python-imaging
+ optdepends = dvgrab: for IEEE digital sources
+ optdepends = libquicktime
+ optdepends = libavc1394
+ optdepends = faac
+ optdepends = jack
+ optdepends = jack-rack
+ optdepends = ladspa
+ conflicts = openshot
+ source = bzr+lp:openshot
+ md5sums = SKIP
+
+pkgname = openshot-bzr
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..02ec4fb8b4e7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Cedric Girard <girard.cedric@gmail.com>
+# Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Contributor: Asa Marco <marcoasa90[at]gmail[.]com>
+
+pkgname=openshot-bzr
+pkgver=741
+pkgrel=1
+pkgdesc="an open-source, non-linear video editor for Linux based on MLT framework"
+arch=('any')
+url="http://www.openshotvideo.com/"
+license=('GPL')
+conflicts=(openshot)
+depends=('mlt-python-bindings' 'pygoocanvas' 'sdl' 'librsvg' 'mplayer'
+ 'pyxdg' 'pygtk' 'python2-httplib2' 'python-imaging')
+makedepends=('bzr')
+optdepends=('dvgrab: for IEEE digital sources'
+ 'libquicktime' 'libavc1394' 'faac' 'jack' 'jack-rack' 'ladspa')
+install=openshot.install
+source=(bzr+lp:openshot)
+md5sums=('SKIP')
+
+pkgver() {
+ cd openshot
+ bzr revno
+}
+
+package() {
+ cd $srcdir/openshot
+ python2 setup.py install --root=$pkgdir/ --optimize=1
+}
diff --git a/openshot.install b/openshot.install
new file mode 100644
index 000000000000..660593cf5668
--- /dev/null
+++ b/openshot.install
@@ -0,0 +1,11 @@
+post_install() {
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}