summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2018-12-04 16:39:16 +0000
committerDaniel Bermond2018-12-04 16:43:52 +0000
commitb48b7ad5899b6b66cbf0a0d506e5a944b6ccfffc (patch)
tree5411f0603a9bb5937b9c991a83b2b599d36b0f0f
parent3ac21eec9e82b7300571d5d7514887235084b6dc (diff)
downloadaur-b48b7ad5899b6b66cbf0a0d506e5a944b6ccfffc.tar.gz
Use https url. Fix license. Dependencies update. Cosmetic changes.
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD28
2 files changed, 22 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 470d03135b51..8c89c39d7c27 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,11 @@
-# Generated by mksrcinfo v8
-# Mon Jul 24 01:17:54 UTC 2017
pkgbase = openshot-bzr
pkgdesc = An open-source, non-linear video editor for Linux based on MLT framework (bzr version)
- pkgver = 2.3.4.r825
- pkgrel = 1
+ pkgver = 2.4.1.r911
+ pkgrel = 2
epoch = 1
- url = http://www.openshot.org/
+ url = https://www.openshot.org/
arch = any
- license = GPL
+ license = GPL3
makedepends = bzr
makedepends = python-setuptools
depends = mlt-python-bindings
@@ -24,7 +22,7 @@ pkgbase = openshot-bzr
depends = vid.stab
depends = qt5-svg
depends = sdl_image
- depends = libopenshot
+ depends = libopenshot-git
depends = python-pyzmq
depends = qt5-webkit
depends = python-setuptools
@@ -34,7 +32,6 @@ pkgbase = openshot-bzr
optdepends = libavc1394
optdepends = faac
optdepends = jack
- optdepends = jack-rack
provides = openshot
conflicts = openshot
source = openshot-bzr::bzr+lp:openshot/2.0
diff --git a/PKGBUILD b/PKGBUILD
index 8c06aebaab06..6a29948e2744 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,24 @@
-# Maintainer : Daniel Bermond < yahoo-com: danielbermond >
+# Maintainer : Daniel Bermond < gmail-com: danielbermond >
# Contributor: Cedric Girard <girard.cedric@gmail.com>
# Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
# Contributor: Asa Marco <marcoasa90[at]gmail[.]com>
pkgname=openshot-bzr
-pkgver=2.3.4.r825
-pkgrel=1
+pkgver=2.4.1.r911
+pkgrel=2
epoch=1
pkgdesc='An open-source, non-linear video editor for Linux based on MLT framework (bzr version)'
arch=('any')
-url='http://www.openshot.org/'
-license=('GPL')
+url='https://www.openshot.org/'
+license=('GPL3')
depends=('mlt-python-bindings' 'sdl' 'librsvg' 'mplayer'
'pyxdg' 'python-pyqt5' 'python-httplib2' 'python-pillow' 'dvgrab'
'ladspa' 'sox' 'vid.stab' 'qt5-svg' 'sdl_image'
- 'libopenshot' 'python-pyzmq' 'qt5-webkit' 'python-setuptools'
+ 'libopenshot-git' 'python-pyzmq' 'qt5-webkit' 'python-setuptools'
'python-requests')
makedepends=('bzr' 'python-setuptools')
optdepends=('frei0r-plugins: effects'
- 'libquicktime' 'libavc1394' 'faac' 'jack' 'jack-rack')
+ 'libquicktime' 'libavc1394' 'faac' 'jack')
provides=('openshot')
conflicts=('openshot')
source=("$pkgname"::'bzr+lp:openshot/2.0')
@@ -26,12 +26,18 @@ sha256sums=('SKIP')
pkgver() {
cd "$pkgname"
- local _version="$(grep '^VERSION = .*' src/classes/info.py | sed 's/^VERSION = //;s/-.*$//;s/["]//g')"
- local _revision="$(bzr revno)"
+
+ local _version
+ local _revision
+
+ _version="$(grep '^VERSION = .*' src/classes/info.py | sed 's/^VERSION = //;s/-.*$//;s/["]//g')"
+ _revision="$(bzr revno)"
+
printf '%s.r%s' "$_version" "$_revision"
}
package() {
- cd "$pkgname"
- python setup.py install --root="$pkgdir" --optimize='1'
+ cd "$pkgname"
+
+ python setup.py install --root="$pkgdir" --optimize='1'
}