summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2018-12-04 16:20:52 +0000
committerDaniel Bermond2018-12-04 16:44:03 +0000
commit7618d5c20c14356a97499781aac8edb8f2143445 (patch)
tree680a934eabf3c8eaaa36348ff2c14b0465aa01dc
parentf8dff35edf306d122a7fd507cd31294b344d015a (diff)
downloadaur-7618d5c20c14356a97499781aac8edb8f2143445.tar.gz
Use https url. Do not rename the source clone. Dependencies update.
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD18
2 files changed, 14 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 97331275a056..ab2f8e783b90 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,8 @@
-# Generated by mksrcinfo v8
-# Mon Jul 24 01:19:04 UTC 2017
pkgbase = openshot-git
pkgdesc = An open-source, non-linear video editor for Linux based on MLT framework (git version)
- pkgver = 2.3.4.r3.gfe0f5f82
+ pkgver = 2.4.3.r83.gc9a0a8a9
pkgrel = 1
- url = http://www.openshot.org/
+ url = https://www.openshot.org/
arch = any
license = GPL3
makedepends = git
@@ -23,7 +21,7 @@ pkgbase = openshot-git
depends = vid.stab
depends = qt5-svg
depends = sdl_image
- depends = libopenshot
+ depends = libopenshot-git
depends = python-pyzmq
depends = qt5-webkit
depends = python-setuptools
@@ -33,10 +31,9 @@ pkgbase = openshot-git
optdepends = libavc1394
optdepends = faac
optdepends = jack
- optdepends = jack-rack
provides = openshot
conflicts = openshot
- source = openshot-git::git+https://github.com/OpenShot/openshot-qt.git
+ source = git+https://github.com/OpenShot/openshot-qt.git
sha256sums = SKIP
pkgname = openshot-git
diff --git a/PKGBUILD b/PKGBUILD
index 31c35ee05174..f89e53129eed 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,35 @@
-# Maintainer: Daniel Bermond < yahoo-com: danielbermond >
+# Maintainer: Daniel Bermond < gmail-com: danielbermond >
pkgname=openshot-git
-pkgver=2.3.4.r3.gfe0f5f82
+_srcname=openshot-qt
+pkgver=2.4.3.r83.gc9a0a8a9
pkgrel=1
pkgdesc='An open-source, non-linear video editor for Linux based on MLT framework (git version)'
arch=('any')
-url='http://www.openshot.org/'
+url='https://www.openshot.org/'
license=('GPL3')
depends=('mlt-python-bindings' 'sdl' 'librsvg' 'mplayer'
'pyxdg' 'python-pyqt5' 'python-httplib2' 'python-pillow' 'dvgrab'
'ladspa' 'sox' 'vid.stab' 'qt5-svg' 'sdl_image'
- 'libopenshot' 'python-pyzmq' 'qt5-webkit' 'python-setuptools'
+ 'libopenshot-git' 'python-pyzmq' 'qt5-webkit' 'python-setuptools'
'python-requests')
makedepends=('git' 'python-setuptools')
optdepends=('frei0r-plugins: effects'
- 'libquicktime' 'libavc1394' 'faac' 'jack' 'jack-rack')
+ 'libquicktime' 'libavc1394' 'faac' 'jack')
provides=('openshot')
conflicts=('openshot')
-source=("$pkgname"::'git+https://github.com/OpenShot/openshot-qt.git')
+source=('git+https://github.com/OpenShot/openshot-qt.git')
sha256sums=('SKIP')
pkgver() {
- cd "$pkgname"
+ cd "$_srcname"
# git, tags available
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//'
}
package() {
- cd "$pkgname"
+ cd "$_srcname"
+
python setup.py install --root="$pkgdir" --optimize='1'
}