summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSchala2015-06-08 20:50:29 -0700
committerSchala2015-06-08 20:50:29 -0700
commitea4033d15a9061bb1c8bb4541a1457ed4fd8e16e (patch)
tree36f07c246ca39a5b9695736dc7ed2e7211463a3d
downloadaur-ea4033d15a9061bb1c8bb4541a1457ed4fd8e16e.tar.gz
init
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD28
-rw-r--r--opensim-rake.sh2
3 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d7a8582e39e8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = opensim-rake
+ pkgdesc = Rake is meant to dump assets (textures, animations, notecards, scripts, etc...) from either Second Life™ or OpenSim to your local hard-drive.
+ pkgver = 20131012
+ pkgrel = 1
+ url = http://was.fm/opensim:rake
+ arch = any
+ license = GPLv3
+ depends = mono
+ source = http://was.fm/_media/opensim/rake.zip
+ source = opensim-rake.sh
+ md5sums = 53518eab4f5849f5bfaed4ba4149df5e
+ md5sums = 949e23cccf789411a842cb230282d2de
+
+pkgname = opensim-rake
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b55a4f435b01
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+pkgname=opensim-rake
+pkgver=20131012
+pkgrel=1
+pkgdesc="Rake is meant to dump assets (textures, animations, notecards, scripts, etc...) from either Second Life™ or OpenSim to your local hard-drive."
+arch=(any)
+url="http://was.fm/opensim:rake"
+license=("GPLv3")
+depends=(mono)
+source=("http://was.fm/_media/opensim/rake.zip"
+"opensim-rake.sh")
+md5sums=('53518eab4f5849f5bfaed4ba4149df5e'
+ '949e23cccf789411a842cb230282d2de')
+
+package() {
+ install -Dm755 opensim-rake.sh "$pkgdir/usr/bin/opensim-rake"
+ cd Rake
+ install -Dm644 Rake.exe "$pkgdir/usr/lib/opensim-rake/Rake.exe"
+ install -m644 Rake.exe.config "$pkgdir/usr/lib/opensim-rake/"
+ cd libomv
+ find . -name '*.dll' -exec install -Dm644 {} "$pkgdir/usr/lib/opensim-rake/libomv/"{} \;
+ find . -name '*.so' -exec install -m644 {} "$pkgdir/usr/lib/opensim-rake/libomv/" \;
+ cd openmetaverse_data
+ find . -type f -exec install -Dm644 {} "$pkgdir/usr/lib/opensim-rake/openmetaverse_data/"{} \;
+ cd "$pkgdir/usr/lib/opensim-rake/libomv"
+ rm openjpeg*.dll
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/opensim-rake.sh b/opensim-rake.sh
new file mode 100644
index 000000000000..862e1507d9bb
--- /dev/null
+++ b/opensim-rake.sh
@@ -0,0 +1,2 @@
+#!/bin/sh
+mono /usr/lib/opensim-rake/Rake.exe $@