summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGordonGR2015-06-08 14:12:05 +0300
committerGordonGR2015-06-08 14:12:05 +0300
commit34a770a04b04e157b5f77655fc0d48fbb950bf93 (patch)
tree0c5526a10dd42e4726e4e5ae1db1617e3aa617fd
downloadaur-34a770a04b04e157b5f77655fc0d48fbb950bf93.tar.gz
Initial commit
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD84
-rw-r--r--opensimulator-robust.service15
-rw-r--r--opensimulator-robust.sh4
-rw-r--r--opensimulator.install8
-rw-r--r--opensimulator.service15
-rw-r--r--opensimulator.sh4
7 files changed, 156 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4a9915c5d517
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = opensimulator
+ pkgdesc = A 3D application server used to create a virtual environment or world
+ pkgver = 0.8.1
+ pkgrel = 1
+ url = http://opensimulator.org/wiki/Main_Page
+ install = opensimulator.install
+ arch = i686
+ arch = x86_64
+ license = BSD
+ depends = mono
+ depends = sqlite
+ optdepends = mysql
+ backup = opt/opensimulator/bin/OpenSim.ini
+ source = http://opensimulator.org/dist/opensim-0.8.1-source.tar.gz
+ source = opensimulator.sh
+ source = opensimulator-robust.sh
+ source = opensimulator.service
+ source = opensimulator-robust.service
+ md5sums = 6f0c0bd26af88f1d21c525c837168a05
+ md5sums = 58270c537e91b85c1121aacc2ccb194e
+ md5sums = cb3b9d774a9973bb438c9052dbe77112
+ md5sums = c2686291b848bf584c9a05fbc6bac303
+ md5sums = 6201d8b4b9a498f2efc523e58a4abf75
+
+pkgname = opensimulator
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c8337d6894ca
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,84 @@
+# Contributor: Anton Bazhenov <anton.bazhenov at gmail>
+# Contributor: LTSmash <lord.ltsmash@gmail.com>
+# Contributor: Zauber Exonar <zauberexonar at gmail>
+# Contributor: Simon Peter Nicholls <simon.peter.nicholls at googlemail>
+# Maintainer: GordonGR <ntheo1979@gmail.com>
+
+pkgname=opensimulator
+pkgver=0.8.1
+pkgrel=1
+pkgdesc="A 3D application server used to create a virtual environment or world"
+arch=('i686' 'x86_64')
+url="http://opensimulator.org/wiki/Main_Page"
+license=('BSD')
+depends=('mono' 'sqlite')
+optdepends=('mysql')
+install=$pkgname.install
+source=("http://opensimulator.org/dist/opensim-${pkgver}-source.tar.gz"
+ "opensimulator.sh"
+ "opensimulator-robust.sh"
+ "opensimulator.service"
+ "opensimulator-robust.service")
+md5sums=('6f0c0bd26af88f1d21c525c837168a05'
+ '58270c537e91b85c1121aacc2ccb194e'
+ 'cb3b9d774a9973bb438c9052dbe77112'
+ 'c2686291b848bf584c9a05fbc6bac303'
+ '6201d8b4b9a498f2efc523e58a4abf75')
+backup=(opt/$pkgname/bin/OpenSim.ini)
+
+build() {
+cd "$srcdir"/opensim-$pkgver-source
+
+# we need Mono
+export MONO_SHARED_DIR="$srcdir"/.wabi
+mkdir -p $MONO_SHARED_DIR
+
+# build opensimulator using nant
+./runprebuild.sh
+xbuild
+}
+
+package() {
+cd "$srcdir"/opensim-$pkgver-source
+
+# delete unneeded and create log/ini files
+[[ `uname -m` = "i686" ]] && find bin -name "*x86_64.so" -delete
+
+# ensure log file already exists
+touch bin/OpenSim.log
+
+# create a default OpenSim.ini for installs
+sed 's/^\(\s*\)\; \(Include.*Standalone\.ini\)/\1\2/' bin/OpenSim.ini.example >bin/OpenSim.ini
+
+#copying Mono.Posix.dll so that OpenSimulator can use sockets, and by extension MySQL
+cp /usr/lib/mono/4.5/Mono.Posix.dll bin/Mono.Posix.dll
+
+# install
+install -d "$pkgdir"/opt/$pkgname/bin
+cp -r bin/* "$pkgdir"/opt/$pkgname/bin/
+mv README.md README.txt
+install -Dm644 {CONTRIBUTORS,README}.txt "$pkgdir"/opt/$pkgname
+
+# set permissions
+find "$pkgdir"/opt/$pkgname/bin -type d -exec chmod 755 {} +
+find "$pkgdir"/opt/$pkgname/bin -type f -exec chmod 644 {} +
+find "$pkgdir"/opt/$pkgname/bin -name "*.exe" -exec chmod 755 {} +
+find "$pkgdir"/opt/$pkgname/bin -name "*.ini" -exec chmod 666 {} +
+find "$pkgdir"/opt/$pkgname/bin -name "*.xml" -exec chmod 666 {} +
+chmod 777 "$pkgdir"/opt/$pkgname/bin/{,*/}
+chmod 755 "$pkgdir"/opt/$pkgname/bin/opensim-ode.sh
+chmod 666 "$pkgdir"/opt/$pkgname/bin/OpenSim.log
+
+# install scripts, service and license files
+install -m755 -D ../$pkgname.sh "$pkgdir"/usr/bin/$pkgname
+install -m755 -D ../opensimulator-robust.sh "$pkgdir"/usr/bin/opensimulator-robust
+install -Dm644 "$srcdir/opensimulator.service" "$pkgdir/usr/lib/systemd/system/opensimulator@.service"
+install -Dm644 "$srcdir/opensimulator-robust.service" "$pkgdir/usr/lib/systemd/system/opensimulator-robust@.service"
+install -m644 -D LICENSE.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+
+# remove *.dylib files (thanks to Schala)
+cd "$pkgdir"/opt/$pkgname/bin
+rm -f libopenjpeg-dotnet-2-1.5.0-dotnet-1.dylib
+rm -f lib32/libBulletSim.dyliblib64/libode.dylib
+rm -rf lib64/{libopenjpeg-dotnet.dylib,libsqlite3.dylib}
+}
diff --git a/opensimulator-robust.service b/opensimulator-robust.service
new file mode 100644
index 000000000000..6b9dcbd2075c
--- /dev/null
+++ b/opensimulator-robust.service
@@ -0,0 +1,15 @@
+[Unit]
+Description=Opensimulator-Robust
+After=local-fs.target network.target
+
+[Service]
+Type=simple
+ExecStart=/usr/bin/opensimulator-robust
+ExecReload=/bin/kill -HUP $MAINPID
+KillMode=process
+Restart=always
+User=%I
+
+[Install]
+WantedBy=multi-user.target
+
diff --git a/opensimulator-robust.sh b/opensimulator-robust.sh
new file mode 100644
index 000000000000..52d834098a68
--- /dev/null
+++ b/opensimulator-robust.sh
@@ -0,0 +1,4 @@
+#!/bin/sh
+
+cd /opt/opensimulator/bin
+mono Robust.exe
diff --git a/opensimulator.install b/opensimulator.install
new file mode 100644
index 000000000000..d4514505d983
--- /dev/null
+++ b/opensimulator.install
@@ -0,0 +1,8 @@
+post_remove() {
+ echo -e "\n >>> All files created after installation are in the /opt/opensimulator."
+ echo -e " >>> If you want, you may delete them manually."
+}
+
+post_install() {
+ echo -e "\n >>> The example OpenSim configuration is set up on initial install, modified to use a quick start standalone architecture."
+}
diff --git a/opensimulator.service b/opensimulator.service
new file mode 100644
index 000000000000..2e6f90881a4e
--- /dev/null
+++ b/opensimulator.service
@@ -0,0 +1,15 @@
+[Unit]
+Description=Opensimulator
+After=local-fs.target network.target
+
+[Service]
+Type=simple
+ExecStart=/usr/bin/opensimulator
+ExecReload=/bin/kill -HUP $MAINPID
+KillMode=process
+Restart=always
+User=%I
+
+[Install]
+WantedBy=multi-user.target
+
diff --git a/opensimulator.sh b/opensimulator.sh
new file mode 100644
index 000000000000..4f1756767ce2
--- /dev/null
+++ b/opensimulator.sh
@@ -0,0 +1,4 @@
+#!/bin/sh
+
+cd /opt/opensimulator/bin
+mono OpenSim.exe