summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2022-03-22 16:53:12 -0500
committerCarlos Aznarán Laos2022-03-22 16:53:12 -0500
commit60f48611e754fcb74060e04f4d6edd1351865058 (patch)
treef005da87fd5feef3d5d2c38b08702fca3a03b947
parent028b3a3bfff79b0e0ebb023c893db1859695d56d (diff)
downloadaur-60f48611e754fcb74060e04f4d6edd1351865058.tar.gz
Bump version to 0.9.2.1
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD106
2 files changed, 56 insertions, 57 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 87261e7380ed..93fd02046521 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = opensimulator
pkgdesc = A 3D application server used to create a virtual environment or world
- pkgver = 0.9.1.1
+ pkgver = 0.9.2.1
pkgrel = 1
url = http://opensimulator.org/wiki/Main_Page
install = opensimulator.install
@@ -11,16 +11,15 @@ pkgbase = opensimulator
depends = sqlite
optdepends = mysql
backup = opt/opensimulator/bin/OpenSim.ini
- source = http://opensimulator.org/dist/opensim-0.9.1.1-source.tar.gz
+ source = http://opensimulator.org/dist/opensim-0.9.2.1-source.tar.gz
source = opensimulator.sh
source = opensimulator-robust.sh
source = opensimulator.service
source = opensimulator-robust.service
- md5sums = 7d9a4eed80206495760feda0ae3879c8
+ md5sums = f6a49b0bba8841456114346c92697cec
md5sums = 58270c537e91b85c1121aacc2ccb194e
md5sums = cb3b9d774a9973bb438c9052dbe77112
md5sums = c2686291b848bf584c9a05fbc6bac303
md5sums = 6201d8b4b9a498f2efc523e58a4abf75
pkgname = opensimulator
-
diff --git a/PKGBUILD b/PKGBUILD
index 1343eeb4f052..a61e7c1baa0d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,10 +2,10 @@
# Contributor: LTSmash <lord.ltsmash@gmail.com>
# Contributor: Zauber Exonar <zauberexonar at gmail>
# Contributor: Simon Peter Nicholls <simon.peter.nicholls at googlemail>
-# Maintainer: GordonGR <ntheo1979@gmail.com>
+# Contributor: GordonGR <ntheo1979@gmail.com>
pkgname=opensimulator
-pkgver=0.9.1.1
+pkgver=0.9.2.1
pkgrel=1
pkgdesc="A 3D application server used to create a virtual environment or world"
arch=('i686' 'x86_64')
@@ -15,70 +15,70 @@ depends=('mono' 'sqlite')
optdepends=('mysql')
install=$pkgname.install
source=("http://opensimulator.org/dist/opensim-${pkgver}-source.tar.gz"
- "opensimulator.sh"
- "opensimulator-robust.sh"
- "opensimulator.service"
- "opensimulator-robust.service")
+ "opensimulator.sh"
+ "opensimulator-robust.sh"
+ "opensimulator.service"
+ "opensimulator-robust.service")
backup=(opt/$pkgname/bin/OpenSim.ini)
-md5sums=('7d9a4eed80206495760feda0ae3879c8'
- '58270c537e91b85c1121aacc2ccb194e'
- 'cb3b9d774a9973bb438c9052dbe77112'
- 'c2686291b848bf584c9a05fbc6bac303'
- '6201d8b4b9a498f2efc523e58a4abf75')
+md5sums=('f6a49b0bba8841456114346c92697cec'
+ '58270c537e91b85c1121aacc2ccb194e'
+ 'cb3b9d774a9973bb438c9052dbe77112'
+ 'c2686291b848bf584c9a05fbc6bac303'
+ '6201d8b4b9a498f2efc523e58a4abf75')
build() {
-cd "$srcdir"/opensim-$pkgver-source
+ cd "$srcdir"/opensim-$pkgver-source
-# we need Mono
-export MONO_SHARED_DIR="$srcdir"/.wabi
-mkdir -p $MONO_SHARED_DIR
+ # we need Mono
+ export MONO_SHARED_DIR="$srcdir"/.wabi
+ mkdir -p $MONO_SHARED_DIR
-# build opensimulator using nant
-./runprebuild.sh
-xbuild
+ # build opensimulator using nant
+ ./runprebuild.sh
+ xbuild
}
package() {
-cd "$srcdir"/opensim-$pkgver-source
+ cd "$srcdir"/opensim-$pkgver-source
-# delete unneeded and create log/ini files
-[[ `uname -m` = "i686" ]] && find bin -name "*x86_64.so" -delete
+ # delete unneeded and create log/ini files
+ [[ $(uname -m) = "i686" ]] && find bin -name "*x86_64.so" -delete
-# ensure log file already exists
-touch bin/OpenSim.log
+ # ensure log file already exists
+ touch bin/OpenSim.log
-# create a default OpenSim.ini for installs
-sed 's/^\(\s*\)\; \(Include.*Standalone\.ini\)/\1\2/' bin/OpenSim.ini.example >bin/OpenSim.ini
+ # create a default OpenSim.ini for installs
+ sed 's/^\(\s*\)\; \(Include.*Standalone\.ini\)/\1\2/' bin/OpenSim.ini.example >bin/OpenSim.ini
-#copying Mono.Posix.dll so that OpenSimulator can use sockets, and by extension MySQL
-cp /usr/lib/mono/4.5/Mono.Posix.dll bin/Mono.Posix.dll
+ #copying Mono.Posix.dll so that OpenSimulator can use sockets, and by extension MySQL
+ cp /usr/lib/mono/4.5/Mono.Posix.dll bin/Mono.Posix.dll
-# install
-install -d "$pkgdir"/opt/$pkgname/bin
-cp -r bin/* "$pkgdir"/opt/$pkgname/bin/
-mv README.md README.txt
-install -Dm644 {CONTRIBUTORS,README}.txt "$pkgdir"/opt/$pkgname
+ # install
+ install -d "$pkgdir"/opt/$pkgname/bin
+ cp -r bin/* "$pkgdir"/opt/$pkgname/bin/
+ mv README.md README.txt
+ install -Dm644 {CONTRIBUTORS,README}.txt "$pkgdir"/opt/$pkgname
-# set permissions
-find "$pkgdir"/opt/$pkgname/bin -type d -exec chmod 755 {} +
-find "$pkgdir"/opt/$pkgname/bin -type f -exec chmod 644 {} +
-find "$pkgdir"/opt/$pkgname/bin -name "*.exe" -exec chmod 755 {} +
-find "$pkgdir"/opt/$pkgname/bin -name "*.ini" -exec chmod 666 {} +
-find "$pkgdir"/opt/$pkgname/bin -name "*.xml" -exec chmod 666 {} +
-chmod 777 "$pkgdir"/opt/$pkgname/bin/{,*/}
-#chmod 755 "$pkgdir"/opt/$pkgname/bin/opensim-ode.sh
-chmod 666 "$pkgdir"/opt/$pkgname/bin/OpenSim.log
+ # set permissions
+ find "$pkgdir"/opt/$pkgname/bin -type d -exec chmod 755 {} +
+ find "$pkgdir"/opt/$pkgname/bin -type f -exec chmod 644 {} +
+ find "$pkgdir"/opt/$pkgname/bin -name "*.exe" -exec chmod 755 {} +
+ find "$pkgdir"/opt/$pkgname/bin -name "*.ini" -exec chmod 666 {} +
+ find "$pkgdir"/opt/$pkgname/bin -name "*.xml" -exec chmod 666 {} +
+ chmod 777 "$pkgdir"/opt/$pkgname/bin/{,*/}
+ #chmod 755 "$pkgdir"/opt/$pkgname/bin/opensim-ode.sh
+ chmod 666 "$pkgdir"/opt/$pkgname/bin/OpenSim.log
-# install scripts, service and license files
-install -m755 -D ../$pkgname.sh "$pkgdir"/usr/bin/$pkgname
-install -m755 -D ../opensimulator-robust.sh "$pkgdir"/usr/bin/opensimulator-robust
-install -Dm644 "$srcdir/opensimulator.service" "$pkgdir/usr/lib/systemd/system/opensimulator@.service"
-install -Dm644 "$srcdir/opensimulator-robust.service" "$pkgdir/usr/lib/systemd/system/opensimulator-robust@.service"
-install -m644 -D LICENSE.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
-
-# remove *.dylib files (thanks to Schala)
-cd "$pkgdir"/opt/$pkgname/bin
-rm -f libopenjpeg-dotnet-2-1.5.0-dotnet-1.dylib
-rm -f lib32/libBulletSim.dyliblib64/libode.dylib
-rm -rf lib64/{libopenjpeg-dotnet.dylib,libsqlite3.dylib}
+ # install scripts, service and license files
+ install -m755 -D ../$pkgname.sh "$pkgdir"/usr/bin/$pkgname
+ install -m755 -D ../opensimulator-robust.sh "$pkgdir"/usr/bin/opensimulator-robust
+ install -Dm644 "$srcdir/opensimulator.service" "$pkgdir/usr/lib/systemd/system/opensimulator@.service"
+ install -Dm644 "$srcdir/opensimulator-robust.service" "$pkgdir/usr/lib/systemd/system/opensimulator-robust@.service"
+ install -m644 -D LICENSE.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+
+ # remove *.dylib files (thanks to Schala)
+ cd "$pkgdir"/opt/$pkgname/bin
+ rm -f libopenjpeg-dotnet-2-1.5.0-dotnet-1.dylib
+ rm -f lib32/libBulletSim.dyliblib64/libode.dylib
+ rm -rf lib64/{libopenjpeg-dotnet.dylib,libsqlite3.dylib}
}