summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGordonGR2015-06-08 14:12:34 +0300
committerGordonGR2015-06-08 14:12:34 +0300
commite493b313dfd182f98e167dfc3863a6b07f91ae1f (patch)
treecaf1c53e1d955e84f81a2ca7cd9c136a51422b75
downloadaur-e493b313dfd182f98e167dfc3863a6b07f91ae1f.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD44
-rw-r--r--opensimulator-osgrid.install4
-rw-r--r--osgrid.sh4
4 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c563619b118a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = opensimulator-osgrid
+ pkgdesc = OSGrid's distribution of OpenSimulator, preconfigured to connect with OSGrid
+ pkgver = 20150523.v0.8.2.abb3bb6
+ pkgrel = 1
+ url = http://www.osgrid.org
+ install = opensimulator-osgrid.install
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = unzip
+ depends = mono
+ depends = sqlite
+ backup = opt/opensimulator-osgrid/bin/OpenSim.ini
+ backup = opt/opensimulator-osgrid/bin/config-include/GridCommon.ini
+ source = http://danbanner.onikenkon.com/osgrid//osgrid-opensim-05232015.v0.8.2.abb3bb6.zip
+ source = osgrid.sh
+ md5sums = 6d9be12328d73be1bc8f1dbd6394d26d
+ md5sums = 8ad5aab5c434aef00d12b08343a5da5a
+
+pkgname = opensimulator-osgrid
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..42e402542137
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Contributor: Anton Bazhenov <anton.bazhenov at gmail>
+# Contributor: LTSmash <lord.ltsmash@gmail.com>
+# Contributor: Zauber Exonar <zauberexonar at gmail>
+# Maintainer: GordonGR <ntheo1979@gmail.com>
+
+pkgname=opensimulator-osgrid
+pkgver=20150523.v0.8.2.abb3bb6
+_realpkgver=05232015.v0.8.2.abb3bb6
+
+pkgrel=1
+pkgdesc="OSGrid's distribution of OpenSimulator, preconfigured to connect with OSGrid"
+arch=('i686' 'x86_64')
+url="http://www.osgrid.org"
+license=('BSD')
+depends=('mono' 'sqlite')
+makedepends=('unzip')
+install=$pkgname.install
+backup=('opt/opensimulator-osgrid/bin/OpenSim.ini'
+ 'opt/opensimulator-osgrid/bin/config-include/GridCommon.ini')
+source=("http://danbanner.onikenkon.com/osgrid//osgrid-opensim-${_realpkgver}.zip" \
+ "osgrid.sh")
+md5sums=('6d9be12328d73be1bc8f1dbd6394d26d'
+ '8ad5aab5c434aef00d12b08343a5da5a')
+
+package() {
+cd $srcdir/bin
+
+#copying Mono.Posix.dll so that OpenSimulator can use sockets, and by extension MySQL
+cp /usr/lib/mono/4.5/Mono.Posix.dll Mono.Posix.dll
+# install
+install -d $pkgdir/opt/$pkgname/bin
+cp -r ./* $pkgdir/opt/$pkgname/bin/
+# set permissions
+find $pkgdir/opt/$pkgname/bin -type d -exec chmod 755 {} +
+find $pkgdir/opt/$pkgname/bin -type f -exec chmod 644 {} +
+find $pkgdir/opt/$pkgname/bin -name "*.exe" -exec chmod 755 {} +
+find $pkgdir/opt/$pkgname/bin -name "*.ini" -exec chmod 666 {} +
+find $pkgdir/opt/$pkgname/bin -name "*.xml" -exec chmod 666 {} +
+chmod 777 $pkgdir/opt/$pkgname/bin/{,*/}
+chmod 755 $pkgdir/opt/$pkgname/bin/opensim-ode.sh
+# chmod 666 "$pkgdir"/opt/$pkgname/bin/OpenSim.log
+# install launch script
+install -m755 -D ../osgrid.sh $pkgdir/usr/bin/osgrid
+}
diff --git a/opensimulator-osgrid.install b/opensimulator-osgrid.install
new file mode 100644
index 000000000000..9191b192f73f
--- /dev/null
+++ b/opensimulator-osgrid.install
@@ -0,0 +1,4 @@
+post_remove() {
+ echo -e ">>> All files created after installation are in the /opt/opensimulator-osgrid."
+ echo -e ">>> If you want, you may delete them manually."
+}
diff --git a/osgrid.sh b/osgrid.sh
new file mode 100644
index 000000000000..ccc2aa876dfc
--- /dev/null
+++ b/osgrid.sh
@@ -0,0 +1,4 @@
+#!/bin/sh
+
+cd /opt/opensimulator-osgrid/bin
+mono OpenSim.exe