summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames P. Harvey2018-10-16 18:43:52 -0400
committerJames P. Harvey2018-10-16 18:43:52 -0400
commit9670ab65ef57b75f6d6d583095323b526cef7dea (patch)
tree65653ad6cdecbc069a2bd8c829070a2ef3d7736e
parent5d8b5884673185ecc079a53eff14817d24d606de (diff)
downloadaur-9670ab65ef57b75f6d6d583095323b526cef7dea.tar.gz
Depend on rdma-core instead of libibumad and rdma. Modernized PKGBUILD. Added some comments to opensm.{launch,service}
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD26
-rw-r--r--opensm.launch8
-rw-r--r--opensm.service1
4 files changed, 23 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bf20870e10c8..aae71fbaeab5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,20 @@
pkgbase = opensm
pkgdesc = OpenFabrics Alliance InfiniBand Subnet Manager and Administrator
pkgver = 3.3.21
- pkgrel = 1
+ pkgrel = 2
url = https://www.openfabrics.org/index.php/overview.html
arch = x86_64
arch = i686
license = GPL2
license = custom:"Open Fabrics Alliance BSD"
- depends = libibumad
- depends = rdma
+ depends = rdma-core
+ depends = bash
source = https://github.com/linux-rdma/opensm/archive/3.3.21.tar.gz
source = opensm.service
source = opensm.launch
- md5sums = 7149ad46987749ae80a00124dd1e3f9d
- md5sums = f1155dd8fb07ce56c427bceb7ce3fffb
- md5sums = 7cd151f96d46ba1bc651fce0e2b7e8dc
+ sha256sums = 50d024090dc083274bc840792a3b539ecee5ad37a42948f43e84068e42b89b48
+ sha256sums = a40c8a556cb170d84ffb49791fb82aabb21dc4afd22865e8f264a93c1f304788
+ sha256sums = 91cce7a6b652490ad2aa382a0be2ba078068f5a633f4a5f07f7e718f3c91cf53
pkgname = opensm
diff --git a/PKGBUILD b/PKGBUILD
index 2125f0c5f9d4..74d839561640 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,19 @@
-# Maintainer: James Harvey <jamespharvey20@gmail.com>
-# * OpenFabrics Alliance InfiniBand subnet manager (SM) and subnet administrator (SA)
-# * One subnet manager is required to run each InfiniBand subnet, before initializing InfiniBand hardware
-# * No Namcap warnings or errors
-# Up to date with fedora's opensm-3.3.17-5.fc23.src.rpm
+# Maintainer: James P. Harvey <jamespharvey20 at gmail dot com>
pkgname=opensm
pkgver=3.3.21
-pkgrel=1
+pkgrel=2
pkgdesc='OpenFabrics Alliance InfiniBand Subnet Manager and Administrator'
arch=('x86_64' 'i686')
url='https://www.openfabrics.org/index.php/overview.html'
license=('GPL2' 'custom:"Open Fabrics Alliance BSD"')
-depends=('libibumad' 'rdma')
-source=("https://github.com/linux-rdma/opensm/archive/${pkgver}.tar.gz"
+depends=('rdma-core' 'bash')
+source=("https://github.com/linux-rdma/${pkgname}/archive/${pkgver}.tar.gz"
'opensm.service'
'opensm.launch')
-md5sums=('7149ad46987749ae80a00124dd1e3f9d'
- 'f1155dd8fb07ce56c427bceb7ce3fffb'
- '7cd151f96d46ba1bc651fce0e2b7e8dc')
+sha256sums=('50d024090dc083274bc840792a3b539ecee5ad37a42948f43e84068e42b89b48'
+ 'a40c8a556cb170d84ffb49791fb82aabb21dc4afd22865e8f264a93c1f304788'
+ '91cce7a6b652490ad2aa382a0be2ba078068f5a633f4a5f07f7e718f3c91cf53')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
@@ -37,11 +33,9 @@ package() {
install -Dm644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
# Convert from init.d to systemd
- rm -rf ${pkgdir}/etc/init.d
- # If ${pkgdir}/etc is empty (it should be, since /etc/init.d/ was removed) remove it
- if ! [ "$(ls -A ${pkgdir}/etc)" ]; then
- rm -rf ${pkgdir}/etc/
- fi
+ rm -rf "${pkgdir}/etc/init.d"
+ # ${pkgdir}/etc should now be empty
+ rmdir "${pkgdir}/etc/" > /dev/null
install -Dm644 "${srcdir}/opensm.service" "${pkgdir}/usr/lib/systemd/system/opensm.service"
install -Dm755 "${srcdir}/opensm.launch" "${pkgdir}/usr/bin/opensm.launch"
diff --git a/opensm.launch b/opensm.launch
index 08f0b1f5ec2f..b0f4ce96e6d7 100644
--- a/opensm.launch
+++ b/opensm.launch
@@ -1,7 +1,11 @@
#!/bin/bash
+# There is a timing bug that intermittently causes signal 15 failures on start
+# Fedora's workaround is to use a separate script
# Copied from Fedora's opensm-3.3.17-4.fc22.x86_64.rpm
-# Modified to just launch opensm
-# Will come back to adding multiple OpenSM daemons running at once, which is what the rest of Fedora's version is for
+# Following Arch's philosophy of deviating from upstream as little as possible,
+# modified to just launch opensm.
+# If you need simultaneous multiple interfaces, instead check out the AUR package
+# opensm-systemd-multiple-interfaces
#
# Launch the necessary OpenSM daemons for systemd
diff --git a/opensm.service b/opensm.service
index edf2b9551273..2ceb7b0738f1 100644
--- a/opensm.service
+++ b/opensm.service
@@ -1,3 +1,4 @@
+# Upstream doesn't provide a systemd .service file
# Copied from Fedora's opensm-3.3.17-4.fc22.x86_64.rpm
# Modified to follow Arch layout