summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJean Lucas2019-10-19 01:06:26 -0400
committerJean Lucas2019-10-19 01:13:30 -0400
commit32e85b9bc7fb79f2423801681cbce309b954c1be (patch)
treeca11556daec191b0b2b4538c7f726a8f78949994
downloadaur-32e85b9bc7fb79f2423801681cbce309b954c1be.tar.gz
Initial commit
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD75
2 files changed, 98 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a4b48156e7b0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = opensmtpd-extras-git
+ pkgdesc = Additional queues, schedulers, and tables for OpenSMTPD (Git)
+ pkgver = 0+r604+36cc595
+ pkgrel = 1
+ url = https://github.com/OpenSMTPD/OpenSMTPD-extras
+ arch = i686
+ arch = x86_64
+ makedepends = git
+ makedepends = libevent
+ makedepends = python2
+ makedepends = postgresql-libs
+ makedepends = mariadb-libs
+ makedepends = hiredis
+ optdepends = libevent: for table-python support
+ optdepends = python2: for table-python support
+ optdepends = postgresql-libs: for table-postgres support
+ optdepends = mariadb-libs: for table-mysql support
+ optdepends = hiredis: for table-redis support
+ source = git+https://github.com/OpenSMTPD/OpenSMTPD-extras
+ sha512sums = SKIP
+
+pkgname = opensmtpd-extras-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d253479239d1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,75 @@
+# Maintainer: Jean Lucas <jean@4ray.co>
+
+pkgname=opensmtpd-extras-git
+_pkgname=OpenSMTPD-extras
+pkgver=0+r604+36cc595
+pkgrel=1
+pkgdesc='Additional queues, schedulers, and tables for OpenSMTPD (Git)'
+arch=(i686 x86_64)
+url=https://github.com/OpenSMTPD/OpenSMTPD-extras
+license=() # Unclear
+makedepends=(git libevent python2 postgresql-libs mariadb-libs hiredis)
+optdepends=(
+ 'libevent: for table-python support'
+ 'python2: for table-python support'
+ 'postgresql-libs: for table-postgres support'
+ 'mariadb-libs: for table-mysql support'
+ 'hiredis: for table-redis support'
+)
+source=(git+$url)
+sha512sums=('SKIP')
+
+pkgver() {
+ cd $_pkgname
+ echo 0+r$(git rev-list --count HEAD)+$(git rev-parse --short HEAD)
+}
+
+prepare() {
+ cd $_pkgname
+
+ ./bootstrap
+
+ # Python addons use Python 2
+ sed 's#python_type="python"#python_type="python2"#' -i configure
+
+ # Fix config folder location
+ sed 's#/mail#/smtpd#' -i extras/tables/table-sqlite/sqlite.conf
+}
+
+build() {
+ cd $_pkgname
+
+ ./configure \
+ --prefix=/usr \
+ --sbindir=/usr/bin \
+ --libexecdir=/usr/lib/smtpd \
+ --sysconfdir=/etc/smtpd \
+ --with-queue-null \
+ --with-queue-python \
+ --with-queue-ram \
+ --with-queue-stub \
+ --with-scheduler-python \
+ --with-scheduler-ram \
+ --with-scheduler-stub \
+ --with-table-ldap \
+ --with-table-mysql \
+ --with-table-passwd \
+ --with-table-postgres \
+ --with-table-python \
+ --with-table-redis \
+ --with-table-socketmap \
+ --with-table-sqlite \
+ --with-table-stub
+
+ make
+}
+
+check() {
+ cd $_pkgname
+ make -k check
+}
+
+package() {
+ cd $_pkgname
+ make DESTDIR="$pkgdir" install
+}