summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVyacheslav Konovalov2020-12-17 15:39:18 +0500
committerVyacheslav Konovalov2020-12-17 15:39:18 +0500
commit001f218f0ed574bd4edc83cd0198a05ace1f4804 (patch)
tree83ce3004321179cb7c269b24586796d5b90c1e69
parent72d604c564eb8e69e811ae9cfc3b60b912f7f551 (diff)
downloadaur-001f218f0ed574bd4edc83cd0198a05ace1f4804.tar.gz
Bump version to 1.3.0
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD17
2 files changed, 13 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 43ec1232354a..c59d962d1b04 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = opensnitch
- pkgdesc = GNU/Linux application firewall
- pkgver = 1.3.0_rc2
+ pkgdesc = GNU/Linux port of the Little Snitch application firewall
+ pkgver = 1.3.0
pkgrel = 1
- url = https://github.com/gustavo-iniguez-goya/opensnitch
+ url = https://github.com/evilsocket/opensnitch
arch = i686
arch = x86_64
arch = armv6h
@@ -22,8 +22,8 @@ pkgbase = opensnitch
optdepends = logrotate: for logfile rotation support
backup = etc/opensnitchd/default-config.json
backup = etc/opensnitchd/system-fw.json
- source = https://github.com/gustavo-iniguez-goya/opensnitch/archive/v1.3.0-rc.2.tar.gz
- sha256sums = 9a2fe0f7078631b6d6b347fde9125548fa924d6c3c2a38d4b2401175edc81fb9
+ source = https://github.com/evilsocket/opensnitch/archive/v1.3.0.tar.gz
+ sha512sums = fb540614f8ce6799ed1a9af561bcf302f3778e706f5913206ed978402ee65a5577b1a17c5c2ec1805998606f056c3513b87e997133d03985ffccf00bb52f1176
pkgname = opensnitch
diff --git a/PKGBUILD b/PKGBUILD
index f96f33b6fd5f..daee53001f85 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,27 @@
# Maintainer: Vyacheslav Konovalov <f4f7l1hvr@relay.firefox.com>
pkgname=opensnitch
-_pkgver=1.3.0-rc.2
-pkgver=1.3.0_rc2
+pkgver=1.3.0
pkgrel=1
-pkgdesc='GNU/Linux application firewall'
+pkgdesc='GNU/Linux port of the Little Snitch application firewall'
arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
-url='https://github.com/gustavo-iniguez-goya/opensnitch'
+url='https://github.com/evilsocket/opensnitch'
license=('GPL3')
makedepends=('go' 'python-setuptools' 'python-grpcio-tools')
depends=('libnetfilter_queue' 'libpcap' 'python-grpcio' 'python-protobuf'
'python-pyinotify' 'python-slugify' 'python-pyqt5')
optdepends=('logrotate: for logfile rotation support')
backup=('etc/opensnitchd/default-config.json' 'etc/opensnitchd/system-fw.json')
-source=("https://github.com/gustavo-iniguez-goya/opensnitch/archive/v$_pkgver.tar.gz")
-sha256sums=('9a2fe0f7078631b6d6b347fde9125548fa924d6c3c2a38d4b2401175edc81fb9')
+source=("$url/archive/v$pkgver.tar.gz")
+sha512sums=('fb540614f8ce6799ed1a9af561bcf302f3778e706f5913206ed978402ee65a5577b1a17c5c2ec1805998606f056c3513b87e997133d03985ffccf00bb52f1176')
prepare() {
- cd "$srcdir/opensnitch-$_pkgver"
+ cd "$srcdir/opensnitch-$pkgver"
sed -i 's|local/bin|bin|g' daemon/opensnitchd.service
}
build() {
- cd "$srcdir/opensnitch-$_pkgver"
+ cd "$srcdir/opensnitch-$pkgver"
export CGO_CPPFLAGS="${CPPFLAGS}"
export CGO_CFLAGS="${CFLAGS}"
export CGO_CXXFLAGS="${CXXFLAGS}"
@@ -36,7 +35,7 @@ build() {
}
package() {
- cd "$srcdir/opensnitch-$_pkgver"
+ cd "$srcdir/opensnitch-$pkgver"
install -Dm755 daemon/opensnitchd -t "$pkgdir/usr/bin"
install -Dm644 daemon/opensnitchd.service -t "$pkgdir/usr/lib/systemd/system"
install -dm755 "$pkgdir/etc/opensnitchd/rules"