summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEchizen Ryoma2022-04-09 09:05:51 +0800
committerEchizen Ryoma2022-04-09 09:05:51 +0800
commit2a410a1a3eae4c7574eb716dc11017a41f543483 (patch)
treef824e9752066df336c83a9a543c8c7b7f0db6cbb
parent02f0ea1d6175b34621f1cd9d6840c20aaed14702 (diff)
downloadaur-2a410a1a3eae4c7574eb716dc11017a41f543483.tar.gz
display IP's network name
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD15
2 files changed, 18 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c9ec340469d4..0810caac18f3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = opensnitch
pkgdesc = GNU/Linux port of the Little Snitch application firewall
pkgver = 1.5.0
- pkgrel = 6
+ pkgrel = 7
url = https://github.com/evilsocket/opensnitch
arch = i686
arch = x86_64
@@ -12,6 +12,7 @@ pkgbase = opensnitch
makedepends = go
makedepends = python-grpcio-tools
makedepends = python-setuptools
+ makedepends = python-pyasn
makedepends = qt5-tools
depends = libnetfilter_queue
depends = libpcap
@@ -20,9 +21,11 @@ pkgbase = opensnitch
depends = python-slugify
depends = python-pyqt5
depends = abseil-cpp
+ depends = python-pyinotify
+ depends = python-notify2
optdepends = logrotate: for logfile rotation support
optdepends = hicolor-icon-theme: for gui
- optdepends = python-pyinotify: for system notifications
+ optdepends = python-pyasn: display IP's network name
backup = etc/opensnitchd/default-config.json
backup = etc/opensnitchd/system-fw.json
source = opensnitch-1.5.0.tar.gz::https://github.com/evilsocket/opensnitch/archive/v1.5.0.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index c1b8971ba8aa..433b33470e6a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=opensnitch
pkgver=1.5.0
-pkgrel=6
+pkgrel=7
pkgdesc='GNU/Linux port of the Little Snitch application firewall'
arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
url='https://github.com/evilsocket/opensnitch'
@@ -16,17 +16,20 @@ depends=(
'python-slugify'
'python-pyqt5'
'abseil-cpp'
+ 'python-pyinotify'
+ 'python-notify2'
)
makedepends=(
'go'
'python-grpcio-tools'
'python-setuptools'
+ 'python-pyasn'
'qt5-tools'
)
optdepends=(
'logrotate: for logfile rotation support'
'hicolor-icon-theme: for gui'
- 'python-pyinotify: for system notifications'
+ "python-pyasn: display IP's network name"
)
backup=(
'etc/opensnitchd/default-config.json'
@@ -41,7 +44,15 @@ sha512sums=(
prepare() {
cd "$srcdir/opensnitch-$pkgver"
+ echo "patching daemon/opensnitchd.service"
sed -i 's|local/bin|bin|g' daemon/opensnitchd.service
+
+ python_dist_path=$(python3 -c 'import sysconfig; print(sysconfig.get_paths()["purelib"])')
+ echo "patching ui/bin/opensnitch-ui"
+ sed -i 's|/usr/lib/python3/dist-packages/|/usr/lib/python3.10/site-packages/|g' ui/bin/opensnitch-ui
+ echo "patching ui/opensnitch/utils.py"
+ sed -i "s|/usr/lib/python3/dist-packages/data/ipasn_20140513_v12.dat.gz|${python_dist_path}/pyasn/data/ipasn_20140513_v12.dat.gz|g" ui/opensnitch/utils.py
+ sed -i "s|/usr/lib/python3/dist-packages/data/asnames.json|${python_dist_path}/pyasn/data/asnames.json|g" ui/opensnitch/utils.py
}
build() {