summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEchizen Ryoma2021-09-11 07:05:04 +0800
committerEchizen Ryoma2021-09-11 07:05:04 +0800
commit962055a58d93d96cb1fd27c73ea17eedd50fc984 (patch)
tree713b61834d51b4f45d7d033d1fa270eec9f76922
parentbf02d8c0e8f06a2ffba9fff6afb48ab191817bc1 (diff)
downloadaur-962055a58d93d96cb1fd27c73ea17eedd50fc984.tar.gz
Fix PATH
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 82dd358005a4..e6a4757e8abb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = opensnitch
pkgdesc = GNU/Linux port of the Little Snitch application firewall
pkgver = 1.4.0
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/evilsocket/opensnitch
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 1e7c25fa1fe7..6b08f67c2fb9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=opensnitch
pkgver=1.4.0
-pkgrel=2
+pkgrel=3
pkgdesc='GNU/Linux port of the Little Snitch application firewall'
arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
url='https://github.com/evilsocket/opensnitch'
@@ -47,9 +47,13 @@ build() {
export CGO_LDFLAGS="${LDFLAGS}"
export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=mod"
- export PATH=${PATH}:$GOPATH/bin
+ export PATH="${GOPATH}/bin:${PATH}"
+
go install github.com/golang/protobuf/protoc-gen-go
go install google.golang.org/grpc/cmd/protoc-gen-go-grpc
+
+ echo "$(whereis protoc-gen-go)"
+ echo "$(whereis protoc-gen-go-grpc)"
pushd proto
make