summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVyacheslav Konovalov2020-12-05 08:34:35 +0500
committerVyacheslav Konovalov2020-12-05 08:34:35 +0500
commitb7b8cb284b5c3b4b6bcdd8460f0719bf8ee78e5f (patch)
tree118372b57d87923b7e6e6fb53e7b5e2e57148af5
downloadaur-b7b8cb284b5c3b4b6bcdd8460f0719bf8ee78e5f.tar.gz
Version 1.3.0-rc.2
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD49
2 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e01b7ec1d267
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+pkgbase = opensnitch
+ pkgdesc = GNU/Linux application firewall
+ pkgver = 1.3.0_rc2
+ pkgrel = 1
+ url = https://github.com/gustavo-iniguez-goya/opensnitch
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
+ license = GPL3
+ makedepends = git
+ makedepends = go
+ makedepends = python-setuptools
+ makedepends = python-grpcio-tools
+ depends = libnetfilter_queue
+ depends = libpcap
+ depends = python-grpcio
+ depends = python-protobuf
+ depends = python-pyinotify
+ depends = python-slugify
+ depends = python-pyqt5
+ optdepends = logrotate: for logfile rotation support
+ backup = etc/opensnitchd/default-config.json
+ backup = etc/opensnitchd/system-fw.json
+ source = https://github.com/gustavo-iniguez-goya/opensnitch/archive/v1.3.0-rc.2.tar.gz
+ sha256sums = 9a2fe0f7078631b6d6b347fde9125548fa924d6c3c2a38d4b2401175edc81fb9
+
+pkgname = opensnitch
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cb11f4e4d7df
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Vyacheslav Konovalov <f4f7l1hvr@relay.firefox.com>
+
+pkgname=opensnitch
+_pkgver=1.3.0-rc.2
+pkgver=1.3.0_rc2
+pkgrel=1
+pkgdesc='GNU/Linux application firewall'
+arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
+url='https://github.com/gustavo-iniguez-goya/opensnitch'
+license=('GPL3')
+makedepends=('git' 'go' 'python-setuptools' 'python-grpcio-tools')
+depends=('libnetfilter_queue' 'libpcap' 'python-grpcio' 'python-protobuf'
+ 'python-pyinotify' 'python-slugify' 'python-pyqt5')
+optdepends=('logrotate: for logfile rotation support')
+backup=('etc/opensnitchd/default-config.json' 'etc/opensnitchd/system-fw.json')
+source=("https://github.com/gustavo-iniguez-goya/opensnitch/archive/v$_pkgver.tar.gz")
+sha256sums=('9a2fe0f7078631b6d6b347fde9125548fa924d6c3c2a38d4b2401175edc81fb9')
+
+prepare() {
+ cd "$srcdir/opensnitch-$_pkgver"
+ sed -i 's|local/bin|bin|g' daemon/opensnitchd.service
+}
+
+build() {
+ cd "$srcdir/opensnitch-$_pkgver"
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS='-buildmode=pie -trimpath -ldflags=-linkmode=external'
+ make -C daemon
+ make -C proto
+
+ cd ui
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/opensnitch-$_pkgver"
+ install -Dm755 daemon/opensnitchd -t "$pkgdir/usr/bin"
+ install -Dm644 daemon/opensnitchd.service -t "$pkgdir/usr/lib/systemd/system"
+ install -dm755 "$pkgdir/etc/opensnitchd/rules"
+ install -Dm644 daemon/default-config.json -t "$pkgdir/etc/opensnitchd"
+ install -Dm644 daemon/system-fw.json -t "$pkgdir/etc/opensnitchd"
+ install -Dm644 debian/opensnitch.logrotate "$pkgdir/etc/logrotate.d/opensnitch"
+
+ cd ui
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+}