summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlsf2022-01-08 12:42:15 +0100
committerlsf2022-01-08 12:42:15 +0100
commit19ce18f5ebc436ad685b4c83ade3abec22a6ab16 (patch)
treecbddfc3a8806e3f97a31cdc79c42d3b986cc1df1
parent04635eaf0b81cbdc3a57806d340cf0ab8c4a45e6 (diff)
downloadaur-19ce18f5ebc436ad685b4c83ade3abec22a6ab16.tar.gz
add python-notify2 and python-pyasn dependencies; fix hardcoded pyasn db pathes
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 11 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 841fb740023e..f290fae0b6be 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = opensnitch-git
pkgdesc = A GNU/Linux port of the Little Snitch application firewall
- pkgver = 1.5.0.r28.7e5d809
- pkgrel = 1
+ pkgver = 1.5.0.r29.d264bb0
+ pkgrel = 2
url = https://github.com/evilsocket/opensnitch
install = opensnitch.install
arch = i686
@@ -24,6 +24,8 @@ pkgbase = opensnitch-git
depends = python-pyqt5
optdepends = logrotate: for logfile rotation support
optdepends = opensnitch-ebpf-module-git: eBPF process monitor method (non-hardened kernel only)
+ optdepends = python-notify2: desktop notifications
+ optdepends = python-pyasn: display network names
provides = opensnitch
conflicts = opensnitch
backup = etc/opensnitchd/default-config.json
diff --git a/PKGBUILD b/PKGBUILD
index 54d4efdd50d5..ead4dcde95a8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
# Contributor: lsf
# Contributor: Adam Hose <adis@blad.is>
pkgname=opensnitch-git
-pkgver=1.5.0.r28.7e5d809
-pkgrel=1
+pkgver=1.5.0.r29.d264bb0
+pkgrel=2
pkgdesc="A GNU/Linux port of the Little Snitch application firewall"
arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
url="https://github.com/evilsocket/opensnitch"
@@ -14,7 +14,9 @@ makedepends=('git' 'go' 'python-setuptools'
depends=('libnetfilter_queue' 'libpcap' 'python-grpcio' 'python-protobuf'
'python-pyinotify' 'python-slugify' 'python-pyqt5')
optdepends=('logrotate: for logfile rotation support'
- 'opensnitch-ebpf-module-git: eBPF process monitor method (non-hardened kernel only)')
+ 'opensnitch-ebpf-module-git: eBPF process monitor method (non-hardened kernel only)'
+ 'python-notify2: desktop notifications'
+ 'python-pyasn: display network names')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
backup=("etc/${pkgname%-git}d/default-config.json")
@@ -33,6 +35,8 @@ prepare() {
cd "$srcdir/${pkgname%-git}"
sed -i 's|local/bin|bin|g' "daemon/${pkgname%-git}d.service"
+ sed -i 's|/usr/lib/python3/dist-packages/data/|/usr/lib/python3.10/site-packages/pyasn/data/|g' ui/opensnitch/utils.py
+ sed -i 's|/usr/lib/python3/dist-packages/|/usr/lib/python3.10/site-packages/|g' ui/bin/opensnitch-ui
}
build() {