summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2020-12-13 08:48:01 -0700
committerMark Wagie2020-12-13 08:48:01 -0700
commit7ce1b2701bbb7c30ed03e7de38871f792a6c5937 (patch)
tree347d6b29aa8e8cd2ccc2fcb609f767ef1ccd4145
parent9e84025fb546335d0b356b1076d79337704407db (diff)
downloadaur-7ce1b2701bbb7c30ed03e7de38871f792a6c5937.tar.gz
switch back to evilsocket repo
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD86
-rw-r--r--opensnitch.install13
3 files changed, 58 insertions, 49 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0068bb29ff16..26dce8398332 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = opensnitch-git
- pkgdesc = A GNU/Linux application firewall
- pkgver = 1.2.0.r11.a517ebe
+ pkgdesc = A GNU/Linux port of the Little Snitch application firewall
+ pkgver = 1.3.0.rc.2.r19.b6cbc67
pkgrel = 1
- url = https://github.com/gustavo-iniguez-goya/opensnitch
+ url = https://github.com/evilsocket/opensnitch
install = opensnitch.install
arch = i686
arch = x86_64
@@ -25,7 +25,7 @@ pkgbase = opensnitch-git
provides = opensnitch
conflicts = opensnitch
backup = etc/opensnitchd/default-config.json
- source = git+https://github.com/gustavo-iniguez-goya/opensnitch.git
+ source = git+https://github.com/evilsocket/opensnitch.git
sha256sums = SKIP
pkgname = opensnitch-git
diff --git a/PKGBUILD b/PKGBUILD
index dd6413208ff8..59e163b722ec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,12 @@
-# Maintainer: lsf
-# Co-Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+# Contributor: lsf
# Contributor: Adam Hose <adis@blad.is>
-
pkgname=opensnitch-git
-pkgver=1.2.0.r11.a517ebe
+pkgver=1.3.0.rc.2.r19.b6cbc67
pkgrel=1
-pkgdesc="A GNU/Linux application firewall"
+pkgdesc="A GNU/Linux port of the Little Snitch application firewall"
arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
-url="https://github.com/gustavo-iniguez-goya/opensnitch"
+url="https://github.com/evilsocket/opensnitch"
license=('GPL3')
makedepends=('git' 'go' 'python-setuptools' 'python-grpcio-tools')
depends=('libnetfilter_queue' 'libpcap' 'python-grpcio' 'python-protobuf'
@@ -17,58 +16,59 @@ provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
backup=("etc/${pkgname%-git}d/default-config.json")
install="${pkgname%-git}.install"
-source=('git+https://github.com/gustavo-iniguez-goya/opensnitch.git')
+source=('git+https://github.com/evilsocket/opensnitch.git')
sha256sums=('SKIP')
pkgver() {
- cd "$srcdir/${pkgname%-git}"
- git describe --long | sed 's/^v//;s/\([^-]*-\)g/r\1/;s/-/./g'
+ cd "$srcdir/${pkgname%-git}"
+ git describe --long | sed 's/^v//;s/\([^-]*-\)g/r\1/;s/-/./g'
}
prepare() {
- export GOPATH="$srcdir/gopath"
- go clean -modcache
+ export GOPATH="$srcdir/gopath"
+ go clean -modcache
- cd "$srcdir/${pkgname%-git}"
- sed -i 's|local/bin|bin|g' "daemon/${pkgname%-git}d.service"
+ cd "$srcdir/${pkgname%-git}"
+ sed -i 's|local/bin|bin|g' "daemon/${pkgname%-git}d.service"
}
build() {
- cd "$srcdir/${pkgname%-git}"
- export CGO_CPPFLAGS="${CPPFLAGS}"
- export CGO_CFLAGS="${CFLAGS}"
- export CGO_CXXFLAGS="${CXXFLAGS}"
- export CGO_LDFLAGS="${LDFLAGS}"
- export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external"
- pushd daemon
- make
- popd
+ cd "$srcdir/${pkgname%-git}"
+
+ pushd daemon
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external"
+ make
+ popd
- # Clean mod cache for makepkg -C
- go clean -modcache
+ # Clean mod cache for makepkg -C
+ go clean -modcache
- pushd proto
- make
- popd
+ pushd proto
+ make
+ popd
- pushd ui
- python setup.py build
- popd
+ pushd ui
+ python setup.py build
+ popd
}
package() {
- cd "$srcdir/${pkgname%-git}"
- pushd ui
- export PYTHONHASHSEED=0
- python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
- popd
+ cd "$srcdir/${pkgname%-git}"
+ pushd ui
+ export PYTHONHASHSEED=0
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ popd
- install -Dm755 "daemon/${pkgname%-git}d" -t "$pkgdir/usr/bin"
- install -Dm644 "daemon/${pkgname%-git}d.service" -t \
- "$pkgdir/usr/lib/systemd/system"
- install -dm755 "$pkgdir/etc/${pkgname%-git}d/rules"
- install -Dm644 daemon/default-config.json -t "$pkgdir/etc/${pkgname%-git}d"
- install -Dm644 daemon/system-fw.json -t "$pkgdir/etc/${pkgname%-git}d"
- install -Dm644 "debian/${pkgname%-git}.logrotate" \
- "$pkgdir/etc/logrotate.d/${pkgname%-git}"
+ install -d "$pkgdir/etc/${pkgname%-git}d/rules"
+ install -Dm755 "daemon/${pkgname%-git}d" -t "$pkgdir/usr/bin"
+ install -Dm644 "daemon/${pkgname%-git}d.service" -t \
+ "$pkgdir/usr/lib/systemd/system"
+ install -Dm644 daemon/default-config.json -t "$pkgdir/etc/${pkgname%-git}d"
+ install -Dm644 daemon/system-fw.json -t "$pkgdir/etc/${pkgname%-git}d"
+ install -Dm644 "debian/${pkgname%-git}.logrotate" \
+ "$pkgdir/etc/logrotate.d/${pkgname%-git}"
}
diff --git a/opensnitch.install b/opensnitch.install
index f918711f0ee0..35f39b7406de 100644
--- a/opensnitch.install
+++ b/opensnitch.install
@@ -1,12 +1,21 @@
post_install() {
- echo "Enable opensnitchd as a systemd service:"
echo ""
+ echo "Enable opensnitchd as a systemd service:"
echo "systemctl enable --now opensnitchd"
+ echo ""
}
post_upgrade() {
- echo "Restart opensnitchd service:"
echo ""
+ echo "Restart opensnitchd service:"
echo "systemctl daemon reload"
echo "systemctl restart opensnitchd"
+ echo ""
+}
+
+post_remove() {
+ echo ""
+ echo "Optionally remove log file:"
+ echo "sudo rm /var/log/opensnitchd.log"
+ echo ""
}