summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorevs-ch2020-03-04 17:54:37 +0100
committerevs-ch2020-03-04 17:54:37 +0100
commit853ad2db491080d8641c95ee5fcc65619916b405 (patch)
tree5ab61f05234b3eff5dd36f696e3c52a851293ebc
parent803d9223a6d9b0f99ea4727a0498f5bbf22fa449 (diff)
downloadaur-853ad2db491080d8641c95ee5fcc65619916b405.tar.gz
switch to fork; thanks @Devastator
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
2 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index af36e4635020..00bad599fd51 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = opensnitch-git
pkgdesc = A GNU/Linux port of the Little Snitch application firewall.
- pkgver = r379.2b49871
+ pkgver = r514.db22e83
pkgrel = 1
- url = https://github.com/evilsocket/opensnitch
+ url = https://github.com/gustavo-iniguez-goya/opensnitch
arch = i686
arch = x86_64
license = GPL3
@@ -19,7 +19,7 @@ pkgbase = opensnitch-git
depends = python-libconfigparser
provides = opensnitch
conflicts = opensnitch
- source = git+https://github.com/evilsocket/opensnitch.git
+ source = git+https://github.com/gustavo-iniguez-goya/opensnitch.git
sha256sums = SKIP
pkgname = opensnitch-git
diff --git a/PKGBUILD b/PKGBUILD
index dca0eb0ee31e..fcd7ac20cce7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,11 +3,11 @@
# Contributor: Adam Hose <adis@blad.is>
pkgname=opensnitch-git
-pkgver=r379.2b49871
+pkgver=r514.db22e83
pkgrel=1
pkgdesc="A GNU/Linux port of the Little Snitch application firewall."
arch=('i686' 'x86_64')
-url="https://github.com/evilsocket/opensnitch"
+url="https://github.com/gustavo-iniguez-goya/opensnitch"
license=('GPL3')
makedepends=('git' 'dep' 'go-pie' 'python-setuptools')
depends=('libnetfilter_queue' 'libpcap' 'python-protobuf-compiler'
@@ -15,7 +15,7 @@ depends=('libnetfilter_queue' 'libpcap' 'python-protobuf-compiler'
'python-libconfigparser')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
-source=('git+https://github.com/evilsocket/opensnitch.git')
+source=('git+https://github.com/gustavo-iniguez-goya/opensnitch.git')
sha256sums=('SKIP')
pkgver() {
@@ -24,12 +24,12 @@ pkgver() {
}
prepare() {
- mkdir -p gopath/src/github.com/evilsocket
+ mkdir -p gopath/src/github.com/gustavo-iniguez-goya
ln -rTsf "$srcdir/${pkgname%-git}" \
- "gopath/src/github.com/evilsocket/${pkgname%-git}"
+ "gopath/src/github.com/gustavo-iniguez-goya/${pkgname%-git}"
export GOPATH="$srcdir"/gopath
- cd "gopath/src/github.com/evilsocket/${pkgname%-git}/daemon"
+ cd "gopath/src/github.com/gustavo-iniguez-goya/${pkgname%-git}/daemon"
dep ensure
cd "$srcdir/${pkgname%-git}"
@@ -39,7 +39,7 @@ prepare() {
build() {
export GOPATH="$srcdir"/gopath
- cd "gopath/src/github.com/evilsocket/${pkgname%-git}/daemon"
+ cd "gopath/src/github.com/gustavo-iniguez-goya/${pkgname%-git}/daemon"
go build \
-trimpath \
-ldflags "-extldflags $LDFLAGS" \